Upstream bug in wicd-cli, fix included.

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
White ninja
White ninja
Posts: 14
Joined: 03 Sep 2011, 21:15
Location: I am everywhere.

Upstream bug in wicd-cli, fix included.

Post#1 by TheDoctor » 21 Nov 2011, 02:44

Hi. While working with the wicd-cli utility (/usr/share/wicd/cli/ I ran across a bug in the option parser that prevents the utility from being used to configure encryption on a wireless network interface. Before the fix, the command wicd-cli --wireless --network=0 --network-property=enctype --set-to=wpa2 would result in the following Python traceback:
Traceback (most recent call last):
File "/usr/share/wicd/cli/", line 146, in <module>
options.network_property = option.network_property.lower()
NameError: name 'option' is not defined
The fix is trivial but crucial:

options.network_property = options.network_property.lower()

I've fixed it on one of my test boxen and it seems to do the job. You may wish to incorporate the single-character fix in v1.1 of Porteus.

User avatar
Moderator Team
Moderator Team
Posts: 5667
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland

Re: Upstream bug in wicd-cli, fix included.

Post#2 by fanthom » 21 Nov 2011, 09:40

it's too late for incorporating the fix in rc2 but i'll pay attention to do it for 1.1 final.

thanks a lot.
Please add [Solved] to your thread title if the solution was found.

Post Reply