Setting up locale

Arch based Porteus community project
Post Reply
M. Eerie
Black ninja
Black ninja
Posts: 90
Joined: 31 Aug 2017, 21:18
Distribution: APorteus BUDGIE x64

Setting up locale

Post#1 by M. Eerie » 04 Feb 2018, 15:27

I've tried to

Code: Select all

setup-locale
with no success. A module is built, but the language still is english.

How do I ???

:%)

(Also how can I save Numlock state?)

Thanks

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1443
Joined: 20 Mar 2012, 03:42
Distribution: 4.0-64bit all-DE+more
Location: australia
Contact:

Setting up locale

Post#2 by ncmprhnsbl » 04 Feb 2018, 23:27

yeah, this function is not currently implemented ie:

Code: Select all

$pserver/$arch/current/export/locales
does not exist..
i have the exported locales(stripped from base modules).
i'll ask brokenman about uploading them to the server...
M. Eerie wrote:
04 Feb 2018, 15:27
how can I save Numlock state?
do:

Code: Select all

root #rc-update add numlock default
root #/etc/init.d/numlock start
then save /etc/runlevels/default/numlock (which is a symlink) to a module..
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

M. Eerie
Black ninja
Black ninja
Posts: 90
Joined: 31 Aug 2017, 21:18
Distribution: APorteus BUDGIE x64

Setting up locale

Post#3 by M. Eerie » 09 Feb 2018, 21:13

Thank you!
:)

M. Eerie
Black ninja
Black ninja
Posts: 90
Joined: 31 Aug 2017, 21:18
Distribution: APorteus BUDGIE x64

Setting up locale

Post#4 by M. Eerie » 09 Mar 2018, 17:17

Further investigating, I've found that /etc/profile.d/locale.sh contains several variables:
LC_ALL=C
LC_CTYPE
LANG

and so on.

Should I made changes there in order to export locale variables to the whole system?

Concerning to switch numlock on when desktop is alive:
ncmprhnsbl wrote:
04 Feb 2018, 23:27
then save /etc/runlevels/default/numlock (which is a symlink) to a module..
I've followed those steps with no luck.

I've check it out the numlock script, and found that is looking for /dev/vc(...) but they don't exists in filesystem.

(Sorry for the double-trouble)

Cheers!

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1443
Joined: 20 Mar 2012, 03:42
Distribution: 4.0-64bit all-DE+more
Location: australia
Contact:

Setting up locale

Post#5 by ncmprhnsbl » 09 Mar 2018, 22:03

M. Eerie wrote:
09 Mar 2018, 17:17
Further investigating, I've found that /etc/profile.d/locale.sh contains several variables:
LC_ALL=C
LC_CTYPE
LANG
and so on.

Should I made changes there in order to export locale variables to the whole system?
you could be right, here's what artix wiki https://wiki.artixlinux.org/Main/Instal ... figuration says:
Generate locales:

Code: Select all

 nano /etc/locale.gen  <- uncomment your locale
 locale-gen
To set the locale systemwide, edit /etc/profile.d/locale.sh (which is sourced by /etc/profile) or /etc/bash/bashrc.d/artix.bashrc or /etc/bash/bashrc.d/local.bashrc; user-specific changes may be made to their respective ~/.bashrc, for example:

Code: Select all

 export LANG="en_US.UTF-8"
 export LC_COLLATE="C"
looking at /usr/local/bin/setup-locales-live, it mentions localectl, which i guess is a systemd thing(therefore a leftover from a previous nemesis(systemd)version...

anyway heres the full locales .xzm : link 53mb
just extract it and grab the /usr/share/locales/? folder you need, and try editing /etc/locales.gen(uncomment the relevant one) and edit /etc/profile.d/locale.sh
and see how that goes
M. Eerie wrote:
09 Mar 2018, 17:17
I've check it out the numlock script, and found that is looking for /dev/vc(...) but they don't exists in filesystem.
not in the live filesystem? i'll have to look into it...
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

M. Eerie
Black ninja
Black ninja
Posts: 90
Joined: 31 Aug 2017, 21:18
Distribution: APorteus BUDGIE x64

Setting up locale

Post#6 by M. Eerie » 11 Mar 2018, 09:12

Thank you so much, ncmprhnsbl

Refering to
M. Eerie wrote:
09 Mar 2018, 17:17
/dev/vc(...) but they don't exists in filesystem
forget it. It happened in another (older) computer, but haven't see it again.

Thanks again.

Post Reply