Porteus 3.2rc5 & changes=

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
Posts: 3953
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus 3.2rc5 & changes=

Post#1 by Ed_P » 01 Nov 2016, 20:42

Cinnamon 64-bit

Something is going on with Firefox and Flashplayer modules when I use a changes= save.dat file. Firefox isn't connecting with the Flashplayer module whether it is from update-flashplayer or USM. I thought it could be a problem with my save.dat file so created a new one last week but the problem continues.

These are the various modules I've tried. The active ones are the .xzm files, the others are ones I have tried previously.

Code: Select all

guest@porteus:~$ ls -lgh /mnt/sda5/porteus3.2/Modules/f*
-rwxrwxrwx 1 root  47M Jun  6 11:21 /mnt/sda5/porteus3.2/Modules/firefox-47.0b9-x86_64-1.xyzm*
-rwxrwxrwx 1 root  49M Jul 10 08:24 /mnt/sda5/porteus3.2/Modules/firefox-48.0b6-x86_64-1.xyzm*
-rwxrwxrwx 1 root  48M Oct 12 20:13 /mnt/sda5/porteus3.2/Modules/firefox-49.0.1-x86_64-1.xyzm*
-rwxrwxrwx 1 root  49M Oct  7 15:43 /mnt/sda5/porteus3.2/Modules/firefox-50.0b5-x86_64-1.xzm*
-rwxrwxrwx 1 root 5.3M Sep 18 09:36 /mnt/sda5/porteus3.2/Modules/flashplayer-plugin-*
-rwxrwxrwx 1 root 5.3M Sep  6 08:42 /mnt/sda5/porteus3.2/Modules/flashplayer-plugin-*
-rwxrwxrwx 1 root 5.3M Sep 29 16:28 /mnt/sda5/porteus3.2/Modules/flashplayer-plugin-*
-rwxrwxrwx 1 root 5.3M Nov  1 02:06 /mnt/sda5/porteus3.2/Modules/flashplayer-plugin-*

With a prior 3.2 rc system there were problems when a user used the changes= cheatcode. I don't remember what the problems were specifically but I ended up using a changes-time script to determine what the impact was of each tweak I made then creating a module of the changed files. When I boot without a changes= cheatcode and use my changes modules Firefox and the Flashplayer work together. Even after updating the Flashplayer module yesterday. :)

The Firefox files in my changes module are:

Code: Select all

cp -a --parents    /home/guest/.mozilla/firefox/profiles.ini                    /tmp/mod/
cp -a --parents    /home/guest/.mozilla/firefox/dxsqumip.default/places.sqlite  /tmp/mod/
cp -a --parents    /home/guest/.mozilla/firefox/dxsqumip.default/prefs.js       /tmp/mod/
cp -a --parents    /home/guest/.mozilla/firefox/dxsqumip.default/xulstore.json  /tmp/mod/
The new save.dat file has lots of room so space is not the problem, imho.

Code: Select all

mloop /mnt/sda5/porteus3.2/changes/porteussave.dat
using /dev/loop15

Please wait while i gather some info ....

 Your data file has been mounted at: 

You can unmount it by typing uloop

Here is a list of the files:
etc  home  lib	opt  root  usr	var

du -sh
103M	/mnt/loop
df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/loop15     317M  121M  196M  39% /mnt/loop

176K	/mnt/loop/etc
81M	/mnt/loop/home
16K	/mnt/loop/opt
16K	/mnt/loop/root
212K	/mnt/loop/usr
19M	/mnt/loop/var

Post Reply