[SOLVED] minor bug pgawk and gawk sym links 64 bit

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply

[SOLVED] minor bug pgawk and gawk sym links 64 bit

Post#1 by aus9 » 05 Nov 2015, 11:43


In trying to work out what went wrong with something I am building I tend to use MC terminal file manager.
It displays broken links in red

on LXQt 64 bit you may be interested in the following

Code: Select all

file /usr/bin/pgawk
/usr/bin/pgawk: broken symbolic link to `pgawk-4.1.0'
file /usr/bin/pgawk-4.1.0
/usr/bin/pgawk-4.1.0: ERROR: cannot open `/usr/bin/pgawk-4.1.0' (No such file or directory)

file /usr/bin/gawk
/usr/bin/gawk: symbolic link to `../../bin/gawk'

file /bin/gawk
/bin/gawk: symbolic link to `gawk-4.1.0'
file /bin/gawk-4.1.0 
/bin/gawk-4.1.0: ELF 64-bit LSB  executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), stripped
I may be wrong but maybe /usr/bin/pgawk should sym link to /bin/gawk-4.1.0 ?
Last edited by aus9 on 05 Nov 2015, 22:37, edited 1 time in total.

User avatar
Site Admin
Site Admin
Posts: 5987
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil

Re: minor bug pgawk and gawk sym links 64 bit

Post#2 by brokenman » 05 Nov 2015, 17:47

Thanks. I believe everything should be linked to /bin/gawk to survive version bumps.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply