[SOLVED] missing deps for mirage module

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply

[SOLVED] missing deps for mirage module

Post#1 by aus9 » 26 Oct 2015, 22:56


This is similar to my post on the diffuse module, I am on 64 bit LxQt with python-2.7.5-x86_64-1.xzm already in my modules folder.
I moved from XFCE to LxQt in case you are wondering.

Code: Select all

Traceback (most recent call last):
  File "/usr/bin/mirage", line 27, in <module>
    import mirage
  File "/usr/lib64/python2.7/site-packages/mirage.py", line 30, in <module>
    import gtk
  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 30, in <module>
  File "/usr/lib64/python2.7/site-packages/gobject/__init__.py", line 26, in <module>
  File "/usr/lib64/python2.7/site-packages/glib/__init__.py", line 22, in <module>
ImportError: No module named _glib
So I tried same trick and loaded

mirage now opens.
Last edited by aus9 on 30 Oct 2015, 06:34, edited 1 time in total.

User avatar
Site Admin
Site Admin
Posts: 5867
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil

Re: missing deps for mirage module

Post#2 by brokenman » 29 Oct 2015, 20:55

Thanks. USM has trouble picking up python deps. I need to add them manually and rely on users to report these deps.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply