Stuck on Install

Share your opinion about Porteus Kiosk Edition.
Post Reply
Posts: 1
Joined: 13 Aug 2015, 19:47
Distribution: 3.4
Location: Bellingham WA

Stuck on Install

Post#1 by Rydmasm » 13 Aug 2015, 20:15

Good Afternoon,
I am in the process of installing Porteus-Kiosk. I configure my network settings (no proxy) and finish. I then get the following message:

"Updated Porteus Kiosk is available for download from
For security reasons it's recommended to use latest version of the system when performing kiosk installation. (click on this message to dismiss)"

After that, it just hangs, and never continues. I know the internet connection is fine, and I downloaded the most recent version (3.4) from the download link. Tried re-downloading the iso, and installed it onto a different USB device, but still the same issue.

Any ideas would be appreciated. Thanks in advance!

User avatar
Site Admin
Site Admin
Posts: 5385
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland

Re: Stuck on Install

Post#2 by fanthom » 13 Aug 2015, 21:52

Hello Rydmasm,

Please test your ISO in VirtualBox - i'm 100% sure it will work.

I can bet there is an older kiosk installation somewhere and system is booting from it. Which version is reported when system copies modules to RAM?
Please wipe older kiosk installations (reformat devices) and try again.

Or maybe your firewall/proxy blocks downloads from
Please add [Solved] to your thread title if the solution was found.

Post Reply