Trying to Disable USB 3, no luck

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
Black ninja
Black ninja
Posts: 31
Joined: 16 Jan 2012, 18:48
Location: USA

Trying to Disable USB 3, no luck

Post#1 by jesmith » 04 May 2015, 19:11

I have found that on some hardware, booting Porteus from a USB 3 drive is not working very reliably, and so I'd like to be able to disable USB 3 support in the linux kernel. But I don't really want to have to rebuild the kernel to get there, if I can avoid it.

I've figured out where to put kernel command-line parameters, but I can't find a parameter that actually keeps the USB ports running at 2.0 speeds when you have a 3.0 drive in them.

I've tried:


and I've tried:


and in both cases confirmed they were there with 'cat /proc/cmdline' yet the xhci_hcd driver was loaded anyway, and lsusb -t confirms that the drives are running at full, flaky 3.0 speed.

Any suggestions?

User avatar
White ninja
White ninja
Posts: 28
Joined: 01 Nov 2011, 17:36
Distribution: porteus v3.1 32bit XFCE
Location: Netherlands

Re: Trying to Disable USB 3, no luck

Post#2 by libernux » 04 May 2015, 19:49

Can you disable usb3 via the bios? It should continue to work but with usb2 speeds.
I was born with nothing and I still got most of it.

Full of knowledge
Full of knowledge
Posts: 2081
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Trying to Disable USB 3, no luck

Post#3 by donald » 04 May 2015, 20:34

you can use a short USB 2 extension cable to connect the device.
This forces the USB 3 port to use USB 2 signalling.
A USB 3 device or cable has 9 pins, whereas a USB 2 device or cable only has 4 pins.
A USB 3 port will default to USB 2 signaling communication when only 4 pins are connected.
This way you wouldn't lose the ability to connect other USB 3 Devices to operate at full speed.

Post Reply