autostarting applications

Non release banter
Post Reply
OnlyHazeRemains
White ninja
White ninja
Posts: 5
Joined: 15 May 2014, 13:21
Distribution: Kiosk
Location: Germany

autostarting applications

Post#1 by OnlyHazeRemains » 10 Oct 2014, 15:25

Hello everyone,

I am running Porteus-LXDE-v3.0.1 with autologin for the Root User. I have installed a teamviewer 6 by downloading the provided .deb and converting it to .xzm (runs an integrated wine emulator). It starts just fine if run in a terminal session via su guest teamviewer6 (it cannot be started as Root user).

I previously tried the KDE-Desktop that had a neat GUI-Option to enable autostart programs even as a different User.
What file do i need to edit / what do i have to do to autostart teamviewer as guest user?

I tried:
- adding a shortcut (create new shortcut => command = su guest teamviewer6, etc) to /root/.config/autostart (works as Guest but not as Root user)
- adding a shortcut to /etc/xdg/autostart (when i did this all entries for "automatically started applications" in the Desktop Session Settings disappeared
- editing /etc/rc.d/rc.local and adding the line su guest /opt/teamviewer/teamviewer/6/bin/teamviewer (teamviewer has its own .xzm; if i type this string into a terminal it starts)
- editing /etc/xdg/lxsession/LXDE/autostart and adding @teamviewer6 and @su guest teamviewer6 and @su guest /opt/teamviewer/teamviewer/6/bin/teamviewer

Thank you for your help.

tome
Contributor
Contributor
Posts: 598
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Re: autostarting applications

Post#2 by tome » 10 Oct 2014, 18:43

you use wrong binaries, download tar file (http://download.teamviewer.com/download ... nux.tar.gz) extract and run ./teamviewer,
no problem running as root
No intelligence, no life and no information can exist without prior intelligence, life or information (in place where things change and time is running).

OnlyHazeRemains
White ninja
White ninja
Posts: 5
Joined: 15 May 2014, 13:21
Distribution: Kiosk
Location: Germany

Re: autostarting applications

Post#3 by OnlyHazeRemains » 12 Oct 2014, 11:54

Got it working now.
For anyone who might have the same problem:

Download the tarball, extract it as Guest user, then add the line

Code: Select all

@ su guest /$your path$/teamviewer6/teamviewer
to

Code: Select all

/etc/xdg/xsession/LXDE/autostart

Post Reply