[Solved] No Sound

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
mparillo
Black ninja
Black ninja
Posts: 32
Joined: 14 Mar 2014, 19:11
Distribution: Porteus-KDE-v4.0-x86_64.iso
Location: USA

[Solved] No Sound

Post#1 by mparillo » 29 Mar 2014, 11:48

On a different machine, I do just fime with the Open Source Video drivers, but I get no sound. Windows seems to think I have IDT High Definition Audio. Is there a driver for that?
Last edited by mparillo on 31 Mar 2014, 01:16, edited 1 time in total.

User avatar
francois
Contributor
Contributor
Posts: 5330
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: No Sound

Post#2 by francois » 29 Mar 2014, 12:07

Windows...
This is porteus. Please give more information on the problem. It is not clear. :)
Prendre son temps, profiter de celui qui passe.

mparillo
Black ninja
Black ninja
Posts: 32
Joined: 14 Mar 2014, 19:11
Distribution: Porteus-KDE-v4.0-x86_64.iso
Location: USA

Re: No Sound

Post#3 by mparillo » 30 Mar 2014, 13:25

Is there an audio driver that works with an HP EliteBook 840?

User avatar
francois
Contributor
Contributor
Posts: 5330
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: No Sound

Post#4 by francois » 30 Mar 2014, 13:48

1.0 Try in command line:

Code: Select all

guest@porteus:~$ alsamixer
guest@porteus:~$ 
See if you cannot adjust the parameters. Toggle and adjust with the arrow keys.

2.0 Please give us the output:

Code: Select all

guest@porteus:~$ lsmod | grep snd
3.0 Meanwhile that we find some solution, have a look at:
http://docs.slackware.com/howtos:hardwa ... -hda-intel

4.0 What have your tried under porteus to assert that there is no sound? Your laptop is sais to work under linux, so there should be a solution, see:
http://h71016.www7.hp.com/dstore/html/p ... _Sheet.pdf
Prendre son temps, profiter de celui qui passe.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5847
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: No Sound

Post#5 by brokenman » 30 Mar 2014, 14:01

In a terminal as root run this:

Code: Select all

cat >> /etc/asound.conf << EOF
defaults.pcm.card 1
defaults.ctl.card 1
EOF
How do i become super user?
Wear your underpants on the outside and put on a cape.

mparillo
Black ninja
Black ninja
Posts: 32
Joined: 14 Mar 2014, 19:11
Distribution: Porteus-KDE-v4.0-x86_64.iso
Location: USA

Re: No Sound

Post#6 by mparillo » 30 Mar 2014, 14:18

It looks as if the guest account used for the Always Fresh mode lacks permissions to do it directly:

guest@porteus:~$ cat >> /etc/asound.conf << EOF
defaults.pcm.card 1
defaults.ctl.card 1
EOF
bash: /etc/asound.conf: Permission denied

And cannot use sudo either:

guest@porteus:~$ sudo cat >> /etc/asound.conf << EOF
defaults.pcm.card 1
defaults.ctl.card 1
EOF
bash: /etc/asound.conf: Permission denied

User avatar
francois
Contributor
Contributor
Posts: 5330
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: No Sound

Post#7 by francois » 30 Mar 2014, 17:57

In guest mode use terminal to get in root mode:

Code: Select all

guest@porteus:~$ su
Password: 
The root password is toor, unless you changed it. Then try the commands. Some work only in root mode. 8)
Prendre son temps, profiter de celui qui passe.

mparillo
Black ninja
Black ninja
Posts: 32
Joined: 14 Mar 2014, 19:11
Distribution: Porteus-KDE-v4.0-x86_64.iso
Location: USA

Re: No Sound

Post#8 by mparillo » 30 Mar 2014, 19:24

su worked when sudo did not. Thank you very much. Sound (both YouTube.com and Great Little Radio Player) now works. Two questions:

1. Since I prefer to run always fresh, is there a way I do not need to do this every time? Maybe write some kind of script? But if I put it in my KDE System Settings > Startup and Shutdown > Autostart, it will not survive the re-boot as I am Always Fresh, right?
2. I assume asound.conf contains my sound configuration, but what do these settings do?
defaults.pcm.card 1
defaults.ctl.card 1

User avatar
francois
Contributor
Contributor
Posts: 5330
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: No Sound

Post#9 by francois » 30 Mar 2014, 22:47

There is no sudo package installed stock on porteus. It has to be installed.

What type of porteus install do you have: usb, cd, hdd? It will be easier to give some reccomandations. 8)
Prendre son temps, profiter de celui qui passe.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5847
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: No Sound

Post#10 by brokenman » 30 Mar 2014, 23:41

Put the file /etc/asound.conf into your rootcopy folder and then in /mnt/sdxY/boot/syslinux/porteus.cfg change the graphics line mode line that says :

LABEL mate
MENU LABEL Graphics mode (mate)
KERNEL vmlinuz
APPEND initrd=initrd.xz changes=/porteus guiexec=mate-terminal
TEXT HELP
Run Porteus the best way we can.
Try to autoconfigure graphics
card and use the maximum
allowed resolution
ENDTEXT

Remove the changes= part and you will be booting into always fresh mode, but stuff in your rootcopy folder will be copied into the live file system.

Code: Select all

cp -a --parents /etc/asound.conf /mnt/sdxY/porteus/rootcopy
How do i become super user?
Wear your underpants on the outside and put on a cape.

mparillo
Black ninja
Black ninja
Posts: 32
Joined: 14 Mar 2014, 19:11
Distribution: Porteus-KDE-v4.0-x86_64.iso
Location: USA

Re: No Sound

Post#11 by mparillo » 31 Mar 2014, 01:25

brokenman wrote:

Code: Select all

cp -a --parents /etc/asound.conf /mnt/sdxY/porteus/rootcopy
I used your command above to copy /etc/asound.conf to my USB (/mnt/sdb1/), and was able to test without even having to edit /mnt/sdb1/boot/syslinux/porteus.cfg on my USB, because you taught me the tab trick. I simply hit tab at the mode selection, removed the changes=/porteus parameter, and I heard the Porteus KDE Workspace login sound, and am listening to the Great Little Radio Player.

Thank you.

hargitay
Ronin
Ronin
Posts: 1
Joined: 01 Sep 2017, 15:16
Distribution: Porteus Mate 3.2.2 X86_64

[Solved] No Sound

Post#12 by hargitay » 01 Sep 2017, 15:20

Dear Porteus users/friends!

I am having the same issue... on my laptop on Porteus 3.2.2.mate 64.


I have tried everything listed here... but still no sound.
The output for aplay -l now:

root@porteus:/home/guest# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Generic [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0


I really like Porteus... Can anyone help me to configure my soundcard?

Kind regards,
Attila

User avatar
francois
Contributor
Contributor
Posts: 5330
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

[Solved] No Sound

Post#13 by francois » 01 Sep 2017, 16:16

Have you tried:

Code: Select all

cat >> /etc/asound.conf << EOF
defaults.pcm.card 1
defaults.ctl.card 1
EOF
Prendre son temps, profiter de celui qui passe.

Post Reply