odd wifi issue

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Power user
Power user
Posts: 53
Joined: 29 Dec 2010, 01:46
Location: Near SF, CA

odd wifi issue

Post#1 by Burninbush » 07 Feb 2011, 02:32

... on my Toshiba Satellite laptop -- new maybe 18 months ago. This with Porteus V09-32.

It has two MAC addresses, one for the wired rj45 and another for the wifi, which uses the rlt8187 chipset. Both slax and porteus have the driver, and load it at boot time. On the same laptop, Slax easily connects with a very simple command line invoking iwconfig with a few parms. But the same command line doesn't work for Porteus, nor does the pns-tool supplied script which appears to do approximately the same thing only calling wlassistant. That script eventually times out, dhcpcd not producing an IP address.

The problem appears to be: Porteus is trying init the wrong interface. After booting Porteus, before or after trying to connect, if I run a ifconfig -a it will show wlan0 associated with the MAC of the wired NIC, not the wifi chip.

Any clues? One thing that looks weird to me, it appears [booting slax] that the rlt8187 is connected in the Toshiba through a usb buss. One difference I see, running lsmod after slax and after Porteus boots, Porteus is not loading anything like 'usbcore' which on Slax is associated with the rlt8187 module.

Hope this makes sense.

User avatar
Moderator Team
Moderator Team
Posts: 5667
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland

Re: odd wifi issue

Post#2 by fanthom » 07 Feb 2011, 06:58

i have heard about mixed names for one device (eth0 and eth1) but different MAC? really strange.
could you try 'lspci -k' on slax and porteus and check if the same driver is used for wired device?

BTW - 'usbcore' is build into kernel as i dont want to load it from initrd at each boot.
Please add [Solved] to your thread title if the solution was found.

Post Reply