[Solved]no possible root with su

Here you can post about the issues related to modifications performed manually (not through the kiosk wizard). Example: swapped kernel, added 3rd party modules or files.
Please describe in detail what has been changed and hopefully other kiosk user will be able to help.
Porteus team wont resolve bugs posted in this category as we support only modifications made by the kiosk wizard.
Forum rules
Porteus Kiosk section of the forum is unmaintained now. Its kept in a 'read only' mode for archival purposes.
Please use the kiosk contact page for directing your queries: https://porteus-kiosk.org/contact.html
User avatar
Moderator Team
Moderator Team
Posts: 5667
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland

Re: no possible root with su

Post#16 by fanthom » 07 Sep 2013, 08:52

What I do understand though is that you don't want to work on this case :)
because this case wants to achieve goals which i find totally different from the original kiosk's one: running only one app (firefox) with root access permitted for guest.
i have nothing against kiosk mods but dont want to be involved in supporting 10+ additional projects as i have no time for this (wife, kids, friends, job, etc). that's why i have created 'User's modifications to the Kiosk ISO' category where users can help each other and convert Kiosk to anything they want (even media player) but without me being involved.

to be honest: kiosk modifications are tough due to several things: kernel limitations (iso9660 as the only supported filesystem, lack of virtual terminals), missing deps, sometimes even single files. i would rather suggest sticking to some other minimal projects like slitaz which has the same ISO size as kiosk but are more friendly for modifications as have less restrictions enabled by default.
Please add [Solved] to your thread title if the solution was found.

Black ninja
Black ninja
Posts: 40
Joined: 21 Aug 2013, 10:01
Distribution: lubuntu
Location: Rennes

Re: no possible root with su

Post#17 by wsteven » 14 Oct 2013, 09:52

Just to tell that this was possible without modifying anything, just installing sshd, and ssh root@localhost would do the trick ^^