UEFI problem

Post here if you are a new Porteus member and you're looking for some help.
Posts: 2
Joined: 07 Aug 2016, 22:57
Distribution: KDE4-v3.1-i486
Location: Russia

Re: UEFI problem

Post#106 by Russian_Fox » 08 Aug 2016, 08:02

Thanks for your quick replies.

What I did:
1. Booted Windows (The non-EFI PC) and downloaded the 222mb 'Porteus-XFCE-v3.2rc4-i586.iso' from http://dl.porteus.org/i586/Porteus-v3.2rc4/, saved it to be linux-accessible for future use to make a Live USB from brand-new Porteus :)

(note, this one was the 2nd attempt; the first one with 'MATE' wasn't successful as the PLUMA-text-editor didn't seem to be working (dies in a few seconds after launching right in the taskbar) and the second thing was my mistake that I deleted the ISO file right away after unpacking it to the pendrive (it turned out that I needed it later).

2. Took my Micro-SD and put it back to USB-adaptor so that PC thinks it's a USB pendrive. Nuked the SD-card contents and formatted it as one whole FAT32 partition - for BIOS&MBR (or EFI in Compatibility Support Mode, of course, when it emulates BIOS for older PC's. Regretfully my EFI laptop isn't equipped with such mode).

3. Installed the ISO onto the SD (actually steps 2 and 3 are best done with Rufus, you just select a few details of your future filesystem and pick an ISO to unpack on it, then click Start and it does the all-in-one-job). The whole job took only one minute.

4. Started the boot/Porteus-installer-for-Windows.exe (the inconvenience here is that the executable upon its ending closes its window immediately so that I can't even read whether the installation was okay or sudden problems appeared. A 'Success, press any key to exit'-thing at the end would be highly appreciated)

5. Browsed the contents of the card and did not find any EFI folders or .efi files.

6. Booted Porteus (BIOS-mode) from the pendrive in Fresh 'root' mode (Navigated to 'Fresh', pressed Tab and added to the string that appeared: login=root)

7. Picked Start menu -> System -> Create live USB

8. Picked the ISO file I downloaded and used for making the BIOS-version of the Live USB

9. Chose parameters: for EFI PC, Device name (dev/sdb) for my SD-card, clicked OK, confirmed.

10. The thing reported that Live USB was created successfully, I browsed the EFI folder and duh, there's a grub-related file and a boot64.efi! That's not what I need because my EFI is 32 bit!

Nonetheless, I shut the PC down via the Start Menu and tried to boot my laptop from the SD. Failed! EFI bootloader still doesn't see the pendrive as bootable. Moreover, browsing it via EFI Shell showed that there seemed to be no *.efi files at all on the SD. the EFI folder is empty. How's that? I thought there was at least the boot64-one? I understand that it won't work anyway but it was supposed to be there but all vanished for some reason, except for the EFI folder itself. Why? Maybe that's because of the mode Fresh? What did I do wrong?

Now the SD isn't bootable either way. Neither BIOS, nor EFI. I am starting to understand the deep wisdom of the concept that 'hardware is something that you can smash with a hammer' (as opposed to software), which my laptop definitely is :)

User avatar
Site Admin
Site Admin
Posts: 6104
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil

Re: UEFI problem

Post#107 by brokenman » 09 Aug 2016, 02:07

All that is needed is to:

1) Boot into Porteus.
2) Open the 'Create live USB' application and follow the instructions.
3) Reboot from the device you installed Porteus onto with the USB creator.

There is a bootx64.efi and grub.cfg file on the drive, but fear not. It should still boot. I am booted into right now using the method above.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply