[SOLVED] slapt-get --add-keys (invalid crypto engine)

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
Posts: 2
Joined: 18 Feb 2013, 16:52
Distribution: debian, centos, linuxmint
Location: Cyprus

[SOLVED] slapt-get --add-keys (invalid crypto engine)

Post#1 by ddemetis » 21 Feb 2013, 23:35

I have installed with porteus manager the packages from slackware:
-> gnupg-1.4.12-i486-1
-> gnupg2-2.0.19-i486-1
-> gpgme-1.3.2-i486-1

I try the command:
$ slapt-get --add-keys

and i get this error (I even restarted netbook and also made sure they are activated)

GPGME: Invalid crypto engine
GPG key could not be imported.

$cat /etc/porteus-version

it seems i needed the following package for gpg to work

after installed that. it worked.

User avatar
Site Admin
Site Admin
Posts: 6104
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil

Re: [SOLVED] slapt-get --add-keys (invalid crypto engine)

Post#2 by brokenman » 24 Feb 2013, 13:25

This package was added to v2.0. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply