Known bugs Porteus v09

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
Site Admin
Site Admin
Posts: 6104
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil

Known bugs Porteus v09

Post#1 by brokenman » 11 Jan 2011, 18:47

For some reason (probably 2.6.37 aufs kernel patch fault) KDE-3 stopped working with 'changes=' saved on FAT/NTFS filesystem.
I had this issue before with v09 2.6.36 kernel release and found a workaround: tmpfs had to be mounted in /var/tmp directory to allow KDE-3 desktop start correctly. I have implemented extra function in linuxrc and it worked fine (also for Kde-4).

After update to 2.6.37 kernel, KDE-4 and LXDE are fine (with tmpfs mounted in /var/tmp) but KDE-3 not. Have tried to mount tmpfs also in /tmp but still no joy.

Workaround as per today: please save changes in slaxsave.dat container placed on Windows fs (dont need to use it on linux filesystems).

Hopefully for 1.0 release:
- aufs patch gonna sort this issue out
- we switch to KDE-3.5.12-Trinity
- i'll find another workaround

How do i become super user?
Wear your underpants on the outside and put on a cape.