nvidia driver

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
beny
Full of knowledge
Full of knowledge
Posts: 902
Joined: 02 Jan 2011, 11:33
Location: italy

nvidia driver

Post#1 by beny » 10 Jan 2011, 21:07

the nvidia driver for porteus64 are on the same folder:http://www.mediafire.com/download.php?5o2k04228v460w8

Pedro
White ninja
White ninja
Posts: 16
Joined: 11 Jan 2011, 01:57
Location: Portugal

Re: nvidia driver

Post#2 by Pedro » 11 Jan 2011, 02:01

I cant make this driver to work. During boot i get a message of possible problem in the module. I tryed redownloading but same problem.
Pedro

User avatar
fanthom
Site Admin
Site Admin
Posts: 5318
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland
Contact:

Re: nvidia driver

Post#3 by fanthom » 11 Jan 2011, 07:18

"unsquashfs porteus-nvidia64.lzm
Can't find a SQUASHFS superblock on porteus-nvidia64.lzm"

bad upload?
Please add [Solved] to your thread title if the solution was found.

beny
Full of knowledge
Full of knowledge
Posts: 902
Joined: 02 Jan 2011, 11:33
Location: italy

Re: nvidia driver

Post#4 by beny » 11 Jan 2011, 19:03

mediafire,i delete file and reuploads i have installed driver and i have to loads module for check sanity.

Posted after 27 minutes 50 seconds:
hi pedro you can downloads file, i have uploaded again please check it.

Kaso_Da_Zmok
White ninja
White ninja
Posts: 10
Joined: 12 Jan 2011, 11:47
Location: Ireland

Re: nvidia driver

Post#5 by Kaso_Da_Zmok » 12 Jan 2011, 15:46

hi beny,
i can't find the nvidia module.
could you also describe how did you compile the nvidia module briefly?
thanks.

beny
Full of knowledge
Full of knowledge
Posts: 902
Joined: 02 Jan 2011, 11:33
Location: italy

Re: nvidia driver

Post#6 by beny » 12 Jan 2011, 16:13

hi http://www.mediafire.com/beny look for the nvidia folder and porteus64.lzm,i have uploaded two time file,tell me if work or not please

Pedro
White ninja
White ninja
Posts: 16
Joined: 11 Jan 2011, 01:57
Location: Portugal

Re: nvidia driver

Post#7 by Pedro » 13 Jan 2011, 01:26

Thanks beny, driver is now working fine:)

User avatar
fanthom
Site Admin
Site Admin
Posts: 5318
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland
Contact:

Re: nvidia driver

Post#8 by fanthom » 13 Jan 2011, 10:48

stripped and added to official repo:
http://ponce.cc/porteus/x86_64/current/ ... x86_64.lzm

Thanks!
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 5846
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: nvidia driver

Post#9 by francois » 12 May 2011, 02:58

Thanks beny.

Your nvidia 64 bit rc2 works fine for me.
Prendre son temps, profiter de celui qui passe.

User avatar
francois
Contributor
Contributor
Posts: 5846
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: nvidia driver

Post#10 by francois » 28 Jul 2011, 22:41

I am working with a porteus hdd install, with a save changes folder. Nvidia will work for me with porteus 64-bit v 1.0 if I blacklist nouveau in /etc/modprobe.d/blacklist.conf.

Ahau, to get the same result, makes the proposition of modification of the xorg.conf :
http://porteus.org/info/docs/46-video/1 ... river.html
Last edited by francois on 29 Jul 2011, 12:52, edited 1 time in total.
Prendre son temps, profiter de celui qui passe.

User avatar
fanthom
Site Admin
Site Admin
Posts: 5318
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland
Contact:

Re: nvidia driver

Post#11 by fanthom » 29 Jul 2011, 09:26

@all
nouveau is blacklisted by default in Porteus. it get's loaded only when user is going to GUI and when other drivers (like nvidia, nv) are unavailable.
check /etc/modprobe.d/BLACKLIST-nouveau.conf
reference:
/var/log/packages/xf86-video-nouveau-blacklist-noarch-1
Please add [Solved] to your thread title if the solution was found.

User avatar
francois
Contributor
Contributor
Posts: 5846
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: nvidia driver

Post#12 by francois » 29 Jul 2011, 14:14

And you are right. I was probably using the nvidia driver with the wrong architecture.

Sorry, for the false alert.
Prendre son temps, profiter de celui qui passe.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: nvidia driver

Post#13 by Ahau » 29 Jul 2011, 16:39

Hrm -- that's not the experience I had. I'll double check, but I thought that if I simply drop the nvidia driver in my /porteus/modules folder, my system still defaults to nouveau, unless I blacklist it in /etc/modprobe.d/blacklist.conf or modify xorg.conf to point to nvidia AND disable xconf.

I'm going to download the driver again and test this to make sure--though I don't think I would have written a HOWTO for this if it had worked for me out of the box :)
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
francois
Contributor
Contributor
Posts: 5846
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: nvidia driver

Post#14 by francois » 31 Jul 2011, 01:43

@ahau:

Expecting a comeback on your investigations! 8)
Prendre son temps, profiter de celui qui passe.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: nvidia driver

Post#15 by Ahau » 31 Jul 2011, 06:30

Thanks for the reminder :)

Well, I downloaded the nVidia driver module from the Porteus server, dropped it into my /porteus/modules folder, and on the next reboot, it started up the nVidia driver automatically... I don't know what I was doing wrong before lol.

However, the font is still too large in some places, so I would still need to customize my xorg.conf and remove xconf from my /boot/porteus.cfg as specified in the HOWTO.
Please take a look at our online documentation, here. Suggestions are welcome!

Post Reply