Porteus v09 32 bit is out

Non release banter
User avatar
Site Admin
Site Admin
Posts: 6105
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil

Porteus v09 32 bit is out

Post#1 by brokenman » 09 Jan 2011, 20:13

Download the latest version here

Bott Menu Splash


Please remember - less time which i spent on answering questions which are already answered in this FAQ means more time for adding new features to Porteus!

Just to mention few features of this build:

- kernel 2.6.37 (without ck-patches as per this release, had some troubles with it)
- xorg-server-1.9.2
- new implementation of Linux Live Script (please read /porteus/cheatcodes.txt as some cheatcodes were added/changed/removed)
- squashfs3 modules will be automatically converted upon activation (with your permission)

Many other small changes:
- all scripts and docs updated with new name - Porteus. please help us with finding typos and still exisiting, unnecessary references to old name: slax-remix
- removed sq4 suffix so all porteus tools will produce .lzm modules instead of .sq4.lzm
- following boot parameters: 'rw root=/dev/ram0 ramdisk_size=6666' are now hardcoded into kernel and no longer required in bootloader config (bootloader can still override it when necessary, example: increasing initrd size)
- jfs is compiled as (M) - i don't think that anyone is really using it, also removed fsck function for this fs from linuxrc
- added 'from_iso=' cheatcode to linuxrc and updated /porteus/cheatcodes.txt file:
from_iso=/path/to/image.iso ... This cheatcode can be used to boot from Porteus ISO image directly.
Full path to ISO is required.

WARNING: You can't use it together with 'from_dev=' parameter.
Example: 'from_iso=/mnt/sda6/linux-images/latest-porteus.iso'

- added support for multiple swap partitions to linuxrc (they all have the same priority so when placed on different drives will work as RAID 0!)
- updated 'fault' message (inside initrd) with warning about new cheatcodes
- integrated PLOP boot manager with syslinux
- new colour scheme for porteus.cfg
- new syslinux splash screen
- added back/restore of MBR to bootinst scripts
- removed /porteus/tools content except WIN folder (not necessary files were there)
- added 'mkswapfile' Q/A to the FAQ
- changed /etc/rc.d/rc.6 script as swap files needs to be deactivated before unmounting local filesystems
- added 'one extra loop' function to rc.slax so there will be always one free :)
- /root/.bash-profile checks for lxterminal first so all Porteus scripts are launched in it (if available)
- removed slaxdrive
- updated LST with new downloading paths (separated from 32/64 bits)
- merged WPA and WPA2 in pns-tool (old sns-tool), added info about incompatible drivers for ad-hoc mode.

Known Bugs
For some reason (probably 2.6.37 aufs kernel patch fault) KDE-3 stopped working with 'changes=' saved on FAT/NTFS filesystem.
I had this issue before with v09 2.6.36 kernel release and found a workaround: tmpfs had to be mounted in /var/tmp directory to allow KDE-3 desktop start correctly. I have implemented extra function in linuxrc and it worked fine (also for Kde-4).

After update to 2.6.37 kernel, KDE-4 and LXDE are fine (with tmpfs mounted in /var/tmp) but KDE-3 not. Have tried to mount tmpfs also in /tmp but still no joy.

Workaround as per today: please save changes in slaxsave.dat container placed on Windows fs (dont need to use it on linux filesystems).

Hopefully for 1.0 release:
- aufs patch gonna sort this issue out
- we switch to KDE-3.5.12-Trinity
- i'll find another workaround

Official repo:
How do i become super user?
Wear your underpants on the outside and put on a cape.