google-chrome won't start *fix*

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Posts: 1
Joined: 29 Jan 2012, 01:52
Location: berlin

google-chrome won't start *fix*

Post#1 by knallbunt » 29 Jan 2012, 02:33

Hej to all porteus users arround here.
I just installed porteus, and i got to admit im quiet impressed, especially by the paketmanagement, which is working like a magician with all those different repositorys.
Everything went flawless, until i tried to install google-chrome, because when i tried starting it, it simply didnt.
It just happend nothing, so i tried starting it from terminal aaand i got an error message, saying the gconf libraries were missing.

Knowing this issue i opened the pmm again, looked for the library inside the porteus repository, et voila! (:

But trying to start chrome again, it suggested to make some changes to the sandbox folder
so i had to chown it to root, and chmod it to 4755 (if i do remember it right).. the path was /opt/google/chrome/chrome-sandbox

Then i tried starting it again, getting a new error, this time complaining about the nss libraries.. the only problem was, i didnt find those neither in the porteus repos nor the slackwares, BUT i found the mozilla-nss--3.12.4--0.1.5.xzm in the fidoslax repos.. after the pmm had done his work anothertime (amazingly without problems in conversion etc).. chrome did work..

since i dont know if im the only one with his problem & i already found a way to fix it, i thought it would be okej to post it here, not saying SOLVED in front of it, because nobody will care about it then anyway ((:

so i hope i could help, and if not, my pleasure spamming your forums (:
(did i mention i just registered to be able to post this? (x )

greets from berlin,

User avatar
Posts: 6438
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Re: google-chrome won't start *fix*

Post#2 by francois » 31 Jan 2012, 01:44

Welcome to you on porteus knallbunt. Have a look on this howto. It might help you resolve your problem:
Prendre son temps, profiter de celui qui passe.

User avatar
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: google-chrome won't start *fix*

Post#3 by Ahau » 01 Feb 2012, 16:12

Welcome, knallbunt, and thanks for posting!

From which repository did you download Chrome? Did you download it from the Porteus repo, and if so had you checked for updates to PPM and the repo index? I tried to recreate this problem last night but was short on time and PPM failed for some other reason (I think it must be some buggy module I put in my /optional/ folder), but I'll try this again tonight to see if I can sort out what happened and perhaps how to solve it for other users.

Posted after 1 day 40 minutes 44 seconds:
I tried again last night, and reproduced this problem (or others) when trying to download google chrome. In 32-bit, the latest PPM version failed immediately when I tried to download the google chrome module from the repo, telling me that it was an invalid module name or some such nonsense. I then reverted to the PPM that came with 1.1-final, and it downloaded google chrome, but didn't resolve GConf, just as you said. I mlooped the module and it does have a /var/porteus/*info file that lists the missing gconf lib, so I'm not sure what's going on...

In 64-bit (PPM from 1.1-final, not the latest), it downloaded the deps, but something was wrong with the google chrome module itself -- it only downloaded a tiny file, which IIRC it was named as a google chrome module, but the content was an html page complaining that I'd broken the interwebs (or something to that effect).

Brokenman and fanthom, you ought to check this out.

Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
Site Admin
Site Admin
Posts: 6105
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil

Re: google-chrome won't start *fix*

Post#4 by brokenman » 04 Feb 2012, 16:57

but the content was an html page complaining that I'd broken the interwebs (or something to that effect).
This is ponce's 404 error page so either the link was wrong or the server couldn't be contacted at the time ... or you really did break the interweb.

I'll look into what is making it fail. Thanks.

Posted after 2 days 21 hour 57 minutes 19 seconds:
Fixed now. Please run the update module database function from the menu to fix this.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply