Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Добро пожаловать!

Moderator: Blaze

sfs
Black ninja
Black ninja
Posts: 33
Joined: 20 Apr 2013, 19:30
Distribution: Arch
Location: ru
Contact:

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#106 by sfs » 14 May 2019, 06:19

SaintAnd wrote:
13 May 2019, 16:15
могу ли я из puppy репозитория взять драйвера на ту же видеокарту и запустить, чтобы всё работало адекватно?
Из PRA -Да. Вместе с ядром (vmlinus) и его модулями 000-kernel*.
Из других линуксов (например Manjaro) - нужен еще другой initrd (rootaufs2 или UIRD) - это для опытных

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#107 by SaintAnd » 14 May 2019, 09:31

sfs, Спасибо, что пояснили, и за полезные ссылки.

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#108 by SaintAnd » 18 May 2019, 14:37

Я пока не могу решить вопрос по ошибке с видеокартой.
На porteus v4 x64 lxde. Ввожу такие команды:
nvidia-settings:
https://pastebin.com/MTEjTiq5
vainfo:
https://pastebin.com/RR2LKB6M
vdpow:
https://pastebin.com/En8fzvq3

Ввёл в одной консоли такие команды export LIBVA_DRIVER_NAME=nvidia и после export LIBVA_DRIVERS_PATH=${HOME}/usr/lib64/ стало по другому (потому что я ввёл неправильный путь. Нужно было без этого ${HOME}):
Негде нет libva-x11.so.2 для slackware. Я от отчаяния попробовал использовать libva-x11.so.2 из пакета для freebsd, но тоже не помогло. Написало ошибку с версией ABI. А скачал для rosa и такая ошибка
Я смог решить проблему с vainfo
путём присвоения трёх символьных ссылок на файлы libva-x11.so.1.4000.0, libva-drm.so.1.4000.0, libva.so.1.4000.0, (а они должны быть версии 2.4000)
Но теперь опять при введении vainfo выводится следующее:

User avatar
Blaze
DEV Team
DEV Team
Posts: 2691
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#109 by Blaze » 18 May 2019, 17:12

SaintAnd, предлагаю накатить предварительные обновления Porteus 5 (001-core.xzm и 002-xorg.xzm)

Code: Select all

# Раздел с установленным Porteus должен быть смонтирован и папка base должна быть доступна для записи
su
toor
update-porteus
Ссылка для ручного обновления:
http://dl.porteus.org/x86_64/Porteus-v5.0/updates/core/
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#110 by SaintAnd » 18 May 2019, 18:28

Blaze, сегодня как раз заметил на dl.porteus.org porteus v5, только не понял как его установить.
Попробую как вы предложили.

Я уже хотел начать пользоваться v3, т.к. там меньше проблем с драйверами на видеокарту. Посмотрю, как поведёт себя эта версия.

Вопрос. Драйвер видеокарты нужно по-новой для ядра установить?

User avatar
Blaze
DEV Team
DEV Team
Posts: 2691
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#111 by Blaze » 18 May 2019, 18:34

SaintAnd, драйвер желательно заново скомпилировать, но я думаю что он и так запустится.

Кстати в обновлении:

Code: Select all

# ls -l /usr/lib64/libva*
lrwxrwxrwx 1 root root     20 мая 15 20:20 /usr/lib64/libva-drm.so -> libva-drm.so.2.401.0*
lrwxrwxrwx 1 root root     20 мая 15 20:20 /usr/lib64/libva-drm.so.2 -> libva-drm.so.2.401.0*
-rwxr-xr-x 1 root root  14448 апр  8 19:11 /usr/lib64/libva-drm.so.2.401.0*
lrwxrwxrwx 1 root root     20 мая 15 20:20 /usr/lib64/libva-glx.so -> libva-glx.so.2.401.0*
lrwxrwxrwx 1 root root     20 мая 15 20:20 /usr/lib64/libva-glx.so.2 -> libva-glx.so.2.401.0*
-rwxr-xr-x 1 root root  23008 апр  8 19:11 /usr/lib64/libva-glx.so.2.401.0*
lrwxrwxrwx 1 root root     20 мая 15 20:20 /usr/lib64/libva-x11.so -> libva-x11.so.2.401.0*
lrwxrwxrwx 1 root root     20 мая 15 20:20 /usr/lib64/libva-x11.so.2 -> libva-x11.so.2.401.0*
-rwxr-xr-x 1 root root  27136 апр  8 19:11 /usr/lib64/libva-x11.so.2.401.0*
lrwxrwxrwx 1 root root     16 мая 15 20:20 /usr/lib64/libva.so -> libva.so.2.401.0*
lrwxrwxrwx 1 root root     16 мая 15 20:20 /usr/lib64/libva.so.2 -> libva.so.2.401.0*
-rwxr-xr-x 1 root root 145896 апр  8 19:11 /usr/lib64/libva.so.2.401.0*
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#112 by SaintAnd » 18 May 2019, 20:46

Blaze, к сожалению не запускается драйвер. Выдаёт ошибку.
:pardon:

User avatar
Blaze
DEV Team
DEV Team
Posts: 2691
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#113 by Blaze » 19 May 2019, 09:45

SaintAnd, менеджер входа slim ругается на недостающую библиотеку.
Скорее всего ошибка вызвана тем, что DE (Desktop Environment - окружение рабочего стола) не обновлено.

У меня

Code: Select all

# ls -l /usr/lib64/libjpeg*
lrwxrwxrwx 1 root root     13 мая 15 20:20 /usr/lib64/libjpeg.so -> libjpeg.so.62*
lrwxrwxrwx 1 root root     17 мая 15 20:20 /usr/lib64/libjpeg.so.62 -> libjpeg.so.62.3.0*
-rwxr-xr-x 1 root root 604800 фев 20 20:37 /usr/lib64/libjpeg.so.62.3.0*
посмотрите у себя и сделайте символическую ссылку (пример см. ниже)

Code: Select all

ln -s /usr/lib64/libjpeg.so.62.3.0 /usr/lib64/libjpeg.so.8
так же можно запустить иксы от root минуя slim с помощью команды startx

И наконец, самый последний вариант - включить ждуна и ждать Porteus 5
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#114 by SaintAnd » 19 May 2019, 15:18

Blaze, ls -l /usr/lib64/libjpeg* вывел такой результат:

Code: Select all

root@porteus:/home/guest# ls -l /usr/lib64/libjpeg*
lrwxrwxrwx 1 root root     17 Apr  4 20:33 /usr/lib64/libjpeg.so -> libjpeg.so.62.2.0*
lrwxrwxrwx 1 root root     17 Apr  4 20:33 /usr/lib64/libjpeg.so.62 -> libjpeg.so.62.2.0*
-rwxr-xr-x 1 root root 424488 Dec 24  2017 /usr/lib64/libjpeg.so.62.2.0*
lrwxrwxrwx 1 root root     16 May  1  2018 /usr/lib64/libjpeg.so.8 -> libjpeg.so.8.0.1*
-rwxr-xr-x 1 root root 238224 Jun 20  2017 /usr/lib64/libjpeg.so.8.0.1*
libjpeg.so.8 уже привязана к libjpeg.so.8.0.1

Code: Select all

lrwxrwxrwx 1 root root     16 May  1  2018 /usr/lib64/libjpeg.so.8 -> libjpeg.so.8.0.1*
Ввёл команды

Code: Select all

root@porteus:/home/guest# rm /usr/lib64/libjpeg.so.8
root@porteus:/home/guest# ln -s /usr/lib64/libjpeg.so.62.2.0 /usr/lib64/libjpeg.so.8
и стало так:

Code: Select all

lrwxrwxrwx 1 root root     28 May 19 18:16 /usr/lib64/libjpeg.so.8 -> /usr/lib64/libjpeg.so.62.2.0*
Привожу скриншоты по результатам команд:
Image Image
В результате началась загрузка иксов через команду startx и тройного Ctrl+C, но опять переходило в меню консоли.


Решение оказалось таким - просто создал отдельный changes для porteus v5, появляется ошибка с libjpeg... (символические ссылки я хоть и сделал, но приходиться вводить) startx и запускаются иксы, только не работает модуль вайфай (нет индикатора сети в правом верхнем углу, даже в настройках панели нет). Пришлось настраиваться через pns-tool. И так при каждой загрузке.

Nvidia-settings теперь работает. Остаётся только разобраться с libjpeg и восстановить значёк вай-фай на верхней панели.

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#115 by SaintAnd » 09 Jul 2019, 18:30

Подскажите, как доустановить 32-битные библиотеки к имеющемуся драйверу nvidia (415.27)? Хочу запустить steam, а он мне пишет

Code: Select all

You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6
Porteus v5 x86_64.
Драйвер на видеокарту не собирается вручную, так как пишет, что у меня версия gcc 8, а, как бы, нужна gcc 9. Но не уверен, что нужно. В итоге ничего не устанавливается.

Пробовал удалять libc.so.6 по пути /home/guest/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6, но тщетно

Решил установить драйвер 340.107. В этом случае, не было замечаний по поводу gcc, но драйвер всё равно не установился. Вывел такое сообщение:

Code: Select all

ERROR: Unable to build the NVIDIA kernel module.
Вот лог
https://pastebin.com/66s8zS27

User avatar
Blaze
DEV Team
DEV Team
Posts: 2691
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#116 by Blaze » 09 Jul 2019, 19:06

SaintAnd, по Steam особо не подскажу.
SaintAnd wrote:
09 Jul 2019, 18:30
/home/guest/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
от куда это все взялось (из какого пакета)?

Вам потребуется multilib http://www.slackware.com/~alien/multilib/current/ для запуска 32-х разрядных приложений.
SaintAnd wrote:
09 Jul 2019, 18:30
Porteus v5 x86_64.
Драйвер на видеокарту не собирается вручную, так как пишет, что у меня версия gcc 8, а, как бы, нужна gcc 9.
Правильно пишет. Заглянул в зеркала Porteus-v5.0 RC1, а там отсутствуют 05 и 06 модули - вот это поворот :wall:
Сообщу об этом выше, чтобы положили в http://ftp.nluug.nl/os/Linux/distr/port ... 0/modules/

Загрузил для Вас отдельно (сырцы ядроа 5.1.5 и софт для компиляции под gcc 9 - не знаю заведется-ли с Вашей видео картой):
05-devel.xzm
06-crippled_sources-5.1.5-64bit.xzm
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#117 by SaintAnd » 09 Jul 2019, 19:12

Blaze wrote:
09 Jul 2019, 19:06
от куда это все взялось (из какого пакета)?
От сюда https://www.magentacloud.de/share/5o-zl ... ti-Modules и скачал 30-Steam_Client.xzm
Blaze wrote:
09 Jul 2019, 19:06
Вам потребуется multilib http://www.slackware.com/~alien/multilib/current/ для запуска 32-х разрядных приложений.
Именно этот пакет нужен или другой http://www.slackware.com/~alien/multili ... 6alien.txz? Я не совсем понял.
Blaze wrote:
09 Jul 2019, 19:06
Загрузил для Вас отдельно (сырцы ядроа 5.1.5 и софт для компиляции под gcc 9 - не знаю заведется-ли с Вашей видео картой):
Blaze, Я загружал с сайта dl.porteus.org. То есть у меня эти модули стояли.

User avatar
Blaze
DEV Team
DEV Team
Posts: 2691
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#118 by Blaze » 09 Jul 2019, 19:38

SaintAnd wrote:
09 Jul 2019, 18:30
Вот лог
https://pastebin.com/66s8zS27
по поводу ошибки
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
проверьте, что выдаст команда, если ничего то все ок.

Code: Select all

test -e /lib/modules/`uname -r`/source/include/generated/autoconf.h -a -e /lib/modules/`uname -r`/source/include/config/auto.conf || echo error
заодно покажите лог

Code: Select all

cat /var/log/nvidia-installer.log
SaintAnd wrote:
09 Jul 2019, 19:12
Я загружал с сайта dl.porteus.org. То есть у меня эти модули стояли.
странно, от куда он тогда говорит, что у Вас gcc 8 :wall:

Отправлено спустя 8 минут 6 секунд:
SaintAnd wrote:
09 Jul 2019, 19:12
Именно этот пакет нужен или другой
все пакеты с префиксом multilib, надеюсь, что до compat32 не дойдет дело.
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

SaintAnd
Samurai
Samurai
Posts: 117
Joined: 02 Sep 2018, 13:45
Distribution: Porteus-v4-x64 (LXDE)

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#119 by SaintAnd » 09 Jul 2019, 19:54

Blaze wrote:
09 Jul 2019, 19:46
проверьте, что выдаст команда, если ничего то все ок.

Code: Select all

root@porteus:/home/guest# test -e /lib/modules/`uname -r`/source/include/generated/autoconf.h -a -e /lib/modules/`uname -r`/source/include/config/auto.conf || echo error
error
Blaze wrote:
09 Jul 2019, 19:46

заодно покажите лог
https://pastebin.com/66s8zS27 - это он и был.
Blaze wrote:
09 Jul 2019, 19:46
все пакеты с префиксом multilib, надеюсь, что до compat32 не дойдет дело.
Понял.

-------

Установил все пакеты с префиксом multilib, но выдалось всё тоже сообщение, о версии gcc 8.3.
nvidia-installer.log
https://pastebin.com/0kATr3LH part1
https://pastebin.com/kcA84UJY part 2

User avatar
Blaze
DEV Team
DEV Team
Posts: 2691
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus и NVIDIA. Собираем актуальный драйвер для видеокарты

Post#120 by Blaze » 10 Jul 2019, 16:33

SaintAnd wrote:
09 Jul 2019, 19:54
Установил все пакеты с префиксом multilib, но выдалось всё тоже сообщение, о версии gcc 8.3.
это 32 битные пакеты для Steam Client, еще та солянка :D

по команде не должно

Code: Select all

test -e /lib/modules/`uname -r`/source/include/generated/autoconf.h -a -e /lib/modules/`uname -r`/source/include/config/auto.conf || echo error
выдать error

По команде

Code: Select all

gcc -v
должно выдать:

Code: Select all

Спецификации прочитаны из /usr/lib64/gcc/x86_64-slackware-linux/9.1.0/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-slackware-linux/9.1.0/lto-wrapper
Целевая архитектура: x86_64-slackware-linux
Параметры конфигурации: ../gcc-9.1.0/configure --prefix=/usr --libdir=/usr/lib64 --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,brig,c,c++,d,fortran,go,lto,objc,obj-c++ --enable-threads=posix --enable-checking=release --enable-objc-gc --with-system-zlib --enable-libstdcxx-dual-abi --with-default-libstdcxx-abi=new --disable-libstdcxx-pch --disable-libunwind-exceptions --enable-__cxa_atexit --disable-libssp --enable-gnu-unique-object --enable-plugin --enable-lto --disable-install-libiberty --disable-werror --with-gnu-ld --verbose --with-arch-directory=amd64 --disable-gtktest --enable-clocale=gnu --disable-multilib --target=x86_64-slackware-linux --build=x86_64-slackware-linux --host=x86_64-slackware-linux
Модель многопоточности: posix
gcc версия 9.1.0 (GCC)
если у Вас там нет 9.1.0, значит у Вас не те модули, или подгружаются мусорные сохранения от предыдущих сборок Porteus.

Однако, тут другая картина, очередной - "вот это поворот":
The kernel was built with gcc version 8.3.0 (GCC), but the current compiler version is cc (GCC) 9.1.0.
Ядро собрано под gcc версии 8.3.0, а текущий компилятор gcc версии 9.1.0 :wall:
Даже пытаться не стоит на этом собирать - ничего не выйдет.

Собирать нужно на этом
[Updated kernel Example]
==== AUFS Kernel only for Porteus ====
Simple package (vmlinuz, 000-kernel.xzm, 06-crippled_sources-NNN-XXbit.xzm)
[5.2] : "basic patches and optional patch" patching was done.
32bit-kernel5.2.tar (86 M)
http://www.mediafire.com/file/n4emgnqh1 ... nel5.2.tar
md5sum: ff5bbacb4b75016037e3bca99404bda0 32bit-kernel5.2.tar

64bit-kernel5.2.tar (92 M)
http://www.mediafire.com/file/75pckqrvi ... nel5.2.tar
md5sum: a82e336436f700a0c9765b7c0a3cadb8 64bit-kernel5.2.tar

[5.1.17] <---NEW : "All patches" patching was done by manual operation.
32bit-ALL-kernel5.1.17.tar (87 M)
http://www.mediafire.com/file/ulwpb1izx ... 5.1.17.tar
md5sum: 1238d86840b59199a82457b6571744e1 32bit-ALL-kernel5.1.17.tar

64bit-ALL-kernel5.1.17.tar (92 M)
http://www.mediafire.com/file/r6l6s2at2 ... 5.1.17.tar
md5sum: 1c8dc8e36541468f04a97b3abbc9ae2b 64bit-ALL-kernel5.1.17.tar

[4.19.57] : Restricted version ("Only basic patches" patching was done.)
32bit-RES-kernel4.19.57.tar (86 M)
http://www.mediafire.com/file/aw5tkr4y3 ... .19.57.tar
md5sum: 28999f5a4973d9f2bae81e5df205d921 32bit-RES-kernel4.19.57.tar

64bit-RES-kernel4.19.57.tar (91 M)
http://www.mediafire.com/file/10uce44xm ... .19.57.tar
md5sum: 6b3aaaae389daa5c6495d321d9f0dc92 64bit-RES-kernel4.19.57.tar

Note 2: Compiler was used at building 5.2, 5.1.17, 4.19.57
gcc-9.1.0-x86_64-1
Спасибо neko за обновления!
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

Post Reply