Porteus 4.0 not booting in UEFI mode SOLVED

Technical issues/questions of an intermediate or advanced nature.
portypit
White ninja
White ninja
Posts: 7
Joined: 03 Dec 2018, 11:09
Distribution: 4.0

Porteus 4.0 not booting in UEFI mode SOLVED

Post#1 by portypit » 22 Mar 2019, 12:23

Add to /porteus/porteus-v4.0-x86_64.cfg the following line:

APPEND /EFI/BOOT

Ignore /boot/syslinux/porteus-v4.0-x86_64.cfg
(yes there are 2 .cfg files!).

Got hint from the files Rufus created to make USB stick bootable.
Then used Porteus method to install onto USB stick.
Then added above line. Strange but true !


Porteus 4.0 installed on PNY 4GB USB stick.
Connected stick to Toshiba Satellite C-50 B-189.

Toshiba System BIOS version = 5.10
O.S. = Windows 8.1

User avatar
Ed_P
Contributor
Contributor
Posts: 5075
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus 4.0 not booting in UEFI mode SOLVED

Post#2 by Ed_P » 22 Mar 2019, 14:07

Did you disable the EFI Secure Boot function on the Toshiba? That's all it took to boot my USB drive on my EFI system. No Rufus, no APPEND /EFI/BOOT The USB drive was created with the /boot/Porteus-installer-for Linux.com file after the ISO files were copied to the USB drive.
Ed

portypit
White ninja
White ninja
Posts: 7
Joined: 03 Dec 2018, 11:09
Distribution: 4.0

Porteus 4.0 not booting in UEFI mode SOLVED

Post#3 by portypit » 23 Mar 2019, 22:08

Yes I did and it works like you say.
But I run Windows 8.1 on the PC sometimes and I was tired changing the BIOS setting from CSM -> to UEFI and back.
I was annoyed that Porteus 4.0 didn't work with PC in UEFI mode: I saw that it was supplied with an EFI folder containing files.
So I searched for ANY kind of solution for my convenience.

User avatar
Ed_P
Contributor
Contributor
Posts: 5075
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus 4.0 not booting in UEFI mode SOLVED

Post#4 by Ed_P » 23 Mar 2019, 23:37

Truly surprised you couldn't run Porteus on your EFI machine without that cheatcode.

I run Windows 10 on an EFI machine and boot to a Porteus flash drive without changing the BIOS since I have Secure Boot disabled. And my flash drive does not have the APPEND /EFI/BOOT cheatcode. My wife's machine is an EFI machine and use to run Windows 8.1. Once I disabled Secure Boot on her machine I could run Porteus on it with not /EFI/BOOT cheatcode. You should write to Rufus and ask how they came up with using that cheatcode.

Do you have an EFI folder on your flash drive?
Ed

portypit
White ninja
White ninja
Posts: 7
Joined: 03 Dec 2018, 11:09
Distribution: 4.0

Porteus 4.0 not booting in UEFI mode SOLVED

Post#5 by portypit » 27 Mar 2019, 10:18

Yes I was surprised also, especially as there was an EFI folder accompanying Porteus 4.0. That's why I was annoyed... my laptop should have booted from the USB stick, especially as I had Secure Boot turned off.

nanZor
Samurai
Samurai
Posts: 185
Joined: 09 Apr 2019, 03:27
Distribution: Porteus 5.0 RC1 XFCE
Location: Los Angeles

Porteus 4.0 not booting in UEFI mode SOLVED

Post#6 by nanZor » 16 Apr 2019, 02:06

Interesting - maybe of interest for those coming from windows / RPI's and wanting to run a flash utility ..

I've had no problem with Rufus and Porteus on my Intel NUC, and other stuff. If my machine is running *solely* in UEFI mode (and of course Secure Boot disabled), when flashing Porteus, all I needed to do was make sure that the Partitioning Scheme in Rufus was set for GPT, not mbr.

If running in legacy mode, and not UEFI, then MBR was fine. Even when Rufus throws up the notice about an old vesamenu in use, and offering to download and install a new one, Porteus boots up fine if you decide to take the offer or not. That's for us propeller heads who check the "Add fixes for old Bioses, (extra partition, align, etc) box.

No files needed to be edited to get the image to boot initially.

YMMV of course. But I was happy that Porteus on my hardware, seems to *want* to work no matter what.

How about Belena Etcher? OH NO..
"The Image does not appear to contain a partition table, and might not be recognized or bootable by your device."

Sure enough, when using Etcher, it wouldn't boot no matter what. In that case, I'd try Rufus, using either MBR or GPT if you run into a roadblock. At least for Porteus.

Tip: don't blame Porteus - these utils just do the best the can and sometimes get confused.
That's a UNIX book - cool. -Garth

User avatar
Ed_P
Contributor
Contributor
Posts: 5075
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus 4.0 not booting in UEFI mode SOLVED

Post#7 by Ed_P » 16 Apr 2019, 02:46

I just use the Porteus install apps to put it on my flash drive and it boots on my UEFI system, with Secure Boot disabled.
Ed

nanZor
Samurai
Samurai
Posts: 185
Joined: 09 Apr 2019, 03:27
Distribution: Porteus 5.0 RC1 XFCE
Location: Los Angeles

Porteus 4.0 not booting in UEFI mode SOLVED

Post#8 by nanZor » 16 Apr 2019, 06:56

Yup - that works .... but take this for instance:

Wanted my relatively modern Acer chromebook-wannabe (Aspire 1, A114-31-C4HH) running Windows to make a bootable image from the Porteus download, running the exe file inside the iso ... )

which results in the Porteus utility wanting to install to the "DVD drive" [which the stick isn't!], and not the real part of the usb stick. Heh, windows thing. Going to the forums is always awesome, but after 4 cans of energy drink, some might just want to

Fire up latest Rufus. Flash the image with the GPT option.

Get into bios, and disable Secure Boot (natch), and while there change the mouse from "advanced" to "BASIC." (otherwise mouse is frozen when booting Porteus)

After Porteus boots, one may need to hit the blue Fn-F7 to enable the now basic mouse/touchpad to work.

Of course I admire the work of the devs to create nifty utilities, and point back to the forum in case of trouble - but this is a workaround for the um, no-beards. :)
That's a UNIX book - cool. -Garth

portypit
White ninja
White ninja
Posts: 7
Joined: 03 Dec 2018, 11:09
Distribution: 4.0

Porteus 4.0 not booting in UEFI mode SOLVED

Post#9 by portypit » 16 Apr 2019, 11:21

Interesting stuff guys (gals?).
Sometimes Mouse Pointer Icon (arrow symbol) is unmovable at center-screen after boot-up.
nanZor, your comments have given me an idea to place Porteus 4.0 on another USB stick and look more closely at its operation.
Thanks !

User avatar
Ed_P
Contributor
Contributor
Posts: 5075
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus 4.0 not booting in UEFI mode SOLVED

Post#10 by Ed_P » 16 Apr 2019, 17:47

I think one of the secrets to booting Porteus flash drives on EFI systems is creating a GPT partition table from the MBR file. I believe it can be done with GParted and I think there is a build_gpt-fm_mbr command to do it somewhere.

These might help: How to upgrade to UEFI Secure Boot

Uefi and porteus 3.0 (Post by Ed_P #25587)
Ed

zahtar
White ninja
White ninja
Posts: 6
Joined: 06 Aug 2019, 13:24
Distribution: Porteus v4.0 x64 LXQT
Location: Greece

Porteus 4.0 not booting in UEFI mode SOLVED

Post#11 by zahtar » 07 Aug 2019, 23:19

Hello there, first post here!

I have a problem booting Porteus 4.0 x64 via a fat32 usbstick in uefi mode. What I have done so far is:

a) extract the iso, copy the porteus and boot folders to the usbstick, ran the correct .bat file within windows. That was done on a uefi booting laptop (which is not mine).
b) tried to boot via usb, but the usbstick was not available in the boot menu (F12 during startup).
c) made sure secure boot is disabled, and boot mode: UEFI. Failed again, not available as an option in boot menu.
d) the laptop can switch to legacy bios, so I did that and Porteus booted and worked file. While I was there, I edited the /porteus/porteus-v4.0-x86_64.cfg file to add

Code: Select all

APPEND /EFI/BOOT
but no luck booting in UEFI, still not available in the boot menu...

It is not a matter of boot order, because I am accessing the boot menu F12 during startup, in order to boot from the usb stick (nevertheless, I did set boot priorilyty#1 usb-hdd, both in uefi and legacy-bios options without luck). The option to boot from usb only appears when I have selected lecagy-bios in the laptop. In that case, windows will not boot, which is a problem as the laptop is not mine.

Do I need to format the usb stick to a different filesystem? Or is it a different partition table I need to make as Ed-p mentioned?

I want this flash drive to:
a) be able to boot Porteus in uefi mode (perhaps either uefi or bios depending on the machine?)
b) be able to be used as storage to transfer files to different computers (currently formatted as fat32)
c) be able to be used as a medium to playback video files and photographs on my tv (perhaps b and c are the same thing?)

Thanks in advance, sorry for the long post!

User avatar
Ed_P
Contributor
Contributor
Posts: 5075
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus 4.0 not booting in UEFI mode SOLVED

Post#12 by Ed_P » 08 Aug 2019, 03:51

zahtar wrote:
07 Aug 2019, 23:19
a) extract the iso, copy the porteus and boot folders to the usbstick, ran the correct .bat file within windows.
zahtar if you read the USB_INSTALLATION.txt file in the ISO's / directory it makes no reference to a .bat file.
USB_INSTALLATION.txt wrote:FOR EFI SYSTEMS:
Ensure the first partition is of type FAT32.
a) Copy the EFI, boot and porteus folders onto the FAT32 partition.
:
:
From Windows:
a) copy the contents of the ISO image to your drive
b) navigate to the \boot folder and launch the
'Porteus-installer-for-Windows.exe' script
c) verify you are installing to the correct drive and press 'Enter' to
complete the installation
Ed

zahtar
White ninja
White ninja
Posts: 6
Joined: 06 Aug 2019, 13:24
Distribution: Porteus v4.0 x64 LXQT
Location: Greece

Porteus 4.0 not booting in UEFI mode SOLVED

Post#13 by zahtar » 08 Aug 2019, 14:26

Ed_P wrote:
08 Aug 2019, 03:51
...
zahtar if you read the USB_INSTALLATION.txt file in the ISO's / directory it makes no reference to a .bat file.
...
Ed_P, thanks for your reply :beer:

Within windows the file extension was not visible, for some reason I thought it was a .bat, not an .exe. Anyway I had that part correct, that's the script I ran.

Also, thank you for pointing out the USB_INSTALLATION.txt, which I hadn't opened. I followed the instructions on the main page:
http://www.porteus.org/component/conten ... SB-Windows

which didin't mention about copying the efi folder, so I didn't pay attention to that. Is there someone that I can send a pm or email to, who can update those instructions on the main page? I tried using the contact form on the website to contact Hamza, but I get the error: "The following from address failed: admin@porteus.org"

Anyway, after copying to the usb stick, it booted fine in UEFI :good: Right now I am writing from PaleMoon, which I happily found to be ready as a module which I had created. The wifi setting weren't stored though, I'll check after the next boot. Right now I need to do something about the mouse that's wheel-scrolling many lines at the same time, which doesn't seem to get fixed via the lxqt preferences... I'll look into it, as for the UEFI part thank you, copying the efi folder did the trick, problem solved!

User avatar
Ed_P
Contributor
Contributor
Posts: 5075
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus 4.0 not booting in UEFI mode SOLVED

Post#14 by Ed_P » 08 Aug 2019, 16:48

zahtar wrote:
08 Aug 2019, 14:26
I tried using the contact form on the website to contact Hamza, but I get the error: "The following from address failed: admin@porteus.org"
If you click on the Members link in the blue bar at the bottom of the page you will see the names of the Admins and you can then PM them. Tell them I will fix the error if I can have access to do it. :happy62:
The wifi setting weren't stored though, I'll check after the next boot.
If your drive is all FAT32 you have to create a Porteus Save Data file Use the Menu>Admin>Porteus save file manager. You will then need to add a changes= cheatcode to your boot parms. Personally I like the changes=EXIT; version.
Ed

zahtar
White ninja
White ninja
Posts: 6
Joined: 06 Aug 2019, 13:24
Distribution: Porteus v4.0 x64 LXQT
Location: Greece

Porteus 4.0 not booting in UEFI mode SOLVED

Post#15 by zahtar » 14 Aug 2019, 11:34

Thanks for your relply Ed_P.

The savefile is a matter I've been struggling with for the past few days, but I think I found the solution in this thread by your post (#2):
porteus-v4.0-x86_64.cfg ignores changes (Post by Ed_P #71007)

so I'll continue asking there, since this conversation has become off-topic here.

As for the UEFI mode boot, the takeaway is that we need to copy the EFI folder in the usb stick as well. I'll contact the team the way you suggested, thanks!

Post Reply