GIMP 2.10.8

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

GIMP 2.10.8

Post#1 by Rava » 29 Jan 2019, 20:08

Update
Success with creating a minimal dependency GIMP 2.10.8 module on Porteus dev Openbox, that is able to load (and save) png and jpeg.
gimp-2.10.8-x86_64-1_stripped+minimal_dependencies_rava.xzm (13.8 MB)
3d18118f24b52cdbb1ef55c5142e8ba9 gimp-2.10.8-x86_64-1_stripped+minimal_dependencies_rava.xzm

gimp-2.10.8-x86_64-1_locales_only_rava.xzm (10.27 MB)
c0cdfbf041f42fec2737026371366ded gimp-2.10.8-x86_64-1_locales_only_rava.xzm

Click on
➤ Jetzt zur Download-Seite (Go to the Download page)

and then on
Dein Download steht nun bereit. ➤ Klicke hier, um ihn zu starten. (Your download is now ready. Click here to start)

Like always, xzm2dir gimp-2.10.8-x86_64-1_locales_only_rava.xzm and extract only the locales you need, or delete all but the ones you want to keep, and create a new minimal locale module that fits your locales need out of that.
____________________________

All dependencies and the main program:

Code: Select all

root@porteus:/Porteus_modules/x.x/gimp_depsNEU# ./txz2dir-gimp-2.10.8-x86_64-1NEU.sh 

LibRaw-0.18.12-x86_64-1: library for decoding raw digital photos ......... [2.3M]
babl-0.1.60-x86_64-1: pixel format translation library ................... [980K]
gegl-0.4.12-x86_64-1: Generic Graphics Library ........................... [7.6M]
gexiv2-0.10.10-x86_64-1: GObject-based Exiv2 wrapper ..................... [2.2M]
gimp-2.10.8-x86_64-1: The GNU Image Manipulation Program ................. [105M]
jasper-2.0.14-x86_64-1: free implementation of the JPEG-2000 standard .... [610K]
json-c-0.13.1_20180305-x86_64-1: JSON library in C ....................... [1.2M]
json-glib-1.4.4-x86_64-1: GLib/GObject based JSON tools .................. [1.8M]
libmypaint-1.3.0-x86_64-1: brush engine library .......................... [680K]
And here the proof it works, (using porteus dev version, Openbox), GIMP loading jpeg and loading png:
Image

The only optimizations so far are these (I am not on such an expert level when it comes to optimizing GIMP modules as ncmprhnsbl is! He is the real GIMP guru on https://forum.porteus.org !)

Code: Select all

removed
/usr/share/gimp/2.0/brushes/Fun/Wilber.gih 8.8M

resized:
/usr/share/gimp/2.0/images/gimp-splash.png now 324 KB instead of 3.2 MB
 │                         Target file already exists!                         │
 │   /Porteus_modules/x.x/gimp-2.10.8-x~hare/gimp/2.0/images/gimp-splash.png   │
 ├─────────────────────────────────────────────────────────────────────────────┤
 │  New     : Jan 29 23:10, size 331788                                        │
 │  Existing: Nov  8 23:35, size 3354880                                       │
 ├─────────────────────────────────────────────────────────────────────────────┤
 │  Overwrite this target? [ Yes ] [ No ] [ Append ]                           │


_________________________________________________________


The old now outdated original version of the post follows here:

Trying to create GIMP 2.10.8 I get this error:

Code: Select all

gzip: /tmp/txz2xzm6037/usr/man/man1/gimp-console.1.gz: No such file or directory
Creating /Porteus_modules/x/gimp-2.10.8-x86_64-1.xzm

gzip: /tmp/txz2xzm6037/usr/man/man1/gimp-console.1.gz: No such file or directory
Not liking this one bit.

I looked into the resulting module:

Code: Select all

root@porteus:/mnt/loop/usr/man/man1# l
total 54
drwxr-xr-x 2 root   140 2019-01-29 20:51 .
drwxr-xr-x 4 root    39 2018-11-08 23:38 ..
-rw-r--r-- 1 root 12663 2018-11-08 23:38 gimp-2.10.1
-rw-r--r-- 1 root 12663 2018-11-08 23:38 gimp-console-2.10.1
lrwxrwxrwx 1 root    22 2019-01-29 20:51 gimp-console.1.gz -> gimp-console-2.10.1.gz
-rw-r--r-- 1 root 12663 2018-11-08 23:38 gimp.1
-rw-r--r-- 1 root  8102 2018-11-08 23:38 gimptool-2.0.1
-rw-r--r-- 1 root  8102 2018-11-08 23:38 gimptool.1
Sure, gimp-console.1.gz is now a broken link.

I seriously thought the old txz2xzm issue, with having trouble when a .gz man page is a symlink to another .gz man page was solved ages ago, but it seems I was wrong.

The issue seems part of this code of txz2xzm

Code: Select all

    # optimalization procedures, this doesn't hurt
    find $TMPDIR/usr{/local/,/share/,/}{man,info} -type l -name "*.gz" 2>/dev/null | xargs -r gunzip -f
    find $TMPDIR/usr{/local/,/share/,/}{man,info} -type f -name "*.gz" 2>/dev/null | xargs -r gunzip
    cp -a $TMPDIR/usr/share/man $TMPDIR/usr 2>/dev/null; rm -rf $TMPDIR/usr/share/man
    rm -f $TMPDIR/{usr,usr/local,var}/man/cat*/*
Last edited by Rava on 01 Feb 2019, 05:04, edited 1 time in total.
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 5098
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: GIMP 2.10.8

Post#2 by Ed_P » 29 Jan 2019, 21:44

Any particular reason you need 2.10 vs USM's 2.8?

Code: Select all

root@porteus:/home/guest# usm -g gimp

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) gimp-2.8.16-x86_64-1.txz
2) gimp-2.8.18-x86_64-1_slack14.2.txz
3) gimp-feca_hdr-plugin-2010.04.26-x86_64-1_slonly.txz
4) gimp-gap-2.6.0-x86_64-3_slonly.txz
5) gimp-lqr-plugin-0.7.2-x86_64-1_slonly.txz
6) gimp-plugin-bimp-1.18-x86_64-1_slonly.txz
7) gimp-wideangle-plugin-1.0.10-x86_64-2_slonly.txz
#?
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Re: GIMP 2.10.8

Post#3 by Rava » 29 Jan 2019, 21:51

Answered via PM.

Also, why did you not ask the same question here: Gimp-2.10.6 for Porteus 4.0
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Re: GIMP 2.10.8

Post#4 by Rava » 30 Jan 2019, 17:18

Interims Update

Successfully created a module that works in a test environment with a newer kernel. I have to reboot and test if it also works in Porteus 4.0.

The only dependencies I added are:

Code: Select all

babl-0.1.60-x86_64-1.txz
gegl-0.4.12-x86_64-1.txz
json-c-0.13.1_20180305-x86_64-1.txz
libgexiv2-0.10.6-x86_64-1_slonly.txz
libmypaint-1.3.0-x86_64-1.txz
and yes, there are quite some error messages when I start it via the console, but who cares, as long as it runs okay.

The only other shrinking so far have been this:

Code: Select all

removed
/usr/share/gimp/2.0/brushes/Fun/Wilber.gih 8.8M

removed/external module:
/usr/share/locale/

resized:
/usr/share/gimp/2.0/images/gimp-splash.png now 324 KB instead of 3.2 MB
 │                         Target file already exists!                         │
 │   /Porteus_modules/x.x/gimp-2.10.8-x~hare/gimp/2.0/images/gimp-splash.png   │
 ├─────────────────────────────────────────────────────────────────────────────┤
 │  New     : Jan 29 23:10, size 331788                                        │
 │  Existing: Nov  8 23:35, size 3354880                                       │
 ├─────────────────────────────────────────────────────────────────────────────┤
 │  Overwrite this target? [ Yes ] [ No ] [ Append ]                           │
I know ncmprhnsbl has quite more experience than me when it comes to shrinking down a GIMP module. :oops:

For now, its 13467648 bytes or 12.84 MB which is still too large for a minimal slimmed down GIMP.
Cheers!
Yours Rava

User avatar
Blaze
DEV Team
DEV Team
Posts: 2669
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: GIMP 2.10.8

Post#5 by Blaze » 30 Jan 2019, 18:29

Where is this stripped version can be downloaded?
Linux 5.3.0-rc3-porteus #1 SMP Mon Aug 5 11:28:55 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Re: GIMP 2.10.8

Post#6 by Rava » 30 Jan 2019, 18:37

Blaze wrote:
30 Jan 2019, 18:29
Where is this stripped version can be downloaded?
Still untested for 4.0 Image, but here you go:

Update - upload removed since it was not working, no loading JPEG or PNG.
dffad4a0d0b0fad120e6da9e079caa5d gimp-2.10.8-x86_64-1_stripped+minimal_dependencies.xzm

Click on
➤ Jetzt zur Download-Seite (Go to the Download page)

and then on
Dein Download steht nun bereit. ➤ Klicke hier, um ihn zu starten. (Your download is now ready. Click here to start)

________________________


And here are the locales as well:
10678272 bytes, 10.18 MB ! Update - upload also removed, see above
def0ec1f18b252eb300cce44ee64560d gimp-2.10.8-x86_64-1_locales_only.xzm

Like always, xzm2dir gimp-2.10.8-x86_64-1_locales_only.xzm and extract only the locales you need, or delete all but the ones you want to keep (example, delete all locales but ru using mc):
Image
and create a new minimal locale module that fits your locales need out of that.
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Re: GIMP 2.10.8

Post#7 by Rava » 31 Jan 2019, 04:46

Important Update

Seems there is something wrong with this GIMP version, at least on the test environment I am running it on.

Loading any jpeg file results in a failure. The 2 error messages are always the same:

Code: Select all

GIMP Message
Plug-in crashed: "file-jpeg"
(/usr/lib64/gimp/2.0/plug-ins/file-jpeg/file-jpeg)

The dying plug-in may have messed up GIMP's internal state. You may want to save your images and restart GIMP to be on the safe side.

GIMP Message
Opening '/path/to.jpeg' failed: Procedure 'file-jpeg-load' returned no return values
(Only the path and filename change, of course.)

Seems having the GIMP console is helpful in debugging.

It gave me this additional info:

Code: Select all

GEGL-Message: 05:41:13.826: Module '/usr/lib64/gegl-0.4/jp2-load.so' load error: libjasper.so.4: cannot open shared object file: No such file or directory
GEGL-Message: 05:41:13.866: Module '/usr/lib64/gegl-0.4/raw-load.so' load error: libraw.so.16: cannot open shared object file: No such file or directory
/usr/lib64/gimp/2.0/plug-ins/file-jpeg/file-jpeg: symbol lookup error: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZN5Exiv213XmpProperties2nsERKSs
Terminating plug-in: '/usr/lib64/gimp/2.0/plug-ins/file-jpeg/file-jpeg'
GIMP-Error: Plug-in crashed: "file-jpeg"
(/usr/lib64/gimp/2.0/plug-ins/file-jpeg/file-jpeg)
Update2
png gives a similar error, but gif files (at least animated ones) load and save okay.


Seems I do fail in creating newer GIMP modules, or the newer Porteus versions have less dependencies already installed, the times are seemingly over when you just needed to add babl and gegl to have a running GIMP module, it seems.

And to top it all off, http://slakfinder.org finds nothing when searching for libjasper :sorry:
Cheers!
Yours Rava

jssouza
DEV Team
DEV Team
Posts: 1028
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Re: GIMP 2.10.8

Post#8 by jssouza » 31 Jan 2019, 05:16

All your dependencies are part of slackware. Since gimp itself is part of slackware in xap. You can get them my using getpkg as root.

getpkg babl
getpkg gegl
getpkg json-c
getpkg libmypaint
getpkg jasper
getpkg LibRaw
getpkg gexiv2
getpkg gimp

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Re: GIMP 2.10.8

Post#9 by Rava » 31 Jan 2019, 06:55

jssouza wrote:
31 Jan 2019, 05:16
All your dependencies are part of slackware. Since gimp itself is part of slackware in xap. You can get them my using getpkg as root.
That works indeed, but… unlike its name, it seems getpkg is not able to just download the txz package without txz2xzm, since I don't need a module, first I have to merge these all into one folder. Then I make one big GIMP module, after moving the locales out, that is.

_____________________________________

So, created a new module, now also added LibRaw-0.18.12-x86_64-1.txz and jasper-2.0.14-x86_64-1.txz

I was not sure if that could resolve the issue, since both are not directly connected with loading jpeg (not jpeg 2000) or png files, and surprise! The error is still there.

I have to pause for RL, but will try resolving the GIMP 2.10.8 issue as soon as I have time again.
Cheers!
Yours Rava

beny
Full of knowledge
Full of knowledge
Posts: 785
Joined: 02 Jan 2011, 11:33
Location: italy

Re: GIMP 2.10.8

Post#10 by beny » 31 Jan 2019, 12:32

hi ,we need to upgrade at current to build gimp: Error: GIMP configuration failed.

- Error: missing dependency babl >= 0.1.58
- Error: missing dependency gegl-0.4 >= 0.4.12
- Error: missing dependency glib >= 2.54.2
*** Test for GLIB failed
- Error: missing dependency fontconfig >= 2.12.4
- Error: missing dependency gexiv2 >= 0.10.6
- Error: missing dependency libmypaint >= 1.3.0
- Error: missing dependency mypaint-brushes-1.0
- Error: missing dependency poppler-glib >= 0.44.0
- Error: missing dependency lcms2 >= 2.8
this with the 14.2 version aka porteus 4.0..

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2200
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Re: GIMP 2.10.8

Post#11 by ncmprhnsbl » 31 Jan 2019, 12:44

Rava wrote:
31 Jan 2019, 06:55
unlike its name, it seems getpkg is not able to just download the txz package without txz2xzm, since I don't need a module,
have a look at the /usr/local/bin/getpkg script: specificly line 44:

Code: Select all

# Convert downloaded packages into modules
XZM=yes
change that to a no and you'll have packages :happy62:
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Re: GIMP 2.10.8

Post#12 by Rava » 31 Jan 2019, 13:19

ncmprhnsbl wrote:
31 Jan 2019, 12:44
have a look at the /usr/local/bin/getpkg script: specificly line 44:

Code: Select all

# Convert downloaded packages into modules
XZM=yes
change that to a no and you'll have packages :happy62:
Or better yet, have it have a parameter that sets the XZM to either yes or no. Since its default is yes, the parameter, when given, should toggle it to no.

Anyhow, since you are the resident GIMP module creation master :happy62: do you have an idea why my most recent (not yet uploaded) GIMP module still fails?

Seems the attempt to have the module with as little as possible dependencies is harder than I thought, and most probably requires lots of trial and error. With mostly it resulting in error. Image
Cheers!
Yours Rava

User avatar
Blaze
DEV Team
DEV Team
Posts: 2669
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Re: GIMP 2.10.8

Post#13 by Blaze » 31 Jan 2019, 19:15

jssouza wrote:
31 Jan 2019, 05:16
You can get them my using getpkg as root.
...
or

Code: Select all

su
toor
getpkg babl gegl json-c libmypaint jasper LibRaw gexiv2 gimp
Linux 5.3.0-rc3-porteus #1 SMP Mon Aug 5 11:28:55 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Re: GIMP 2.10.8

Post#14 by Rava » 31 Jan 2019, 20:08

Like I said, the same error with jpeg and png, animated gif loads and saves okay.

Used dependencies:

Code: Select all

LibRaw-0.18.12-x86_64-1.txz
babl-0.1.60-x86_64-1.txz
gegl-0.4.12-x86_64-1.txz
jasper-2.0.14-x86_64-1.txz
json-c-0.13.1_20180305-x86_64-1.txz
libgexiv2-0.10.6-x86_64-1_slonly.txz
libmypaint-1.3.0-x86_64-1.txz
Here now the full log via gimp-console:
guest@porteus:/tmp$ file test.jpeg
test.jpeg: JPEG image data, Exif standard: [TIFF image data, little-endian, direntries=0], baseline, precision 8, 850x969, components 3
guest@porteus:/tmp$ gimp-console test.jpeg
HMM....
Something strange is happening,
malloc and free function pointer changing between invocations in babl.

Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/python-eval/python-eval.py", line 19, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/python-console/python-console.py", line 19, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/py-slice/py-slice.py", line 30, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/palette-to-gradient/palette-to-gradient.py", line 16, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/palette-sort/palette-sort.py", line 17, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/palette-offset/palette-offset.py", line 16, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/histogram-export/histogram-export.py", line 40, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/gradients-save-as-css/gradients-save-as-css.py", line 25, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/foggify/foggify.py", line 19, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
/usr/lib64/gimp/2.0/plug-ins/file-wmf/file-wmf: error while loading shared libraries: libwmf-0.2.so.7: cannot open shared object file: No such file or directory
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
/usr/lib64/gimp/2.0/plug-ins/file-ps/file-ps: error while loading shared libraries: libgs.so.9: cannot open shared object file: No such file or directory
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/file-openraster/file-openraster.py", line 20, in <module>
from gimpfu import *
File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 76, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
Traceback (most recent call last):
File "/usr/lib64/gimp/2.0/plug-ins/colorxhtml/colorxhtml.py", line 24, in <module>
import gimp
ImportError: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
gimp-console: LibGimpBase-WARNING: gimp-console: gimp_wire_read(): error
/usr/lib64/gimp/2.0/plug-ins/file-jpeg/file-jpeg: symbol lookup error: /usr/lib64/libgexiv2.so.2: undefined symbol: _ZN5Exiv213XmpProperties2nsERKSs
GIMP-Error: Plug-in crashed: "file-jpeg"
(/usr/lib64/gimp/2.0/plug-ins/file-jpeg/file-jpeg)

The dying plug-in may have messed up GIMP's internal state. You may want to save your images and restart GIMP to be on the safe side.


^Cgimp-console: terminated: Interrupt
/usr/lib64/gimp/2.0/plug-ins/script-fu/script-fu terminated: Interrupt
Highlighting by me. GIMP seems to be okay with the used babl version since it not complains when being started, but the very first error it complains about is about babl.
Cheers!
Yours Rava

jssouza
DEV Team
DEV Team
Posts: 1028
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Re: GIMP 2.10.8

Post#15 by jssouza » 01 Feb 2019, 01:51

Blaze wrote:
31 Jan 2019, 19:15
jssouza wrote:
31 Jan 2019, 05:16
You can get them my using getpkg as root.
...
or

Code: Select all

su
toor
getpkg babl gegl json-c libmypaint jasper LibRaw gexiv2 gimp
:roll:

Post Reply