LibreOffice 5.4.6 + Language Packs

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
apollo
Black ninja
Black ninja
Posts: 75
Joined: 28 Oct 2017, 13:40
Distribution: 4.0 XFCE, Manjaro
Location: .bay.de

LibreOffice 5.4.6 + Language Packs

Post#1 by apollo » 22 Apr 2018, 17:25

It's about time to update my libreoffice modules to the latest release of the libreoffice-still branch.

I removed the extensions and firebase support which results in a bit smaller module:
LibreOffice 5.4.6.2

Additionally i can provide the following language packs. Feel free to ask for another one if you miss one.

german
french
italian
russian
brazilian portuguese

bour59
Samurai
Samurai
Posts: 151
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

LibreOffice 5.4.6 + Language Packs

Post#2 by bour59 » 17 Aug 2018, 13:25

hello
I have created libreoffice 610 by using update-libreoffice (32 and 64)
may I ask you the way to install the langpack fr
for such programs i prefer to use my native language
hope this can help others people
thanks in advance

User avatar
Ed_P
Contributor
Contributor
Posts: 4908
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

LibreOffice 5.4.6 + Language Packs

Post#3 by Ed_P » 17 Aug 2018, 14:06

In that the language pack downloads are .xzm modules simply putting it in the Porteus modules folder should be sufficient. Have you tried doing that?
Ed

bour59
Samurai
Samurai
Posts: 151
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

LibreOffice 5.4.6 + Language Packs

Post#4 by bour59 » 17 Aug 2018, 14:31

hello
the langpack created by apollo is for version 546
I have not tried to use it with version 610
I will try
thanks for suggestion

edit : Libreoffice is always in english

apollo
Black ninja
Black ninja
Posts: 75
Joined: 28 Oct 2017, 13:40
Distribution: 4.0 XFCE, Manjaro
Location: .bay.de

LibreOffice 5.4.6 + Language Packs

Post#5 by apollo » 17 Aug 2018, 19:18

Hi,
for 6.1 language packs, plz go here.

kind regards

bour59
Samurai
Samurai
Posts: 151
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

LibreOffice 5.4.6 + Language Packs

Post#6 by bour59 » 18 Aug 2018, 09:41

thanks, apollo
it's more comfortale with my native language :D

Kulle
Samurai
Samurai
Posts: 152
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

LibreOffice 5.4.6 + Language Packs

Post#7 by Kulle » 17 Mar 2019, 16:25

Hi apollo,
I have downloaded libreoffice_6.1.0.3_x86-64.xzm from https://porteus.rw-net.de/x86_64/modules/
I have activated Java Runtime Environment: jre-8u201-linux-x64.xzm
and activated libreoffice_6.1.0.3_x86-64.xzm
Run in terminal:

Code: Select all

guest@porteus:~$ libreoffice6.1 
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
Why? What can I do?

User avatar
Ed_P
Contributor
Contributor
Posts: 4908
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

LibreOffice 5.4.6 + Language Packs

Post#8 by Ed_P » 17 Mar 2019, 17:39

I run LibreOffice

Code: Select all

guest@porteus:/mnt/sda6/porteus4.0/Optional$ ls -l l*
-rwxrwxrwx 1 root root 187318272 Jan  4 23:29 libreoffice-6.1.4-x86_64-ru-5.0.xzm*
with

Code: Select all

guest@porteus:/mnt/sda6/porteus4.0/Modules$ ls -l j*
-rwxrwxrwx 1 root root 66187264 Jan 17 06:04 jre-8u201-x86_64-1.xzm*
Ed

Kulle
Samurai
Samurai
Posts: 152
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

LibreOffice 5.4.6 + Language Packs

Post#9 by Kulle » 19 Mar 2019, 10:55

If I used libreoffice6.1 without Java-Runtime-environment (!),
that's how it works anyway.
For the Test I created and printed a document.
So far I used Abiword. I use LibreOffice for the first time.
What is Java Runtime Environment required for?

User avatar
Rava
Contributor
Contributor
Posts: 2221
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

LibreOffice 5.4.6 + Language Packs

Post#10 by Rava » 31 Mar 2019, 17:09

As by the thread title, I activated libreoffice_5.4.6.2_x86-64.xzm and libreoffice_5.4.6.2_x86-64_langpack_de.xzm
Still, when I write text in LibreOffice writer that is in German, I don't get to see the German dictionary anywhere.

Do I have to unlock this somehow in the settings?

Here is what the menu looks like:
Image

Via the [More…] entry I could set the "language for the selection" to German, out of a long list of languages that are all not installed O___o but now I can just type gibberish and when I tell Libreoffice that the language is German, the red line below the gibberish disappears. This is not how a dictionary in any office writer program should behave.

Seems LibreOffice is not really using the German dictionary, why is that?

____________________

Update

and I just inserted an image, and resized it, and now it seems LibreOffice writer crashed. It is saying "saving document…" all the time and I cannot write on, nor can I interrupt this seemingly automatic document saving. Is this a known bug?

And when I exit LibreOffice writer and telling it to save the current document, I get this error:
Image
:wall:
Cheers!
Yours Rava

Post Reply