USM Unified Slackware Package Manager

Here is a place for your projects which are not officially supported by the Porteus Team. For example: your own kernel patched with extra features; desktops not included in the standard ISO like Gnome; base modules that are different than the standard ISO, etc...
User avatar
francois
Contributor
Contributor
Posts: 5418
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

USM Unified Slackware Package Manager

Post#391 by francois » 17 Feb 2018, 01:43

Real funny, qt-4.8 from usm tried to pull so much dependencies. When I download it from pkgs.org and txz2xzm, it turns to be the only dependency needed for smplayer. :roll:
Prendre son temps, profiter de celui qui passe.

User avatar
Ed_P
Contributor
Contributor
Posts: 4154
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

USM Unified Slackware Package Manager

Post#392 by Ed_P » 17 Feb 2018, 02:22

francois wrote:
16 Feb 2018, 23:42
Are you talking about 1) the salix problem or 2) the One or more errors occurred while usm was running?
1) and hopefully it's fix fixes 2)
Personnaly, I have fixed 1) the salix database error by choosing another server and saved it in/porteus/rootcopy/etc/usm/mirrors-salix.txt.
Yup, doing it manually or using one of bogomips's script will accomplish that.

My USM changes, /etc/usm/* & /var/usm/ will survive also as I have them saved in a module I make of my changes.
However, I was wondering if usm would run with minima snags. Or at least that we would have some kind of common problems and solution for usm.
There was a script that bogomips had that did fix a lot of the USM errors, unfortunately I don't recall it's name or location at this point. :(
Ed

jssouza
DEV Team
DEV Team
Posts: 645
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

USM Unified Slackware Package Manager

Post#393 by jssouza » 18 Feb 2018, 15:54

francois wrote:
17 Feb 2018, 01:43
Real funny, qt-4.8 from usm tried to pull so much dependencies. When I download it from pkgs.org and txz2xzm, it turns to be the only dependency needed for smplayer. :roll:
francois, smplayer can be built with qt5 as well. Were you using kde5?

User avatar
francois
Contributor
Contributor
Posts: 5418
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

USM Unified Slackware Package Manager

Post#394 by francois » 18 Feb 2018, 23:21

Good to know. No I was on xfce4. This means that smplayer alone could run on kde5.
Thanks.
Prendre son temps, profiter de celui qui passe.

Post Reply