[Solved] Date and Time setting not working

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
meet
Black ninja
Black ninja
Posts: 88
Joined: 31 Mar 2020, 04:37
Distribution: Porteus 4.0

[Solved] Date and Time setting not working

Post#1 by meet » 09 Apr 2020, 09:51

Hello.

I am running Porteus 5.0 rc1 with KDE.

When I set my time zone in the Date and Time setting and select the automatically update time setting, and click APPLY, it throws me error "Unable to authenticate/execute the action: 4,"

I am entering correct root password. So that's not the issue.

How to fix this?

Solution:
1. The System Setting > Date and time on Porteus won't allow to set the time zones. There's a bug in it and it doesn't work on Porteus 4 and 5 both.
2. Time zone can be set using Cheat code "timezone=Area/Location" in the Porteus.cfg file in Porteus folder.
However, only entering the cheatcode will not work. In my case, even after entering the cheat code, it still showed incorrect time and date.
Then I changed it using "Porteus Settings Centre". Change the time zone here, and when it asks to save changes to a module, click yes. Now the date and time will be correct across sessions / boots.
3. Set the time and date manually. Ignore the time zone, whatever is selected. This will work along with the changes save.dat file.
Last edited by meet on 11 Apr 2020, 04:01, edited 3 times in total.

User avatar
francois
Contributor
Contributor
Posts: 5786
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Date and Time setting not working

Post#2 by francois » 09 Apr 2020, 18:30

You can set timezone with the cheatcode http://www.porteus.org/tutorials/26-gen ... -them.html
timezone=region/zone

You have to put it in the porteus.cfg file.

You will find a lot of other tweaks for you porteus system.
Prendre son temps, profiter de celui qui passe.

meet
Black ninja
Black ninja
Posts: 88
Joined: 31 Mar 2020, 04:37
Distribution: Porteus 4.0

Date and Time setting not working

Post#3 by meet » 11 Apr 2020, 03:40

francois wrote:
09 Apr 2020, 18:30
You can set timezone with the cheatcode http://www.porteus.org/tutorials/26-gen ... -them.html
timezone=region/zone
Hey thanks.
Adding this cheat-code didn't work. The time was not shown correctly as per the selected time zone.

Then I ignored the time zone and just set a time and date manually, which stays across the sessions so that's great.

User avatar
francois
Contributor
Contributor
Posts: 5786
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

[Solved] Date and Time setting not working

Post#4 by francois » 11 Apr 2020, 23:17

Your computer's clock could be late. Glad that you found the solution. :)
Prendre son temps, profiter de celui qui passe.

User avatar
Blaze
DEV Team
DEV Team
Posts: 2868
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

[Solved] Date and Time setting not working

Post#5 by Blaze » 12 Apr 2020, 05:30

How about like this?

Code: Select all

su
toor
cp /etc/localtime{,.bak} && rm /etc/localtime && ln -sf /usr/share/zoneinfo/Europe/Moscow /etc/localtime && ntpdate pool.ntp.org && hwclock -lw
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

meet
Black ninja
Black ninja
Posts: 88
Joined: 31 Mar 2020, 04:37
Distribution: Porteus 4.0

[Solved] Date and Time setting not working

Post#6 by meet » 12 Apr 2020, 16:12

francois wrote:
11 Apr 2020, 23:17
Your computer's clock could be late. Glad that you found the solution. :)
Well no. The date and time in Windows works properly as per the set time zone.
Yes, adding the time zone module file through Porteus Settings Manager centre worked. Only adding cheat code didn't work.
Blaze wrote:
12 Apr 2020, 05:30
How about like this?

Code: Select all

su
toor
cp /etc/localtime{,.bak} && rm /etc/localtime && ln -sf /usr/share/zoneinfo/Europe/Moscow /etc/localtime && ntpdate pool.ntp.org && hwclock -lw
Hey thanks for the reply but I am not trying this now. The time's shown correct now and I don't wanna try anything on it.
But it may solve someone else's problem.

Post Reply