Disable of Touchscreen

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
sedersmith
Ronin
Ronin
Posts: 1
Joined: 15 Dec 2019, 14:50
Distribution: N/A

Disable of Touchscreen

Post#1 by sedersmith » 15 Dec 2019, 14:53

Hi team,

I have an old PC (Sony VAIO Duo 11) with a faulty hard drive. In addition, the PC also has a touchscreen functionality that doesn't work properly (i.e. every 5-10 seconds it moves the pointer to the left corner and performs left-click action). I'm fine to use it with a mouse, i.e. turning touchscreen off.

I have installed Porteus on a flash drive and connected it to the PC. Everything seems to work perfectly apart from the issue with the touchscreen.

I used some other Linux distributions in past and to disable the touchscreen I used 'xinput disable # [the number of the touchscreen in the system]' command (Terminal). Also, I read that potentially touchscreen could be disabled through changes to xorg.conf file, however, I cannot locate it and never tried this method.

Would you be so kind as to advise the best way to disable the touchscreen?

Regards,
Seder Smith
Tutuapp ShowBox Kodi
Last edited by sedersmith on 18 Dec 2019, 06:18, edited 1 time in total.
Thanks for accepting in the forum.

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2363
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Disable of Touchscreen

Post#2 by ncmprhnsbl » 16 Dec 2019, 03:29

welcome to porteus forum :)
looks like there's a few ways you can do it..
1. see if you can disable it at the bios level (requires accessing bios settings at/before boot and searching the settings for the relevant setting)(best since it's universal)
or
2. finding the kernel module it uses and blacklisting it
(lsmod and figuring which is the driver and adding it to /etc/modprobe.d/blacklist-<something>.conf containing line: blacklist <something> )
or
3. putting "xinput disable # " in your autostart (or even as a cheatcode: guiexec=xinput~disable~# )
or
4. adding: /etc/X11/xorg.conf.d/99-no-touchscreen.conf with this in it:

Code: Select all

Section "InputClass"
    Identifier         "Touchscreen catchall"
    MatchIsTouchscreen "on"
    Option "Ignore" "on"
EndSection
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

burdi01
Samurai
Samurai
Posts: 116
Joined: 18 Aug 2013, 12:09
Distribution: Slackware, Xubuntu
Location: The Netherlands

Disable of Touchscreen

Post#3 by burdi01 » 16 Dec 2019, 10:07

Or use a script so you can toggle your touchpad(s):

Code: Select all

#!/bin/sh

# _tp : enable/disable/toggle the touchpad(s)
# ===========================================
# (c) DLCB 28/10-2019

# Usage: _tp [0|1]   # 0=enable, !0=disable, default is toggle

DEVS="$(xinput | grep -i touchpad | awk '{print $(NF-3)}' | awk -F id= '{print $2}')"
[ -z "$DEVS" ] && exit
for DEV in "$DEVS" ; do
   [ -n "$1" ] && ON="$1" || ON="$(xinput --list-props $DEV | grep -i "device enabled" | awk '{print $NF}')"
   [ "$ON" = 0 ] && ON=en || ON=dis
   xinput --${ON}able $DEV
done
:D

User avatar
Ed_P
Contributor
Contributor
Posts: 5278
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Disable of Touchscreen

Post#4 by Ed_P » 16 Dec 2019, 19:33

:%)

Code: Select all

root@porteus:/home/guest# xinput
bash: xinput: command not found
root@porteus:/home/guest# 
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2363
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Disable of Touchscreen

Post#5 by ncmprhnsbl » 16 Dec 2019, 21:12

yeah, good point Ed, first need to install xinput for that option .. :D it's in the official slackware repo, so usm or getpkg...
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

Post Reply