PORTEUS v4 i586 - can't connect to Wifi

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
glestwid
Black ninja
Black ninja
Posts: 85
Joined: 09 Jan 2018, 20:05
Distribution: Porteus-KDE 3.2.2 i586

PORTEUS v4 i586 - can't connect to Wifi

Post#1 by glestwid » 21 Aug 2019, 15:59

I am trying to connect my Porteus to a Wifi network but having troubles doing this. Wifi adapters are available in the OS:
root@porteus:/home/guest# iwconfig
eth0 no wireless extensions.

wlan1 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

lo no wireless extensions.

wlan2 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

They even see some networks around:
oot@porteus:/home/guest# iwlist wlan1 scan|grep -i essid
ESSID:"sweet_home"
ESSID:"TP-LINK_4F5642"
ESSID:"Keenetic-0050"
ESSID:"Daniel"
ESSID:"Pifagor_2016"
ESSID:"ml448"
ESSID:"TP-Link_5590"
ESSID:"ZyXEL_kat"
ESSID:"Ne"
ESSID:"Redmi"
I created a .conf file with WPA data for my network but when I tried to connect to if from both adapters, the wpa_supplicant simply hung:
root@porteus:/home/guest# wpa_supplicant -i wlan2 -c /mnt/sdb1/dump/sweet_home.conf
Successfully initialized wpa_supplicant
^Cnl80211: deinit ifname=wlan2 disabled_11b_rates=0
wlan2: CTRL-EVENT-TERMINATING

root@porteus:/home/guest# wpa_supplicant -i wlan1 -c /mnt/sdb1/dump/sweet_home.conf
Successfully initialized wpa_supplicant
What did I do wrong with them and how should I make the Wifi connection established in my Porteus instance?

Post Reply