(SOLVED) kdeconnect; installed but won't run

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
Tolkem
White ninja
White ninja
Posts: 13
Joined: 10 Aug 2019, 05:53
Distribution: Porteus 4.0 KDE

(SOLVED) kdeconnect; installed but won't run

Post#1 by Tolkem » 10 Aug 2019, 15:03

Hi everyone! Hope you're all having a nice life! :D

I started using Porteus 4.0 KDE few days ago, althought I did try Porteus Kiosk couple of years ago. I have a lot of questions which I'll definetely make in other posts so expect to see more from me :lol: , however, so far so good except that I'd like to use kdeconnect which I succesfully installed or at least it seems that way but it won't run. It doesn't show in menu nor in krunner if I type "kdeconnect", I also tried running it from terminal to see if I could get any error messages that help me troubleshooting and got

Code: Select all

kdeconnect: command not found
Has anyone succesfully installed it and used it? If so, any advice is much appreciated.
Thanks in advance for your answers. :D
Last edited by Tolkem on 16 Aug 2019, 22:08, edited 3 times in total.

jssouza
DEV Team
DEV Team
Posts: 1033
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

kdeconnect; installed but won't run

Post#2 by jssouza » 10 Aug 2019, 17:26

Are you using 64bit or 32bit KDE? If 64bit, there is already a kdeconnect module shared for porteus 4.0 kde
KDE Connect for Porteus 4.0 KDE

Is this what you are using? If not, try activating this module. Comes up if searched from the menu as well as from krunner.

Tolkem
White ninja
White ninja
Posts: 13
Joined: 10 Aug 2019, 05:53
Distribution: Porteus 4.0 KDE

kdeconnect; installed but won't run

Post#3 by Tolkem » 10 Aug 2019, 17:34

jssouza wrote:
10 Aug 2019, 17:26
Hi, welcome to Porteus!
Are you using 64bit or 32bit KDE? If 64bit, there is already a kdeconnect module shared for porteus 4.0 kde
KDE Connect for Porteus 4.0 KDE

Is this what you are using? If not, try activating this module. Comes up if searched from the menu as well as from krunner.
Hi and thanks for the quick answer and the kind welcome! Oh Yes, sorry about that, forgot to mention that I'm using KDE 64bit. No, this one KDE Connect for Porteus 4.0 KDE is different from the one I installed which is "kdeconnect-kde-0.8-x86_64-3" according to usm. Will try this one and see if it works. Thanks again for the quick reply! :Yahoo!:

Tolkem
White ninja
White ninja
Posts: 13
Joined: 10 Aug 2019, 05:53
Distribution: Porteus 4.0 KDE

kdeconnect; installed but won't run

Post#4 by Tolkem » 10 Aug 2019, 20:53

Thanks @jssouza ! kdeconnect now works! Problem solved! :Yahoo!:

Tolkem
White ninja
White ninja
Posts: 13
Joined: 10 Aug 2019, 05:53
Distribution: Porteus 4.0 KDE

(Solved) kdeconnect; installed but won't run

Post#5 by Tolkem » 10 Aug 2019, 22:03

Seems I spoke too early :( After reboot I saw the kdeconnect icon in the taskbar and when clicked on it got this:

Image

Any idea how to solve this? Thanks.

jssouza
DEV Team
DEV Team
Posts: 1033
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

kdeconnect; installed but won't run

Post#6 by jssouza » 11 Aug 2019, 01:25

Just checked using kdeconnect on an android (it has been a while) and works fine.

Do you still have the old kdeconnect installed? That's what the error looks like. What other modules are activated besides the base modules and kdeconnect?

Tolkem
White ninja
White ninja
Posts: 13
Joined: 10 Aug 2019, 05:53
Distribution: Porteus 4.0 KDE

kdeconnect; installed but won't run

Post#7 by Tolkem » 12 Aug 2019, 00:47

jssouza wrote:
11 Aug 2019, 01:25
Just checked using kdeconnect on an android (it has been a while) and works fine.

Do you still have the old kdeconnect installed? That's what the error looks like. What other modules are activated besides the base modules and kdeconnect?
Oh yes that was it, thanks again! I deactivated and deleted the old one and now it's working again. Regarding your question about what other modules I'm really not sure about every single one of them but searching for kde modules gives me this:

Code: Select all

kde-cli-tools-5.12.3-x86_64-1jss
kde-gtk-config-5.12.3-x86_64-1jss
kdeclarative-5.45.0-x86_64-1jss
kdeconnect-kde-0.8-x86_64-3
kdecoration-5.12.3-x86_64-1jss
kded-5.45.0-x86_64-1jss
kdelibs-4.14.21-x86_64-1
kdelibs4support-5.45.0-x86_64-1jss
kdeplasma-addons-5.12.3-x86_64-1jss
kdesignerplugin-5.45.0-x86_64-1jss
kdesu-5.45.0-x86_64-1jss
kdewebkit-5.45.0-x86_64-1jss
polkit-kde-agent-1-5.12.3-x86_64-1jss
xdg-desktop-portal-kde-5.12.3-x86_64-1jss
kdeplasma-addons-5.12.3-x86_64-1jss
I'm aware some of those are part of the desktop so I'm not sure which ones were downloaded along with kdeconnect.

jssouza
DEV Team
DEV Team
Posts: 1033
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

kdeconnect; installed but won't run

Post#8 by jssouza » 12 Aug 2019, 03:21

Tolkem wrote:
12 Aug 2019, 00:47
Oh yes that was it, thanks again! I deactivated and deleted the old one and now it's working again.
Great!
Tolkem wrote:
12 Aug 2019, 00:47
Regarding your question about what other modules I'm really not sure about every single one of them but searching for kde modules gives me this:
Those are the packages that are installed.
The activated modules can be seen at the path /mnt/live/memory/images/

Code: Select all

[guest:~]$ ls /mnt/live/memory/images/
000-kernel.xzm/    003-kde.xzm/                          palemoon-27.9.0-x86_64-1.xzm/
001-core.xzm/      009-changes.xzm/                      palemoon_changes.xzm/
002-xorg.xzm/      bible.xzm/
003-cinnamon.xzm/  kdeconnect-1.3.0-x86_64-kde-jss.xzm/
You can also use the application "Porteus Modules" to check available and installed modules.
Tolkem wrote:
12 Aug 2019, 00:47
I'm not sure which ones were downloaded along with kdeconnect.
On KDE, kdeconnect does not have any other dependency.

Tolkem
White ninja
White ninja
Posts: 13
Joined: 10 Aug 2019, 05:53
Distribution: Porteus 4.0 KDE

kdeconnect; installed but won't run

Post#9 by Tolkem » 12 Aug 2019, 16:45

jssouza wrote:
12 Aug 2019, 03:21
The activated modules can be seen at the path /mnt/live/memory/images/
Ah, I see...well, this is what I got in there:

Code: Select all

000-kernel.xzm/
001-core.xzm/
002-xorg.xzm/
003-kde.xzm/
aria2-1.34.0-x86_64-1_slonly.xzm/
aspell-0.60.6.1-x86_64-1.xzm/
attica-0.4.2-x86_64-1.xzm/
c-ares-1.13.0-x86_64-1_slonly.xzm/
celt-0.11.3-x86_64-1dj.xzm/
chromium-76.0.3809.87-x86_64-es-1jay.xzm/
clucene-2.3.3.4-x86_64-2.xzm/
cmus-20180219_20a738d-x86_64-1ponce.xzm/
conky-1.10.6-x86_64-alldesktops-1bundle.xzm/
console-cyrillic-0.9.17-noarch-1.xzm/
enchant-1.6.0-x86_64-1.xzm/
es-core_locales.xzm/
es_US-locales-files.xzm/
exiv2-0.25-x86_64-1.xzm/
glew-1.13.0-x86_64-1.xzm/
glibc-i18n-x86_64-1jay.xzm/
glibmm-2.46.4-x86_64-1.xzm/
hunspell-1.3.3-x86_64-1.xzm/
icu4c-56.1-x86_64-2.xzm/
jack-1.9.10-x86_64-1dj.xzm/
jasper-1.900.1-x86_64-5.xzm/
jemalloc-3.6.0-x86_64-1.xzm/
judy-1.0.5-x86_64-1.xzm/
kde-l10n-es-17.04.3-noarch-1alien.xzm/
kdeconnect-1.3.0-x86_64-kde-jss.xzm/
kdelibs-4.14.21-x86_64-1.xzm/
libbluray-0.9.2-x86_64-1gv.xzm/
libcdio-0.93-x86_64-1.xzm/
libconfig-1.5-x86_64-1dj.xzm/
libcuefile-r475-x86_64-1gv.xzm/
libdbusmenu-qt-0.9.2-x86_64-2.xzm/
libdiscid-0.6.1-x86_64-1.xzm/
libfakekey-0.1-x86_64-1.xzm/
libffado-2.2.1-x86_64-1dj.xzm/
libiec61883-1.2.0-x86_64-2dj.xzm/
libiodbc-3.52.10-x86_64-2.xzm/
libmodplug-0.8.8.5-x86_64-1gv.xzm/
libmp4v2-2.0.0-x86_64-1ponce.xzm/
libreplaygain-r475-x86_64-1gv.xzm/
libsigc++-2.6.2-x86_64-1.xzm/
libvncserver-0.9.10-x86_64-2.xzm/
libxml++-2.40.1-x86_64-1dj.xzm/
man-db-2.8.3-x86_64-1_slonly.xzm/
mariadb-10.0.26-x86_64-1.xzm/
mhash-0.9.9.9-x86_64-3.xzm/
musepack-tools-r475-x86_64-2ponce.xzm/
ncdu-1.13-x86_64-1_slonly.xzm/
numactl-2.0.11-x86_64-1gv.xzm/
phonon-4.8.3-x86_64-2.xzm/
polkit-qt-1-0.103.0-x86_64-1.xzm/
qca-2.1.1-x86_64-2.xzm/
qjson-0.8.1-x86_64-1.xzm/
qt-4.8.7-x86_64-4.xzm/
raptor2-2.0.15-x86_64-2.xzm/
rasqal-0.9.30-x86_64-1.xzm/
redland-1.0.16-x86_64-1.xzm/
soprano-2.9.4-x86_64-1.xzm/
soundcard_config.xzm/
strigi-0.7.8-x86_64-2.xzm/
timeconfig.xzm/
vlc-2.2.4-x86_64-1gv.xzm/
xfce4-terminal-0.6.3-x86_64-bundle.xzm/
Again, not sure which ones are kdeconnect related. Thanks and sorry for the late reply.

Post Reply