Page 1 of 1

[Solved] USM system update - where did I go wrong?

Posted: 10 Jun 2019, 10:40
by nanZor
System: Porteus X86_64 ver 4.0 / XFCE
Synopsis: After my first ever system update (usm -u system), I lost the xfce4 terminal, and network manager.

Details: maybe someone can tell me where I went wrong ...

As root, I updated both usm and initiated a system wide update with (kids - don't try this until I figure out where I went wrong - this is example material)

Code: Select all

usm -u usm
usm -u system
I was then presented with a list of files to get updated, along with a warning I wasn't exactly sure about. It went something like this as the last line (going from memory here)..

<R>emove, or continue by pressing <enter>

Not the exact wording, but out of an abundance of caution, I just pressed enter. Should I have selected Remove instead??

I watched the script update the system to mostly those from Slackware 14.2 updates. It was beautiful and nearly brought a tear to my eye. :)

Modules of the updates were created in the /tmp/usm directory, and I dutifully moved them to the modules directory.

Upon reboot, and in graphics mode, the new updated modules got loaded, BUT I have two problems:

1) XFCE4 terminal is gone. Clicking on the icon says that it "Failed to execute terminal emulator - input/output error."

So I tried to bring it up manually in uxterm (very SMART to have two terminals loaded!) with

Code: Select all

xfce4-terminal &
and that got me closer to what's wrong:

"Error while loading shared libraries: cannot open shared object file: no such file or directory."

I also noticed that during reboot, the system also complained of libicu missing.

2) Network manager is gone.
Ifconfig shows no wired eth0, BUT I can see my wireless and even scan the spectrum with cli tools, but that's as far as I took it.

Recovery: not complete. Using the base_only cheatcode, the system recovers to it's prior state, BUT when I allow for my porteussave.dat changes file to be active, those missing libraries seem to have propagated into it.

So this first-time system updater borked it somehow. Willing to just start over, but if anyone can shed light on where I went wrong, I'd love to know.

USM system update - where did I go wrong?

Posted: 10 Jun 2019, 12:45
by ncmprhnsbl
from the man page:

Code: Select all

usm -u system  Will check for updates to slackware packages (experimental on Porteus).
key phrase: (experimental on Porteus) most likely would be okay on a full install of slackware 14.2 ..
why it fails: porteus 4.0 is based on slackware current(of about april 2018) so if usm was pulling 14.2 packages, they'd be downgrades..
similarly if usm is pulling packages from current(as of now) there are packages that were custom built that could be broken by mismatched libs...
suffice to say usm -u system is not recomended (at least, i wouldn't)

USM system update - where did I go wrong?

Posted: 10 Jun 2019, 15:20
by Ed_P
Wow!! nanZor :shock:

Execute usm with no operands and look at the options it displays. Note no usm -u system is listed.

When you rebooted you saved all the changes you made because you use the changes=EXIT option and you did not press a key to prevent the saving when shutting down.

To update Porteus use the Porteus menu's Administration > Porteus Settings Center > Porteus Updater option.

Hopefully you have a backup of your save.dat file that you can use to recover from.

But thank you for telling us that the -u system scenario is a BAD idea. :buhehe:

USM system update - where did I go wrong?

Posted: 10 Jun 2019, 18:54
by nanZor
Yeah, I'll check those suggestions out.

At first, I too thought that the reference to 14.2 was a downgrade, but it appears since Patrick is still backporting security issues back into 14.2 until -current arrives, the system upgrade seems to be like an upgrade, not a downgrade.

Last time I used the Porteus updater via the menus, nothing happened. I assumed this was for major security issues, and all appears good with no-news=good news right?

BUT, with usm -u system, it revealed there's a whole bunch of security issues that need addressing that aren't being seen by the gui-method of updating Porteus. I noticed things like key-revocation upgrades and the like going in..

Realizing that Slackware and Porteus are basically one-man shows with helpers, I'm not complaining! Outstanding work considering the situation. I'll have to look and see how well Nemesis updates if I think that is the proper course of action - I'm just awaiting an *official* word on that. :)

It's too bad that out of the 30,000 Slackware-till-I-die lovers over on LQ, that one of them can't lend a hand here. SURELY they know of Porteus. If no one steps up to relieve brokenman, then all the Slackware cheerleading and systemd whining is just a bunch of hot-air - aside from those great individuals providing the slack repos we draw upon of course.

Man, usm -u system just wants to work - its beautiful but I think there's a key issue that's probably *my* fault.

USM system update - where did I go wrong?

Posted: 10 Jun 2019, 19:07
by nanZor
Maybe OT:

It's been about 5 years of calling for help about Porteus being a one man show, and how Nemesis/Arch is much easier to do with just one guy.

Maybe the call for help should go out on LQ / Slackware forum and see if anyone steps up to keep their beloved distribution in the form of Porteus going?

I haven't seen it over there, and maybe they don't read the Porteus threads assuming all is well?

USM system update - where did I go wrong?

Posted: 10 Jun 2019, 22:03
by nanZor
Time to make lemonade out of this. The modular nature of Porteus easily let me get back to a known condition. Try that with a non-modular distro!

Compared the modules made by usm -u system to the graphical USM manager, and looked specifically for those labeled "UPGRADE" with that I already have downloaded. Those marked downgrade are obviously ignored, and those without any status indicator are also left out.

In the end, this is what is now in my modules directory:

Code: Select all

XFCE4-terminal was still a problem - so I rebooted with each one individually to find the culprit. That bad boy was gnutls - even though the status was an "upgrade."

gnutls-3.6.7-86_64-1_slack14.2.xzm <<---- The smoking gun!

So I'm running with this now. We'll see what breaks, but so far, so good!

Update: wget-1.20.3-x86_64-1_slack14.2.xzm was also removed from the modules, since it was whining about missing libunistring, and even when converted with the normal USM download from the repos, it was nowhere to be found. So away it went, and we are back to the oem wget.

Ok, so maybe I've got some sort of Franken-Porteus on my hands now. :) Easy enough to get to square one with the inherent modularity if I want.

USM system update - where did I go wrong?

Posted: 10 Jun 2019, 23:20
by francois
One man show with helpers. Things have changed since the crisis where fanthom forked to porteus kiosk, leaving brokenman with porteus alone. From my view, the currently available helpers could be more appropriately called team of developpers, headed by brokenman as principal developper. From what I know this team has helped a lot relieving the pressure. :)

USM system update - where did I go wrong?

Posted: 11 Jun 2019, 01:40
by nanZor
Yeah, I used the term "helpers" lightly. There's always a cadre of bright devs behind the scenes.

I guess I'm drawn to the small teams - Slackware, Porteus, Tinycore/Dcore/Picore, Knoppix, Armbian etc. I certainly wouldn't want the weight of all that support on me (or small team) of devs. Bravo to all those hanging in there.

It's been rough all around and I can understand the burn-out. All these projects hit their heights about a decade ago, and frankly, all people seem to want are application launchers without regards to what's under the hood - or the team behind it. I saw that when SLAX went browser based, Kiosk of course, and forums flooded with nothing but how do I turn my computer into a TV, radio, or other multimedia box.

There's a big *personal* touch to Porteus that attracts me so. Kind of what Unix used to be all about. People first, not applications.

I say damn the torpedoes. Just do what you love. What is it that keeps Brian Kernighan still teaching? Or Kirk McCusick STILL maintaining the Berkeley FFS after all these years? Dunno' guess that comes from within.

Still loving Porteus, not because it's old fashioned, but just because it is SO DANG COOL! :)

[Solved] USM system update - where did I go wrong?

Posted: 12 Jun 2019, 01:23
by francois
We agree. With time it becomes some kind of dependence. You look and try the other brands, but come back to the original one. It has been neatly structured, with clear access. Years of user suggestions propositions have been integrated in it. You will experience that someday, sooner than later with the next version. We are all waiting for the go of brokenman. :D

[Solved] USM system update - where did I go wrong?

Posted: 12 Jun 2019, 05:21
by nanZor
No rush! Release when ready - or not. Take the time to gauge *all* the variables. If it feels like a job, rather than a joy, then will there just be a buzz of activity and another burn-out in a decade?

Long-term decisions man. I'd hate to have to make them...