Using on Vista pc SOLVED

Post here if you are a new Porteus member and you're looking for some help.
straybit
White ninja
White ninja
Posts: 17
Joined: 29 Apr 2019, 03:07
Distribution: VectorLinux
Contact:

Using on Vista pc

Post#16 by straybit » 05 May 2019, 21:53

3.2.2 on Fat USB stick:
root@porteus:/home/guest# ping [myrouter]
connect: Network is unreachable
root@porteus:/home/guest# lspci -vnn | grep -i net
00:14.0 Bridge [0680]: NVIDIA Corporation MCP51 Ethernet Controller [10de:0269] (rev a3)
03:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 02)
...
00:02.0 PCI bridge [0604]: NVIDIA Corporation C51 PCI Express Bridge [10de:02fc] (rev a1)
Kernel driver in use: ping pcieport
Kernel modules: shpchp
00:03.0 PCI bridge [0604]: NVIDIA Corporation C51 PCI Express Bridge [10de:02fd] (rev a1)
Kernel driver in use: pcieport
Kernel modules: shpchp
...
03:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 02)
Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller [103c:1374]
Kernel modules: ssb
3.4 is on a xf4 USB stick ( also on CD)

donald
Full of knowledge
Full of knowledge
Posts: 1535
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Using on Vista pc

Post#17 by donald » 06 May 2019, 00:08

OK, back to porteus 4.0

4.0 doesn't have the wl driver so we do not need to blacklist.
remove /etc/modprobe.d/b43_blacklist.conf and broadcom_blacklist.conf
(or commend out the blacklisted files)
( make a backup copy first!)

start USM
usm -g b43
and fetch the firmware > activate the module

run
modprobe -r b43
modprobe b43

If the wi-fi is still not working check the output of
rfkill list all
and
dmesg | grep b43
if there are any issues.

straybit
White ninja
White ninja
Posts: 17
Joined: 29 Apr 2019, 03:07
Distribution: VectorLinux
Contact:

Using on Vista pc

Post#18 by straybit » 06 May 2019, 21:50

Realized as I was copying the response that I need to give a password somehow to connect with my router.
root@porteus:/home/guest# usm -g b43
find: `/tmp/xdg-runtime-guest/gvfs': Permission denied

You are missing required database files!
Please run: usm -u all

root@porteus:/home/guest# usm -u all
find: `/tmp/xdg-runtime-guest/gvfs': Permission denied
Starting slackware database update
Downloading: vercheck.txt DONE
Downloading: CHECKSUMS.md5 DONE
Downloading: MANIFEST.bz2 DONE
Downloading: PACKAGES.TXT DONE
Downloading: LIBS.TXT.gz DONE
There was a problem downloading the file:

root@porteus:/home/guest# usm -g b43
find: `/tmp/xdg-runtime-guest/gvfs': Permission denied

You are missing required database files!
Please run: usm -u all

root@porteus:/home/guest# modprobe -r b43
root@porteus:/home/guest# modprobe b43
root@porteus:/home/guest# ping 192.168.0.1
connect: Network is unreachable
root@porteus:/home/guest# rfkill list all
0: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
root@porteus:/home/guest# dmesg | grep b43
[ 806.936752] b43-phy0: Broadcom 4311 WLAN found (core revision 13)
[ 806.954366] b43-phy0: Found PHY: Analog 4, Type 2 (G), Revision 9
[ 806.954392] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2050, Revision 2, Version 0
[ 806.962458] b43 ssb0:0: Direct firmware load for b43/ucode13.fw failed with error -2
[ 806.962560] b43 ssb0:0: Direct firmware load for b43/ucode13.fw failed with error -2
[ 806.962712] b43 ssb0:0: Direct firmware load for b43-open/ucode13.fw failed with error -2
[ 806.962803] b43 ssb0:0: Direct firmware load for b43-open/ucode13.fw failed with error -2
[ 806.962810] b43-phy0 ERROR: Firmware file "b43/ucode13.fw" not found
[ 806.962813] b43-phy0 ERROR: Firmware file "b43-open/ucode13.fw" not found
[ 806.962820] b43-phy0 ERRORp sying wifi was on|connected|or somesuchd get a popu: You must go to http://wireless.kernel.org/en/users/Dri ... cefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
reboot
root@porteus:/home/guest# usm -g b43
find: `/tmp/xdg-runtime-guest/gvfs': Permission denied

You are missing required database files!
Please run: usm -u all

Activated b43 module from hard drive I did get a popup that wifi was on|connected|or some such

root@porteus:/home/guest# usm -g b43
find: `/tmp/xdg-runtime-guest/gvfs': Permission denied

You are missing required database files!
Please run: usm -u all

root@porteus:/home/guest# modprobe -r b43
root@porteus:/home/guest# modprobe b43
root@porteus:/home/guest# ping -c3 192.168.0.1
connect: Network is unreachable
root@porteus:/home/guest# rfkill list all
0: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
root@porteus:/home/guest# dmesg | grep b43
[ 269.901560] b43-phy0: Broadcom 4311 WLAN found (core revision 13)
[ 269.919148] b43-phy0: Found PHY: Analog 4, Type 2 (G), Revision 9
[ 269.919175] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2050, Revision 2, Version 0
[ 270.168062] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 270.408067] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)

donald
Full of knowledge
Full of knowledge
Posts: 1535
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Using on Vista pc

Post#19 by donald » 06 May 2019, 23:43

The last output looks good to me 'afaics'
no firmware errors.
(put the firmware module in the modules folder to be loaded at boot-up)
I need to give a password somehow to connect with my router
Yep..credentials are required. :)
Did you create a connection profile with your credentials in network-manager?
(right-click > edit connections > new/add > wifi..)

right-click the network-manager icon
Is there a checkbox to en-/disable the wifi?

Do you see other wifi networks if you left-click this icon?

does iwlist scan (as root) show wifi networks?

straybit
White ninja
White ninja
Posts: 17
Joined: 29 Apr 2019, 03:07
Distribution: VectorLinux
Contact:

Using on Vista pc

Post#20 by straybit » 08 May 2019, 00:36

Put b43 into modules and configured wifi network using settings>network connections. (I have found no other entry dealing with network in the menu. I running XFCE if that matters.)
reboot and shows networks available. Took me a while but I finally found the Network button on the desktop after I had closed or moved the windows.
Whether i right or left click, I get the same message:
Failed to open "/ on".
Message recipient disconnected
from message bus without trying.
root@porteus:/home/guest# ping -c3 192.168.0.1
connect: Network is unreachable
iwlist scan shows lots of networks along with mine - even after reboot.
AND, after reboot, there is no network button on the desktop, but there is "Browse Network" in Thunar which acts the same.

donald
Full of knowledge
Full of knowledge
Posts: 1535
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Using on Vista pc

Post#21 by donald » 08 May 2019, 01:04

I running XFCE
same do i
I have found no other entry dealing with network
There should be a netwok (manager) icon in the panel (top right)
iwlist scan shows lots of networks along with mine
This clearly indicates that the wifi is up and running.

nanZor
Samurai
Samurai
Posts: 185
Joined: 09 Apr 2019, 03:27
Distribution: Porteus 5.0 RC1 XFCE
Location: Los Angeles

Using on Vista pc

Post#22 by nanZor » 08 May 2019, 06:33

Straybit - donald is right - your wifi is up, but you just have to make the connection now. Two ways of doing it:

1) Use Settings > Network Connections

Use the + icon to manually add a known network name. Answer the prompts. When done, you may want to go into the "General" tab, and click [X] Automatically connect to this network when it is available.

or

2) In the top panel of XFCE where the clock and other icons live, you should see a circular blue world icon. Click and a dropdown will appear. Click on your access point name, and answer the prompts.

Note that if you are *already* connected for some reason, that network manager icon may turn mostly gray - and in many of the current XFCE themes, might look like the icon is missing. Well, maybe for us older guys with glasses on. :) Sometimes changing our theme to Adwaita-dark will help to see it.

I think you may be just a click or two away...
That's a UNIX book - cool. -Garth

straybit
White ninja
White ninja
Posts: 17
Joined: 29 Apr 2019, 03:07
Distribution: VectorLinux
Contact:

Using on Vista pc

Post#23 by straybit » 08 May 2019, 11:15

Thank you for your patience with me Donald. Thanks, also, for pointing out the icon - pictographs are a strange language to me. I´m using palemoon to write this - once I remebered to sign in :crazy:
You are right, nanZor. It turned into a light gray triangle.
And I even got thunar to start with Compact List. Boy! I am going to have fun again.

straybit
White ninja
White ninja
Posts: 17
Joined: 29 Apr 2019, 03:07
Distribution: VectorLinux
Contact:

Using on Vista pc

Post#24 by straybit » 08 May 2019, 12:06

Uh! I didn't see any way to mark this thread solved. Of course - I'm blind in one eye and can't see out of the other three! :wall:

User avatar
Ed_P
Contributor
Contributor
Posts: 5069
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Using on Vista pc

Post#25 by Ed_P » 08 May 2019, 12:37

To add Solved edit your 1st posting and change the title. ;)
Ed

Post Reply