[SOLVED]Can't find wifi on Qualcomm Atheros Device

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
ppp
White ninja
White ninja
Posts: 7
Joined: 25 Dec 2018, 13:25
Distribution: Deepin 15.8 => Porteus-KDE-v4.

[SOLVED]Can't find wifi on Qualcomm Atheros Device

Post#1 by ppp » 25 Dec 2018, 14:51

Merry Christmas everyone!
I find that my 64bit porteus with KDE can't find any wifi even in the xpns-tool (I got a blank in the scan results). And I read the FAQ in the homepage and tried lspci -knn command, the results are:

Code: Select all

...
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
        Subsystem: Lenovo Device [17aa:505b]
        Kernel driver in use: r8169
        Kernel modules: r8169
05:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 31)
        Subsystem: Lenovo Device [17aa:0901]
        Kernel driver in use: ath10k_pci
        Kernel modules: ath10k_pci
What's more, my result for the dmesg | grep b43 is totally blank.

So I think my wireless card is not the Broadcom, and those b43 driver can't help my wifi card. What can I do to get connect with my wifi? :sos:

I'm new to linux and even newer to porteus, sorry for my nearly zero background knowledge and my poor English.
Last edited by ppp on 27 Dec 2018, 09:31, edited 1 time in total.

donald
Full of knowledge
Full of knowledge
Posts: 1532
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Can't find wifi on Qualcomm Atheros Device

Post#2 by donald » 25 Dec 2018, 18:03

Hello ppp

Could be that some firmware files are missing.
Some folder in /lib/firmware/ath10k/* are empty in porteus 4.0 but
not in 3.2.2

Copy the files from 3.2.2 ,reboot - if it works,good - if not
post the output of the rfkill list command.

firmware files can also be found at:
http://anduin.linuxfromscratch.org/BLFS ... re/ath10k/

ppp
White ninja
White ninja
Posts: 7
Joined: 25 Dec 2018, 13:25
Distribution: Deepin 15.8 => Porteus-KDE-v4.

Re: Can't find wifi on Qualcomm Atheros Device

Post#3 by ppp » 26 Dec 2018, 03:00

Hi donald!

Thank you for your suggestion, but I tried both way, and none of them succeeded.

The output of the rfkill list command:

Code: Select all

0: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
As you can see, there's no wireless lan.

I thought maybe this can help you locate the problem, I tried the dmesg in the FAQ:

Code: Select all

root@porteus:/home/guest# dmesg | grep ath10k
[    6.563776] ath10k_pci 0000:05:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    6.783593] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:05:00.0.bin failed with error -2
[    6.783611] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/cal-pci-0000:05:00.0.bin failed with error -2
[    6.805172] ath10k_pci 0000:05:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 17aa:0901
[    6.805174] ath10k_pci 0000:05:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[    6.805542] ath10k_pci 0000:05:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[    9.870008] ath10k_pci 0000:05:00.0: unable to read from the device
[    9.870011] ath10k_pci 0000:05:00.0: could not execute otp for board id check: -110
[    9.870012] ath10k_pci 0000:05:00.0: failed to get board id from otp: -110
[    9.870035] ath10k_pci 0000:05:00.0: could not probe fw (-110)
[  166.880117] Modules linked in: ipv6 snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_codec_generic uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common btusb btrtl btbcm btintel bluetooth ecdh_generic intel_rapl coretemp kvm_intel kvm irqbypass crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel pcbc ath10k_pci aesni_intel ath10k_core nouveau aes_x86_64 crypto_simd glue_helper ath cryptd intel_cstate mac80211 intel_rapl_perf i915 snd_hda_intel snd_hda_codec snd_hda_core cfg80211 snd_hwdep input_leds i2c_i801 thinkpad_acpi nvram snd_pcm r8169 mxm_wmi snd_timer rfkill mii ttm wmi mei_me led_class intel_gtt mei intel_pch_thermal shpchp
I think it means I have a driver for my card, but the driver is broken?

donald
Full of knowledge
Full of knowledge
Posts: 1532
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Can't find wifi on Qualcomm Atheros Device

Post#4 by donald » 26 Dec 2018, 08:12

Hi ppp
This looks promising - read the comments -
https://askubuntu.com/questions/994555/ ... stallation

Firmware files (download the zip archive) at
https://github.com/kvalo/ath10k-firmware

..reboot, check with rfkill list all

ppp
White ninja
White ninja
Posts: 7
Joined: 25 Dec 2018, 13:25
Distribution: Deepin 15.8 => Porteus-KDE-v4.

Re: Can't find wifi on Qualcomm Atheros Device

Post#5 by ppp » 27 Dec 2018, 06:04

Thank you donald!!!!!!

I followed the askubuntu instructions, overrode the .../QCA9377/hw1.0/firmware-5.bin I extracted from Porteus 3.2.2, and rebooted.

Now there's no need to rfkill list all because I already can connect wifi! I'm using wifi to post this! :celebrate14:

User avatar
brokenman
Site Admin
Site Admin
Posts: 6094
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil
Contact:

Re: [SOLVED]Can't find wifi on Qualcomm Atheros Device

Post#6 by brokenman » 27 Dec 2018, 16:04

I followed the askubuntu instructions, overrode the .../QCA9377/hw1.0/firmware-5.bin
I shall include it in initrd.xz. Thanks for the report and thanks donald for sorting it out.
How do i become super user?
Wear your underpants on the outside and put on a cape.

donald
Full of knowledge
Full of knowledge
Posts: 1532
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: [SOLVED]Can't find wifi on Qualcomm Atheros Device

Post#7 by donald » 27 Dec 2018, 19:21

brokenman wrote:
27 Dec 2018, 16:04
I shall include it in initrd.xz.
??

Porteus 3.2.2
/lib/firmware/ath10k/QCA9377/hw1.0/ contains board.bin board-2.bin firmware-5.bin

Porteus 4
/lib/firmware/ath10k/QCA9377/hw1.0/ is empty

The Firmware files are missing!

User avatar
brokenman
Site Admin
Site Admin
Posts: 6094
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil
Contact:

Re: [SOLVED]Can't find wifi on Qualcomm Atheros Device

Post#8 by brokenman » 28 Dec 2018, 21:49

Yes. Between 3.2.2 and somewhere in 4 the firmware files were removed from 000-core.xzm and left for maintainers to include as a package. During the strip of the full firmware package the atheros firmware was removed. I just read I put initrd when I meant 000-core.xzm. Sorry.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
brokenman
Site Admin
Site Admin
Posts: 6094
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil
Contact:

Re: [SOLVED]Can't find wifi on Qualcomm Atheros Device

Post#9 by brokenman » 31 Dec 2018, 17:33

I just checked after running my kernel firmware strip and the firmware for /lib/firmware/ath10k/QCA9377/hw1.0 is still present. Should be OK for next release. Please report any firmwares that are missing during bug reports. I can always add them back in. Thanks.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply