OpenShot not working

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
fulalas
DEV Team
DEV Team
Posts: 1456
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

OpenShot not working

Post#1 by fulalas » 01 Dec 2018, 05:31

Can anypne run OpenShot using the AppImage format? When I try any of these versions here I get the following error:

Code: Select all

/tmp/.mount_g0Iots/usr/bin/launch: symbol lookup error: /usr/lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var
Plus: does anyone know how to extract an AppImage that doesn't run properly and repack it back to an AppImage? I managed to extract it using P7zip, but after repacking it (using this) it doesn't start the running process anymore even if I don't touch anything. :unknown:

User avatar
Blaze
DEV Team
DEV Team
Posts: 2720
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

OpenShot not working

Post#2 by Blaze » 01 Dec 2018, 07:17

In Cinnamon I have this output:

Code: Select all

root@porteus:/home/guest/Загрузки# ./OpenShot-v2.4.3-x86_64.AppImage 
/root/.cache/thumbnails/normal/6fcb23779b2b7fe886a783133637985d.png is missing. Probably not running ./bin//openshot-qt.wrapper from within an AppImage.
Hence falling back to using .DirIcon
./bin//openshot-qt.wrapper: строка 110:  3589 Аварийный останов         LD_LIBRARY_PATH="" zenity --question --title="$TITLE" --text="$TEXT" 2> /dev/null
Loaded modules from current directory: /tmp/.mount_Mu6gLX/usr/bin
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/cx_Freeze-4.3.4-py3.4-linux-x86_64.egg/cx_Freeze/initscripts/Console.py", line 27, in <module>
  File "openshot_qt/launch.py", line 54, in <module>
    from classes.app import OpenShotApp
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 2237, in _find_and_load
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 2226, in _find_and_load_unlocked
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 1200, in _load_unlocked
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 1129, in _exec
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 1471, in exec_module
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 321, in _call_with_frames_removed
  File "/tmp/.mount_Mu6gLX/usr/bin/classes/app.py", line 34, in <module>
    from PyQt5.QtWidgets import QApplication, QStyleFactory, QMessageBox
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 2237, in _find_and_load
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 2226, in _find_and_load_unlocked
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 1191, in _load_unlocked
  File "/usr/lib/python3.4/importlib/_bootstrap.py", line 1161, in _load_backward_compatible
  File "ExtensionLoader_PyQt5_QtWidgets.py", line 22, in <module>
  File "ExtensionLoader_PyQt5_QtWidgets.py", line 14, in __bootstrap__
ImportError: /usr/lib64/libGL.so.1: undefined symbol: xcb_dri3_get_supported_modifiers
root@porteus:/home/guest/Загрузки#
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

fulalas
DEV Team
DEV Team
Posts: 1456
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

OpenShot not working

Post#3 by fulalas » 01 Dec 2018, 07:33

Oh, gosh... It's even worse than I thought. The whole idea of this AppImage thing is to run applications agnostically (i.e. regardless of your system as long it's Linux and uses the right architecture). But people who create these images do that using Ubuntu-likes, so they don't include all dependencies. :wall:

So I guess the only way is to understand how to unpack, include what's missing (in my case I guess it's just a matter of updating freetype2) and then re-pack. :sos:

Thanks for your help anyway, Blaze! :good:

User avatar
brokenman
Site Admin
Site Admin
Posts: 6096
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v4 all desktops
Location: Brazil
Contact:

OpenShot not working

Post#4 by brokenman » 01 Dec 2018, 13:04

I went through a time of playing with appimage thinking it was a great idea. Not as reliable as the concept leads one to believe. I found more that didn't work than worked.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply