Page 1 of 1

[SOLVED] Mounting FTP share - read/write mode startup

Posted: 14 Jan 2014, 21:53
by amplatfus
Hi all,

I managed to automount at startup a ftp folder with curlftpfs-0.9.2-i686-1cf.xzm and rc.d local something like:

Code: Select all

curlftpfs -o allow_other user:**** /mnt/ftpmount
After this, I am not able to write on /mnt/ftpmount even with root.
From google I know :) ( ... ange-files) that I have to edit fstab with a line something like:

Code: Select all

curlftpfs#ftp://user:pass@IP /media/FTP fuse rw,uid=1000,gid=1000,umask=002,user,suid,allow_other,exec,auto,utf8,_netdev  0   0
I have tried this, but failed until now. Because fstab is overwritten. In rc.local is not working. Even in .bashrc this command is not working

If anybody could give here a hint in order to have a ftp mounted read/write working in Porteus (if is possible, a very low mb space cost), please reply.
PS: I am using LXDE 3.0 RC Dec 2013 on 32bits

[SOLVED] Re: Mounting FTP share - read/write mode startup

Posted: 19 Jan 2014, 12:20
by amplatfus
Good news :)

This is it:
1. Activate curlftpfs-0.9.2-i686-1cf.xzm
2. Edit your etc/rc.d/rc file:

Code: Select all

mkdir /mnt/ftpmount
# echo '

' >> /etc/fstab
echo '#ftp mount points' >> /etc/fstab
#echo ' /mnt/ftpmount fuse rw,uid=14,gid=50,umask=000,user,suid,allow_other,exec,auto,_netdev  0   0' >> /etc/fstab

( until ping -q -W4 -c1 &>/dev/null; do
         sleep 5
         mount -a
         ) &
Additional related terminal commands (not required):

Code: Select all

#UID and GID must be from locally porteus ftp user.
#You could list by terminal: id.
#If needed, you could add user, add group. Maybe you need:
#id ftp
#groups ftp
#useradd ftp
#groupadd ftp
#usermod -G ftp -a ftp
# ... ange-files
# ... linux.html

All the best,