Page 1 of 1

Using non-default modules?

Posted: 04 Nov 2013, 19:07
by KitsuneSamurai
Alright, I just started using Porteus about two weeks ago, and it's done what I wanted so far: let me use my computer while I replace the hard drive. I've grown to like it, however, and wanted to do a bit more with it. However, I've run into difficulties with using modules that weren't one of the things you could get built-in when downloading Porteus.

For example, I can't get Wine to load a program I know is compatible with wine (Gargoyle, and IF interpreter), even though I am using the wine module from the Porteus repository. I tried converting the linux gargoyle.deb file from their repository into a module, and running it that way, but after activating the module, I can't find it.

That has been the case with every module I've tried to install that didn't come straight from the PPM, and a few from the PPM.

I followed a wine tutorial, but apparently, there is supposed to be a .wine folder in the home directory? There is not one, even when hidden files are shown.

If possible, I'd also like to know where the actual executable files are stored in Linux. That would probably help a great deal in the future.

Re: Using non-default modules?

Posted: 05 Nov 2013, 11:38
by fanthom
are you on 64bit or 32bit arch?
i guess that dependencies are not resolved for non porteus modules. you could confirm this by running 'slackyd -d app_name' command. if module comes from deb or rpm then slackyd wont be able to check it. best way is to run it from terminal and watch for error messages.
where can i download Gargoyle and IF interpreter?

please run 'echo $PATH' to fine where executables are stored. if you want to track the content of specific module then please go to:

Code: Select all


Re: Using non-default modules?

Posted: 05 Nov 2013, 22:14
by KitsuneSamurai
Sorry, I am using a 64 bit architecture.

The error message I get when running gargoyle from the console is

Code: Select all

guest@porteus:~$ gargoyle
gargoyle: error while loading shared libraries: cannot open shared object file: No such file or directory
I don't quite know how to get additional libraries, as I am new to linux, and would greatly appreciate help doing so.

I didn't notice my typo before. That was supposed to read Gargoyle, AN IF interpreter. The code repository for the program is

I've given up on wine at this point. Every time I run something related to wine, it says "Failed to execute child process "wine" (No such file or directory)." It is clearly located right where the module unpacks it, under the /usr/bin/wine. The same thing happens when I run any linux executable save for built-ins like Firefox and Abiword.

Re: Using non-default modules?

Posted: 05 Nov 2013, 23:00
by wread
If I were you I would run gargoyle directly in windows and use linux for linux applications.....


Re: Using non-default modules?

Posted: 06 Nov 2013, 01:56
by KitsuneSamurai
wread wrote:@KitsuneSamuai
If I were you I would run gargoyle directly in windows and use linux for linux applications.....

I would love to! Thank you for being ever so helpful! I'll go right out and buy a brand new hard drive and another copy of a new OS for several hundred times what is in my bank account right now.

If you couldn't see the sarcasm dripping from my words, allow me to point it out for you. There it is. Do you see it?

Now, if someone would actually like to help me get the linux version of that program up and running, like fanthom was trying to do, I would greatly appreciate it.

EDIT: I noticed that the wine module said i486, so I started rooting around in, and stumbled across the readme in the extras section. I had downloaded wine from the packages section, which does not have that readme. I did not realize that I needed the compat32 libraries. wine now works fine, but I still cannot get other linux programs to work.

Re: Using non-default modules?

Posted: 06 Nov 2013, 02:39
by linuxnoob
if your using 32bit wine make sure you also have the compat32 module, alternatively you can use the 64 bit version which is on the 64 bit modules part of this forum.

wine can be run from the terminal like this:

Code: Select all

wine myprogram.exe
or you can just double click from your file manager, just make sure your mimetypes are setup correctly.

hope that helps.

Re: Using non-default modules? [SOLVED]

Posted: 06 Nov 2013, 03:48
by KitsuneSamurai
Alright, I have wine working now. ...Still can't get Linux anything to work, save for the things mentioned earlier. Still getting missing library errors when I try to run it.

I think I'm just going to give up on this one. Thanks anyway.