Page 1 of 1

Changing mount point

Posted: 30 Sep 2013, 08:48
by bshogeman
In Porteus 2.1 the /mnt is used for removable media and the /mnt/live folder. In porteus 2.0 was this /mnt/live and /media for all removable media.
Is there a way I can change the mount point back to /media for removable media? I use Porteus as thinclient for diskless stations.
Removable media must be visible for users but they don't (want to) understand you can't use the folder called live.
FreeRDP doesn't have an option to hide or excluse a folder in the drive redirection so the only option is to change the mount point.

Re: Changing mount point

Posted: 30 Sep 2013, 15:08
by fanthom
hi bshogeman,

for clarification: /mnt/live is used only for drives found during boot and used by linuxrc (saving changes, loading modules), removable media added during live session are never mounted there.
if you want to use /media instead of /mnt then please edit /sbin/udev-fstab-update and update 'MNTPT' variable:

Code: Select all


[Solved] Re: Changing mount point

Posted: 02 Oct 2013, 13:42
by bshogeman
I described it some wrong. But you understand it.

Tnx, editing that file solved the issue.
Removable media now isn't mounted anymore under /mnt but under /media so (terminal server) users don't see the live folder anymore when browsing to their usb stick.

Re: Changing mount point

Posted: 07 Oct 2013, 10:05
by bshogeman
Folder isn't removed after removing the removable media. The script looks right and seems to use the MNTPT variable. Also mounting of removable media is successful.
Also when booting with the cheatcode nohd and the variable is changed to /media the folder for the HD is created but not mounted. When the folder was unchanged the folder wasn't created.

hm tested again and when not modifying the file the same issue happends when you not savely remove the usb media. And from a rdp sessions save remove is impossible.
Work-a-round possible that the folder is deleted? Checked the /etc/fstab and there the entry is removed.

Re: Changing mount point

Posted: 07 Oct 2013, 16:32
by fanthom
maybe you could add a delay there?

Code: Select all

elif [ "$ACTION" = remove ]; then
    # Delete fstab entry:
    sed -i "/$DEVICE /d" $FSTAB
    # Remove the mount point:
    sleep 3
    rmdir $MNTPT 2>/dev/null
btw: few days ago i was pushing some fixes to 001-core and some of them were 'udev-fstab-update' related. please make sure you synced this update through PSC -> Porteus Updater.