Page 1 of 1

Truecrypt Problem

Posted: 21 Mar 2013, 11:08
by lukaluki

I just created a large truecrypt file 150GB on a ssd. When mounted on Truecrypt 7.1 on porteus 2.0 Final 64Bit (KDE) there is a freeze problem when accessing a folder on the mounted truecrypt volume: It just feezes up and the dolphin explorer window hangs up.

The Volume is ntfs, I tried to use the truecrypt "check volume" function but it gives error:
fsck 1.42.6 (21-Sep-2012)
fsck: fsck.ntfs: not found
fsck: Error 2 while executing fsck.ntfs for /dev/mapper/truecrypt3
is there any way to debug the error and find out what is going on?
I created a 100mb test container on another sd-card and accessing subfolders just works fine.

EDIT: I now tested with older version of porteus (Porteus-v2.0 64bit: Linux 3.4.4.porteus - KDE 4.8.4) using the same Truecrypt xzm and it works without any problems!
Porteus 2.1 Final 64Bit (KDE) seems to have a problem with the truecrypt container , do you have any idea why ?

Thanks and kind regards

Re: Truecrypt Problem

Posted: 21 Mar 2013, 12:03
by Hamza
Please download & activate this module. This should fix your problem.


Re: Truecrypt Problem

Posted: 30 Jul 2013, 07:40
by pchan

I am a new user of Porteus2 xfce. I am also using Puppy Linux.

I simply love the boot up speed and the shutdown speed of Porteus. I have been looking for something like this for a long time.

I have successfully installed Porteus to my 4gb sdcard and created a save changes.dat in my sdcard.

I tried to download truecrypt and activate it. For some reasons, I am not able to do it.

Will be thankful if someone can guide me through the steps I need to do in order to install "Truecrypt."



Re: Truecrypt Problem

Posted: 30 Jul 2013, 16:42
by fanthom
hello pchan,

did you activate truecrypt through PPM? what's the error you are getting?

Re: Truecrypt Problem

Posted: 31 Jul 2013, 10:05
by pchan

Thank you very much for the prompt attention.

I tried again and this time i successfully installed truecrypt7.1.

This is what i did.

I launched the pakage manager.
Clicked on search> typed truecrypt>downloaded truecrypt>

2 files were downloaded to my root folder. - "sudo-1.8.5p2-i486-1.xzm" and "truecrypt-7.1a-i486-2alien.xzm"

A dialogue box opened up asking me if i would like to merge before activating. I didn't understand so I clicked to close the dialogue box.

I went to the root folder. I right clicked on the file named, "truecrypt." I selected open by activating the module. The program was installed and i found the truecrypt listed in program menu under system.

I then copy the 2 files, "sudo-1.8.5p2-i486-1.xzm" and "truecrypt-7.1a-i486-2alien.xzm" into my /porteus/modules directory.

Itested the program, truecrypt and it worked perfectly.

Earlier, it didn't worked when i used the pakage manager to activate. I was getting error messages that it was not porteus module and had to abort. But by going to the /root folder using thunar file manager and doing the right click thing, it worked!

Anyway, I am very happy that i can use true crypt 7.1 in porteus.

I am now looking for something that will unpack rar achives. Something that is easy to use like winrar or 7zip.

I am starting to love Porteus and the boot up speed and shutdown speed is my most favorite feature. I tried bodhi, linus lite, ubuntu, lubuntu, wattos, but they take too long time to boot. Xpup wa the only one that booted fast but development has stopped. And the operating system sometimes hangs because i clicked on something wrong. So, it is like something is not yet complete.

Porteus is the best. The only thing that can compete with porteus is puppy linux. Puppy linux is great but the boot speed porteus is for now still the best. I also like the flexibility of where i can place the save.dat file.

I have created a bootable porteus on my 4gb sdhc fat32 memory card and it works great. I have also made porteus to boot up in one of my hard disk partition.

Very nice!