Page 1 of 1

Archiver not working? Missing package?

Posted: 27 Jul 2012, 19:06
by thundermane

First of all, I love Porteus. Keep up the good work.

I am an internet cafe owner and I use a multiboot USB for my tools. I keep another lightweight distro on that USB for emergencies and yesterday, I finally got to make full use of it. Unfortunately, I found the environment too "alien" to work with; the task that I thought was simple took me an hour. So today, in search of another lightweight distro, I found Porteus.

So using some google-fu, I added Porteus into my multiboot USB (using grub4dos which was already there). Then to test Porteus, I decided to do some "real work" on it: edited my menu.lst and added a splash image onto the USB. That's when my issues started.

By the way, I added the cheatcode "toroot" on my Porteus install. I'm spoiled by Windows so I prefer not to be always bothered by the root password.

So there was the image already converted into .xpm. I right click on it in Thunar, and click "create archive." It gave me an error, something like no suitable archiver. Weird.

So I went to look for it in the menu. "Squeeze" seemed aptly named so I opened that and dragged the .xpm image into it... nothing! I click on the "Create Archive" button... no file was created, but the title bar says "Squeeze - file.gz" So ok, I thought, maybe I need to manually add the file... but after navigating to the file, clicking the "Add" button just made the dialog disappear. There is no file listed in Squeeze. Tried it again and again... no luck.

Finally, I went to the Package Manager and added "fsArchiver" from the list. It downloaded, and activated... but where is it? It is nowhere listed in the menus. Right clicking on the image file again to "create archive" gives the same error.

Out of frustration, I went back to Windows and finished the task in less than 5 minutes. Then I found I want to improve the contrast of the image a bit, decided to try the task again in Porteus.

Same problems, logged in as root. Out of curiosity, I logged out, logged in as guest, the "create archive" option in Thunar worked! But I still cannot create a .gz file of the .xpm in Squeeze. Though a managed to create a .tar.gz file. But they aren't the same, are they?

fsArchiver is still not listed in my menus. But it is still there in the modules folder, and it is still "activated."

What is going on?

Re: Archiver not working? Missing package?

Posted: 28 Jul 2012, 07:25
by Ahau
Welcome, thundermane!

I wasn't able to exactly recreate your issues with squeeze, particularly the bit about "no suitable archiver". I did get that on some older RC versions when I failed to recompile some packages against newer XFCE libraries, but that should have been resolved in 1.2 final. That said, I did try out some different filetypes in squeeze, and some of them worked and others failed to do anything, without giving an error message.

fsArchiver is a CLI (command line interface) tool, so there is no menu item for it. To use it, you would need to open a terminal and type, 'fsarchiver' to get a list of usage options, and run it all in text mode (though it does appear to have a text-based dialog that might be easier to navigate). I think it's more of a rescue/backup tool than a day-to-day archiver.

Please try downloading 'file-roller'. It's in the 64-bit repo (I'm assuming you're using 64-bit because that's the only place I found fsarchiver), and works with the thunar archive plugin. You'll have to select "Archive Manager" from a popup the first time you right click and select to archive something, or you can run it from the menu, accessories->archive manager.

Unless I come across something better, I'll probably include file-roller in the next release and drop squeeze (unless it gets a miraculous update). There's been a few issues with it.

I hope that helps...let us know if it doesn't, or if you have any other questions.

Re: Archiver not working? Missing package?

Posted: 28 Jul 2012, 15:50
by thundermane
Thanks for checking, Ahau.

Actually I've been thinking Squeeze might still be buggy. It is still version 0.2, after all. As for fsArchiver, I guess that is typical newbie mistake on my part.

I'm now on an "Always fresh" session and I'm getting that error again. The error dialog says "Failed to create archive. No suitable archive manager found." But from what you said, I may have to download the ISO again. I am pretty sure I got it from the "current" directory of "porteus/x86_64" from this site, but I'll try again. Will give you further feedback once that is downloaded and I have my multiboot USB redone.

Thanks again for the quick response. Cheeers!

Posted after 1 hour 50 minutes 47 seconds:
Same error. "No suitable archive manager found."

I even used Unetbootin and installed only Porteus on the USB, thinking that perhaps my method of extracting from the ISO is affecting it somehow. I'm using it now and still getting the error.

After I installed file-roller like you suggested, Squeeze was listed there along Archive Manager. That was only a one time prompt though, it's not asking me again after choosing the latter.

So I guess that's it. Thanks for the great support. You might want to check out the ISO, because from what you said, that may be the RC and not the final release. I got the file "/porteus/x86_64/current/Porteus-XFCE-v1.2-x86_64.iso" dated 2012-Jul-04 09:18:40. As for me it will be moot since will be using file-roller once I revert this USB back to multiboot.

Looking forward to your next release. =)

Re: Archiver not working? Missing package?

Posted: 30 Jul 2012, 19:52
by Ahau
Thanks, thunermane, glad file-roller is working for you. It looks to me like you have the right ISO -- so I'm still a bit perplexed as to why you're getting this error, and I've not been able to reproduce it. Your method of extracting and installing shouldn't have anything to do with this issue. If anyone else out there is having this problem, please speak up. Otherwise, look forward to a different archive manager (file-roller, probably) in 2.0.

IMO, Squeeze isn't buggy due to a low version number, it's buggy due to being old code that hasn't been updated. I think that version is now about 4 years old. I ran into bugs when running the latest code from git, so I reverted to that, the last stable release. I think I evaluated file-roller, but wasn't happy with some dependencies it brought in (ORBit and GConf), which I was trying to eliminate from Xfce. I did eliminate them, but fanthom brought them back when he introduced Network now file-roller will install without any additional dependencies (in fact, I even compiled it on ARM and it seems to be working).