Module activated but not recognized?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
alwaysfunk
White ninja
White ninja
Posts: 11
Joined: 16 Mar 2020, 17:48
Distribution: Desktop

Module activated but not recognized?

Post#1 by alwaysfunk » 16 Mar 2020, 17:57

I'm opening two threads for separate issues. I have downloaded and activated Palemoon from the browser selector. I'm on a USB stick formatted as ext4, Cinnamon desktop, persistence works fine.
There is no icon on the desktop or the menu for the application, although it launches just fine from terminal and counts as "activated". It does not appear in the list of applications, e.g. I cannot select Palemoon as the default browser in "favorite apps". I cannot find a solution online, and I don't have the terminal skills to figure out anything.
I managed by fiddling around to finally create a shortcut, but I think it's a launch shortcut instead of a proper application shortcut (it's a gear icon instead of the Palemoon logo). What can I do to check what's going on?

At the same time I'm having a big issue with creating databases on USM, which may be related, but I'll open a different topic for it.

User avatar
Ed_P
Contributor
Contributor
Posts: 5539
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Module activated but not recognized?

Post#2 by Ed_P » 16 Mar 2020, 22:42

What version of Porteus are you using? USM doesn't work on the test version of Porteus 5.0.
Ed

alwaysfunk
White ninja
White ninja
Posts: 11
Joined: 16 Mar 2020, 17:48
Distribution: Desktop

Module activated but not recognized?

Post#3 by alwaysfunk » 16 Mar 2020, 23:31

Ed_P wrote:
16 Mar 2020, 22:42
What version of Porteus are you using? USM doesn't work on the test version of Porteus 5.0.
I am using version 4.0. I first burned on a DVD and then used Install Porteus to create a bootable USB (ext4). The other issue I am experiencing, now that I fixed the other database issues, is that it says "fatal error: could not find LIBS.TXT" when using USM, but there's another user with this issue so maybe I'll talk about it there as it might be unrelated.
Palemoon is version 28.8.4 installed from the browser selection tool. I didn't get the server module, I got the latest version, moved it as root to /modules/ activated it, everything works perfectly fine as far as the browser goes, it just doesn't register correctly. It's not listed under "internet" in the panel, but under "other".
I do not have any error logs to give you since, well, there are no errors I have seen anywhere.

Scratch that, it looks like I installed 5.0 instead of 4 (Porteus-CINNAMON-v5.0rc1). I had no idea it was a test version. I'll stick to the stable one.

Post Reply