Disable powersaving

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
Buurman
White ninja
White ninja
Posts: 9
Joined: 28 Oct 2019, 18:00
Distribution: ver5

Disable powersaving

Post#1 by Buurman » 02 Nov 2019, 19:43

Porteus 5 RC

How do i disable powersaving functions ? (desktop)
no GUI for it and there are several files that point to power-management ..


problem: power goes halt/hibernate (screen off, sound off etc) because no mouse input .. it just goes off while listening to music or playing game with joystick .. i want it to always stay on

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2203
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Disable powersaving

Post#2 by ncmprhnsbl » 04 Nov 2019, 08:36

which desktop module are you using?
maybe:

Code: Select all

xset q  (gives settings  status)
xset s off   (turns off screensaver/blanking) or
xset s 00  (set the timeout to never)
xset -dpms (disables powersaving)
if this works for you they could go in auto start(how: depending on which DE)
unless something else is controlling this..
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Blaze
DEV Team
DEV Team
Posts: 2676
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Disable powersaving

Post#3 by Blaze » 04 Nov 2019, 09:22

Buurman, like this

Code: Select all

su
toor
echo 'xset -dpms s off' >> /etc/rc.d/rc.local
and reboot.
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

Buurman
White ninja
White ninja
Posts: 9
Joined: 28 Oct 2019, 18:00
Distribution: ver5

Disable powersaving

Post#4 by Buurman » 05 Nov 2019, 19:37

First checked with

Code: Select all

xset q
and settings are 600sec for dpms and Blankscreen .. seems right ..
put

Code: Select all

xset -dpms s off
in rc.local
reboot .. still going into powersafe :shock:
check with

Code: Select all

 xset q
settings are default 600 again .. looking in rc.local ..settigns ARE THERE :%)
it's doesn't seem to be using the rc.local ?

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2203
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Disable powersaving

Post#5 by ncmprhnsbl » 05 Nov 2019, 22:38

rc.local might be too early in the boot process.. ie. before X has started..
so autostart at the DE level might be better..
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

Buurman
White ninja
White ninja
Posts: 9
Joined: 28 Oct 2019, 18:00
Distribution: ver5

Disable powersaving

Post#6 by Buurman » 06 Nov 2019, 04:47

i've put it in .config/autostart
in a .desktop launch ..works :blink:

Post Reply