xaralx

If you are looking for a specific 64-bit package and you can't find it in any of the 64-bit repos, please post a request for it here
Post Reply
unixino
Black ninja
Black ninja
Posts: 39
Joined: 28 Dec 2012, 11:42
Distribution: 46 bit xfce
Location: Egypt

xaralx

Post#1 by unixino » 18 Apr 2018, 01:24

Hi, Can anybody help me to create a module from source of XARALX for Porteus4 ?
https://github.com/samuell/xara-xtreme
if anybody can help me i will be grateful.

tome
Contributor
Contributor
Posts: 615
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

xaralx

Post#2 by tome » 20 Apr 2018, 21:54

Why not this:
http://archive.ubuntu.com/ubuntu/pool/m ... _amd64.deb (package without help files)
or this:
http://ftp.altlinux.org/pub/distributio ... x86_64.rpm (package with about 17 MB of help files)

EDIT:
You may need http://ftp.slackware.com/pub/slackware/ ... 6_64-2.txz and its dependency http://ftp.slackware.com/pub/slackware/ ... 6_64-2.txz

EDIT2:
You need also https://slackonly.com/pub/packages/curr ... slonly.txz, I didn't notice that I have it already in my system but it is not default. Thanks @Rava.
No intelligence, no life and no information can exist without prior intelligence, life or information (in place where things change and time is running).

User avatar
Rava
Contributor
Contributor
Posts: 1573
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

xaralx

Post#3 by Rava » 21 Apr 2018, 12:32

@tome

I tried creating a module out of a XaraLX-0.7r1785-11.93 rpm, but so far that fails.
The only dependency seemingly there is is an older version of libpng, so I made a libpng12-1.2.57-4.x86_64.xzm

But trying to run xaralx fails:

Code: Select all

guest@porteus:~$ XaraLX 
XaraLX: relocation error: XaraLX: symbol _ZTV19wxGnomePrintFactory version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference
I have no clue how to handle this error.
Cheers!
Yours Rava

tome
Contributor
Contributor
Posts: 615
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

xaralx

Post#4 by tome » 22 Apr 2018, 09:28

@Rava
Try package for altlinux or ubuntu, for opensuse it doesn't work here.
No intelligence, no life and no information can exist without prior intelligence, life or information (in place where things change and time is running).

User avatar
Rava
Contributor
Contributor
Posts: 1573
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

xaralx

Post#5 by Rava » 24 Apr 2018, 09:35

tome wrote:
22 Apr 2018, 09:28
@Rava
Try package for altlinux or ubuntu, for opensuse it doesn't work here.
I try the altlinux one. Hopefully I can also use GraphicsMagick-1.3.28-x86_64-1_slonly.txz instead of the imagemagick-6.9.9_40-x86_64-2.txz dependency.
Cheers!
Yours Rava

tome
Contributor
Contributor
Posts: 615
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

xaralx

Post#6 by tome » 25 Apr 2018, 09:23

Rava wrote:
24 Apr 2018, 09:35
Hopefully I can also use GraphicsMagick-1.3.28-x86_64-1_slonly.txz instead of the imagemagick-6.9.9_40-x86_64-2.txz dependency.
I don't think so, a warning occurs only once on first run, try with fresh profile (rm -r ~/.xaralx).
No intelligence, no life and no information can exist without prior intelligence, life or information (in place where things change and time is running).

Post Reply