Make a module to downgrade xorg

If you are looking for a specific 64-bit package and you can't find it in any of the 64-bit repos, please post a request for it here
Post Reply
evergreen
Black ninja
Black ninja
Posts: 32
Joined: 27 Mar 2016, 16:58
Distribution: porteus x64
Location: sweden

Make a module to downgrade xorg

Post#1 by evergreen » 01 Apr 2018, 11:35

May be is not common that somebody have those needs, but I want to try if in this way I could make a module with the official drivers for my video card radeon-crimson-15.12

I compiled and converted this packages to xzm

xf86-input-acecad-1.5.0-x86_64-10.txz
xf86-input-evdev-2.10.5-x86_64-1.txz
xf86-input-joystick-1.6.3-x86_64-1.txz
xf86-input-keyboard-1.9.0-x86_64-1.txz
xf86-input-libinput-0.24.0-x86_64-1.txz
xf86-input-mouse-1.9.2-x86_64-1.txz
xf86-input-penmount-1.5.0-x86_64-10.txz
xf86-input-synaptics-1.9.0-x86_64-1.txz
xf86-input-vmmouse-13.1.0-x86_64-5.txz
xf86-input-void-1.4.0-x86_64-10.txz
xf86-input-wacom-0.33.0-x86_64-2.txz
xf86-video-ati-7.8.0-x86_64-1.txz
xf86-video-vesa-2.3.4-x86_64-3.txz
xorg-server-1.17.4-x86_64-1.txz
xorg-server-xephyr-1.17.4-x86_64-1.txz
xorg-server-xnest-1.17.4-x86_64-1.txz
xorg-server-xvfb-1.17.4-x86_64-1.txz

But when I reboot, I have a problem that made not work my keyboard anymore, may be there is something with the preloaded 002-xorg and all the settings there
Porteus-v4.0 AMD A8-7410, APU AMD Radeon R5 Graphics M330

User avatar
Ed_P
Contributor
Contributor
Posts: 4193
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Make a module to downgrade xorg

Post#2 by Ed_P » 02 Apr 2018, 05:55

What happens if you leave xf86-input-keyboard-1.9.0-x86_64-1.txz out of your xzm module?
Ed

evergreen
Black ninja
Black ninja
Posts: 32
Joined: 27 Mar 2016, 16:58
Distribution: porteus x64
Location: sweden

Make a module to downgrade xorg

Post#3 by evergreen » 02 Apr 2018, 19:36

When I tried it, the keyboard still the same, btw my USB mouse is not moving , only work the pad in the laptop... I am not testing in a desktop computer
Porteus-v4.0 AMD A8-7410, APU AMD Radeon R5 Graphics M330

evergreen
Black ninja
Black ninja
Posts: 32
Joined: 27 Mar 2016, 16:58
Distribution: porteus x64
Location: sweden

Make a module to downgrade xorg

Post#4 by evergreen » 07 Apr 2018, 13:15

When I checked the log of xorg I realized that is missing these libs, and now is working :roll:
libinput-1.8.0-x86_64-1.xzm
libwacom-0.25-x86_64-1.xzm
So with those extra modules I have xorg 1.17 working

In case that somebody need the files here is the script

Code: Select all

wget -r -nH --no-parent --reject="index.html*" --cut-dirs=5 https://slackbuilds.org/mirror/slackware/slackware-current/source/x/x11/
cd x11/src/xserver
wget http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-1.17.4.tar.bz2
cd ../..
sh ./x11.SlackBuild xserver
export UPGRADE_PACKAGES=always
sh x11.SlackBuild driver xf86-video-ati
sh x11.SlackBuild driver xf86-video-vesa
sh x11.SlackBuild driver xf86-input-evdev
sh x11.SlackBuild driver xf86-input-acecad
sh x11.SlackBuild driver xf86-input-joystick
sh x11.SlackBuild driver xf86-input-keyboard
sh x11.SlackBuild driver xf86-input-libinput
sh x11.SlackBuild driver xf86-input-mouse
sh x11.SlackBuild driver xf86-input-penmount
sh x11.SlackBuild driver xf86-input-synaptics
sh x11.SlackBuild driver xf86-input-vmmouse
sh x11.SlackBuild driver xf86-input-void
sh x11.SlackBuild driver xf86-input-wacom

#upgradepkg --reinstall /tmp/x11-build/xf86*.txz
Porteus-v4.0 AMD A8-7410, APU AMD Radeon R5 Graphics M330

Post Reply