Page 1 of 1

[Solved...] Important security package...

Posted: 07 Feb 2018, 23:16
by n0ctilucient
The Guarded Memory Move tool gets handy when you have to study buffer overflows and you need to catch them together with a "good" stack image.

The GMM library uses the LD_PRELOAD capability and offers two services to the user. First of all, it avoids buffer overflow to allow the attacker to execute shell-code on your machine. Second, in case where an exploit is detected, the stack content is saved and a segmentation fault is triggered.
Source is @... http://www.xmailserver.org/gmm.html

These package has not been adopted yet by ("slackonly" or)...
https://slakfinder.org
https://slackbuilds.org
https://pkgs.org

Important security package...

Posted: 18 Feb 2018, 22:05
by n0ctilucient
Successfully compiled GMM using these "src2pkg" parameters...
see... Src2pkg.conf w/ "hardened" EXTRA_FLAGS