Page 1 of 1


Posted: 04 Sep 2013, 03:07
by Rava
I try to get sigil running.

from ... ub-editor/

Code: Select all

Sigil: The Free EPUB Editor

The best features of Sigil are the ability of edit the epub files using a WYSIWYG editor and the possibility to converting multiple file formats into epub files.

    Free and open source software under GPLv3
    Multi-platform: runs on Windows, Linux and Mac
    Full UTF-16 support
    Full EPUB 2 spec support
    Multiple Views: Book View, Code View and Preview View
    WYSIWYG editing in Book View
    Complete control over directly editing EPUB syntax in Code View
    Table of Contents generator with multi-level heading support
    Metadata editor with full support for all possible metadata entries (more than 200) with full descriptions for each
    User interface translated into many languages
    Spell checking with default and user configurable dictionaries
    Full Regular Expression (PCRE) support for Find & Replace
    Supports import of EPUB and HTML files, images, and style sheets,
    Documents can be validated for EPUB compliance with the integrated FlightCrew EPUB validator
    Embedded HTML Tidy: all imported files have their formatting corrected, and your editing can be optionally cleaned
I created the module manually already ("sigil-0.5.3-x86_64-1alien.xzm"), and used PPM to search and download and activate the missing dependencies.

But it still says:

Code: Select all

guest@porteus:/usr/lib64$ ldd /usr/bin/sigil|grep "not found" => not found => not found => not found => not found => not found => not found => not found
But all these deps should be solved:

Code: Select all

guest@porteus:/usr/lib64$ ls -1 libhunspell*******
Any idea why it is bickering like that?
All dependencies should be solved, since all needed libraries are of newer versions than the needed...

Re: sigil

Posted: 04 Sep 2013, 03:51
by Rava

I needed to create symlinks like so:

Code: Select all

ln -s
ln -s
ln -s
ln -s
ln -s ln -s
ln -s
And then, I also needed to convert a rpm creating libicu-49.1.1-10.fc18.x86_64.xzm cause after the above, libicu was still missing.

Now it runs fine, but could not read my "GTK+ theme."

Code: Select all

guest@porteus:/usr/lib64$ sigil
Warning: QGtkStyle was unable to detect the current GTK+ theme.
I run XFCe with xfce-dusk appearance, or, in other words: light foreground, black background.
But sigil scares me with its white background and dark text...
How could this be changed, what must I do so that GTK+ programs get tricked into using a "light foreground, black background" theme as well?

Do I need to create a gtk+ settings file? And what do I need to write into it?


If anyone is interested in sigil, please let me know via posting in here and I will upload both the sigil and libicu xzm

(Currently I try to update sigil to current 0.73)

Re: sigil

Posted: 04 Sep 2013, 08:28
by francois
Interesting program to edit ebook files or to convert other formats into epub (ebook) files, see epub definition: ... s-Epub.htm

It would be nice that it could work on my android phone!

Re: sigil

Posted: 04 Sep 2013, 09:24
by fanthom
classic example of troubles caused by using packages from older slackware repo. you are using sigil compiled on slackware-13.37 while porteus-2.x line bases on slackware-14.0.

i have pushed sigil to 64bit official porteus repo so please download from there (and revert all the symlinking you have made as they may break things up).