Page 1 of 1

Wifi not working on Porteus v4.0 - A Solution.

Posted: 13 Aug 2020, 03:54
by Iknownothing
I literally registered to this forum and 'resurrected' my Mediafire account for doing this post. :crazy:
I saw that many people is having issues with wi-fi hardware detection when booting to Porteus 4, and there's not many solutions to those posts. Or at least, there's one, but it has to be the commandline 'tricky' way.
Recently I found in a post that .sfs and .xzm are the same thing, Squashed filesystems. And taking in count that I previously used Puppy linux 'X-slacko 4.4' with working wi-fi, that some of the .sfs files are the ones containing the drivers, and that both OSes are based on Slackware, I thought that porting that .sfs file with the drivers to Porteus would solve it...

And I did it, literally just changing the filename extension from .sfs to .xzm, lol.
Guess what, it did work!

So then I'm here, I decided to upload the file on mediafire and here I leave it for ya'll [Updated 21/08/2020]: ... t.xzm/file

All you have to do is to copy this file to the '/porteus/base/' or '/porteus/modules/' folder, then boot into the drive you have Porteus installed in, and see if it worked.

I hope it does work for you , this post is not intended to give you an allwinner solution but for testing porpuses. Take in count that the original .sfs file comes from a puplet based on Slackware unstable (14.1), and some of the drivers may be outdated, plus it doesn't have all of the drivers in the world. There's anyway another post in this group specificly made for Broadcome adapters. See ya! :)

Wifi not working on Porteus v4.0 - A Solution.

Posted: 13 Aug 2020, 09:13
by donald
Howdy iknownothing

Glad it worked for you and I understand the logic of your thinking.
So i downloaded the File, extracted it, to see what gives.

Don't get me wrong I'm only honest.

First of all, it expands to 3528 items, totalling 81.7 MB, that's quite a lot,
when you actually may only need a file or two from the / lib / firmware folder
for your device to work.

All other files / folders contained in this module are either unusable (different kernel version)
or could lead to unexpected results.

However, it can be of some help, IF:
Dowload > extract > compare the Files/Folders in /lib/firmware with the ones in Porteus
and if some are missing copy them over.

Try it,you may find out which file(s) you really need.

Wifi not working on Porteus v4.0 - A Solution.

Posted: 13 Aug 2020, 12:07
by Iknownothing
Thanks, donald.
Actually, I was wondering what those 'kernel' files where for, and if they were useful for something. I did thought that some of the drivers might be repeated, but didn't cared about it.
I'll do it, and update the Mediafire link.