Page 2 of 2

[SOLVED] hackin' on an Atom z8350 mini pc

Posted: 08 May 2019, 08:42
by kultex
txh a lot for the info....

and you have sound? - normally with Z8350 it should be Everest Semi ES8316 CODEC - the driver is available in Linux - - didnt check, if it is available in Porteus?

here a ubuntu discussion:

and very strange, that intel-idle uses cstate 1 instead of Wolfgang Reimers script....

[ 0.471099] intel_idle: max_cstate 1 reached

[SOLVED] hackin' on an Atom z8350 mini pc

Posted: 10 May 2019, 10:00
by nanZor
Nope - no sound. No wifi. If I truly want it, I'll just use my working usb wifi dongle instead. And also thinking about a usb<>audio adapter. Problem is that the audio is only mono IF you get it working!

There is a limit to my patience these days. :)

Like everyone else chasing problems like these and pronouncing a fix, only to have it fail a few days later, I think I'll make this pronouncement:

On *this box*, the following 3 cheatcodes provided the most stability - other codes seem optional

noacpi - something funky in their acpi. But can't turn it totally off.
intel_max.cstate=1 - or 0. The z8350 on this box needs it.
quiet - lets me get past the underline in the upper corner and progress to graphics. Fastboot does not seem to be an issue.

Season to taste with other codes, but these 3 seem to be the champs. Getting very near to putting the box under my boot. :)

[SOLVED] hackin' on an Atom z8350 mini pc

Posted: 13 May 2019, 21:46
by nanZor
Tilting at windmills ...

Even though listed as solved, there are still random times when the system does not boot back up properly, requiring an fsck on my internal storage, etc - or shutting down the monitor and keyboard. This is soooo frustrating.

I may have tracked down the *real* issue (said before). i2C power management problems.

So now my major cheatcodes are these:



For now, these have really calmed down some of the restart/reboot/shutdown issues. Kind of getting tired of this toy hardware, but I just can't let go for some reason. :)

[SOLVED] hackin' on an Atom z8350 mini pc

Posted: 19 May 2019, 20:37
by nanZor
Ultimate solution found! Shelved the box. This, along with all the Intel cpu security problems is too much. The little 1ghz Vnopn box running AMD works just perfectly with Porteus.

[SOLVED] hackin' on an Atom z8350 mini pc

Posted: 24 Mar 2021, 23:47
by nanZor
Pulled it back off the shelf!

Ultimate solution is to run 5.0 RC2 for now.

Totally usable, without any cheatcodes. No wifi, but I use my own linux-compatible dongles to cure that.

The only thing is not to shutdown too quickly after boot (ie rapid-fire recycling for testing cheatcodes, etc), or sometimes at random, after it exits acpid, the system will just hang and not halt nor power down monitor, etc.

I noticed it seems like a timing thing - if you wait long enough for the cpu speeds to step down, then an orderly shutdown takes place.

To see that, I just cat /proc/cpuinfo |grep MHz , or bring up the LXDE cpufreq front-end applet. Basically just waiting a couple of minutes before you do a shutdown and all is ok. Ie, normal use, and not frenzied power-cycling testing. :)

Thanks to Neko et al for RC2! Made the box usable and fun to use with Porteus.