Вопросы про porteus

Добро пожаловать!

Moderator: Blaze

dZ0TFR
Samurai
Samurai
Posts: 120
Joined: 07 Apr 2019, 07:16
Distribution: Porteus-4.0

Вопросы про porteus

Post#271 by dZ0TFR » 13 Nov 2019, 04:13

glestwid, попробуйте выполнить пункты 1,2,3,4 предыдущего моего сообщения, а модуль xzm активировать уже не нужно (xzm модуль лучше вообще удалить). У меня тоже была проблема с модулями (о чем писал пару дней назад в этой теме).
Porteus-4.0-x86

tiptoper
Black ninja
Black ninja
Posts: 47
Joined: 26 Jun 2013, 05:27
Distribution: Porteus-Xfce-4.0-ru-x64
Location: RU. Одинцово-10

Вопросы про porteus

Post#272 by tiptoper » 13 Nov 2019, 07:16

Всем привет!
У кого-нибудь есть инфа про то, когда появится конкретный Porteus-5.0?

glestwid
Samurai
Samurai
Posts: 101
Joined: 09 Jan 2018, 20:05
Distribution: Porteus-KDE 3.2.2 i586

Вопросы про porteus

Post#273 by glestwid » 13 Nov 2019, 07:38

dZ0TFR wrote:
13 Nov 2019, 04:13
glestwid, попробуйте выполнить пункты 1,2,3,4 предыдущего моего сообщения, а модуль xzm активировать уже не нужно (xzm модуль лучше вообще удалить). У меня тоже была проблема с модулями (о чем писал пару дней назад в этой теме).
Да, помогло, спасибо. Теперь новая трабла там при запуске скрипта:
root@porteus:~/Downloads# python demo.py
Traceback (most recent call last):
File "demo.py", line 3, in <module>
import Tkinter
File "/usr/lib/python2.7/lib-tk/Tkinter.py", line 39, in <module>
import _tkinter # If this fails your Python may not be configured for Tk
ImportError: /usr/lib/python2.7/lib-dynload/_tkinter.so: undefined symbol: PyUnicodeUCS2_AsUTF8String
Где искать либу с этим самым PyUnicodeUCS2_AsUTF8String?

User avatar
Blaze
DEV Team
DEV Team
Posts: 2898
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Вопросы про porteus

Post#274 by Blaze » 13 Nov 2019, 08:10

Blaze wrote:
12 Nov 2019, 10:17
python-modules-tkinter-2.7.17-alt3.i586.rpm (для python 2)
python3-modules-tkinter-3.7.4-alt2.i586.rpm (для python
деактивируйте или удалите.

Попробуйте обновить python до python-2.7.17-i586-1.txz
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

dZ0TFR
Samurai
Samurai
Posts: 120
Joined: 07 Apr 2019, 07:16
Distribution: Porteus-4.0

Вопросы про porteus

Post#275 by dZ0TFR » 13 Nov 2019, 08:28

glestwid, не уверен, но попробовать установить Пайтон поновее:
1) wget http://mirror.yandex.ru/slackware/slack ... ck14.2.txz
2) installpkg python-2.7.17-i586-1_slack14.2.txz

Ой, Blaze опередил :-) Моё сообщение можно не делать.
Porteus-4.0-x86

glestwid
Samurai
Samurai
Posts: 101
Joined: 09 Jan 2018, 20:05
Distribution: Porteus-KDE 3.2.2 i586

Вопросы про porteus

Post#276 by glestwid » 13 Nov 2019, 09:00

dZ0TFR wrote:
13 Nov 2019, 08:28
glestwid, не уверен, но попробовать установить Пайтон поновее:
1) wget http://mirror.yandex.ru/slackware/slack ... ck14.2.txz
2) installpkg python-2.7.17-i586-1_slack14.2.txz
Спасибо, помогло. Теперь новые грабли:
oot@porteus:~/Downloads# python demo.py
Traceback (most recent call last):
File "demo.py", line 4, in <module>
top = Tkinter.Tk()
File "/usr/lib/python2.7/lib-tk/Tkinter.py", line 1825, in __init__
self.tk = _tkinter.create(screenName, baseName, className, interactive, wantobjects, useTk, sync, use)
_tkinter.TclError: unknown color name "BACKGROUND"
Откуда этот самый BACKGROUND прилетает?

dZ0TFR
Samurai
Samurai
Posts: 120
Joined: 07 Apr 2019, 07:16
Distribution: Porteus-4.0

Вопросы про porteus

Post#277 by dZ0TFR » 13 Nov 2019, 09:16

python-modules-tkinter-2.7.17-alt3.i586.rpm (для python 2)
python3-modules-tkinter-3.7.4-alt2.i586.rpm (для python
деактивируйте или удалите.
это делали?
Porteus-4.0-x86

User avatar
Blaze
DEV Team
DEV Team
Posts: 2898
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Вопросы про porteus

Post#278 by Blaze » 13 Nov 2019, 09:19

glestwid, попробуйте выполнить

Code: Select all

xrdb -load /dev/null
xrdb -query
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

glestwid
Samurai
Samurai
Posts: 101
Joined: 09 Jan 2018, 20:05
Distribution: Porteus-KDE 3.2.2 i586

Вопросы про porteus

Post#279 by glestwid » 13 Nov 2019, 11:27

Blaze wrote:
13 Nov 2019, 09:19
glestwid, попробуйте выполнить

Code: Select all

xrdb -load /dev/null
xrdb -query
Спасибо, то что надо!

glestwid
Samurai
Samurai
Posts: 101
Joined: 09 Jan 2018, 20:05
Distribution: Porteus-KDE 3.2.2 i586

Вопросы про porteus

Post#280 by glestwid » 13 Nov 2019, 17:53

Blaze wrote:
08 Nov 2019, 08:04
glestwid, https://codebeautify.org/xmlviewer - вставить код и нажать Beautify / Format
Я снова вернулся к этому вопросу. Нашел древний GTK+ XML viewer. Пытаюсь его собрать из исходников, получаю:
root@porteus:/tmp/gxmlviewer-1.3.3# ./configure
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking for gnome-config... no
checking for gnomeConf.sh file in /usr/local/lib... not found
configure: error: Could not find the gnomeConf.sh file that is generated by gnome-libs install

Кого мне надо добавить чтобы сборка пошла?

User avatar
Blaze
DEV Team
DEV Team
Posts: 2898
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Вопросы про porteus

Post#281 by Blaze » 14 Nov 2019, 08:07

glestwid, gnome-libs-devel-1.4.2-16.el6.i686.rpm
Только это толку не даст, так как возникнет

Code: Select all

checking for GTK - version >= 1.2.0... no
и gtk+-devel-1.2.10-77.sdl7.i686.rpm не решит данный вопрос.
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

glestwid
Samurai
Samurai
Posts: 101
Joined: 09 Jan 2018, 20:05
Distribution: Porteus-KDE 3.2.2 i586

Вопросы про porteus

Post#282 by glestwid » 19 Nov 2019, 20:06

День добрый, подскажите как на Porteus 4.0 поставить GAJIM? Нашел gajim-0.16.9-i586-bundle, поставил его. Он пчему-то не находит python-nbxmpp. Ок, нашел ему python-nbxmpp-0.6.2-i586-bundle, поставил. Теперь при запуске GAJIM получаю:
uest@porteus:/root$ gajim
===============================================================================
PyOpenSSL not found, falling back to Python builtin SSL objects (insecure).
===============================================================================
Traceback (most recent call last):
File "gajim.py", line 211, in <module>
import gtk
File "/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 40, in <module>
from gtk import _gtk
ImportError: /usr/lib/python2.7/site-packages/gtk-2.0/gtk/_gtk.so: undefined symbol: PyUnicodeUCS4_DecodeUTF8
Что ему теперь надо?

dZ0TFR
Samurai
Samurai
Posts: 120
Joined: 07 Apr 2019, 07:16
Distribution: Porteus-4.0

Вопросы про porteus

Post#283 by dZ0TFR » 20 Nov 2019, 01:35

Может PyOpenSSL?
1) usm -g pyOpenSSL-17.5.0
Porteus-4.0-x86

glestwid
Samurai
Samurai
Posts: 101
Joined: 09 Jan 2018, 20:05
Distribution: Porteus-KDE 3.2.2 i586

Вопросы про porteus

Post#284 by glestwid » 20 Nov 2019, 08:27

dZ0TFR wrote:
20 Nov 2019, 01:35
Может PyOpenSSL?
1) usm -g pyOpenSSL-17.5.0
Не, не помогает. Ничего не поменялось после добавления pyOpenSSL-17.5.0. Вот какие модули сейчас установлены:
000-kernel.xzm
001-core.xzm
002-xorg.xzm
003-mate.xzm
05-devel.xzm
Brackets.Release.1.14.32-bit.xzm
firefox-70.0.1-i686-en-US-1.xzm
gajim-0.16.9-i586-bundle.xzm
kate-4.14.3-i586-bundle.xzm
libgtk-3-0_3.24.5-1_i386.xzm
libgtk2.0-0_2.24.32-3_i386.xzm
macchanger-1.6.0.xzm
openjdk-7u141b02-i586-bundle.xzm
pyOpenSSL-17.5.0-i586-bundle.xzm
python-modules-tkinter-2.7.17-alt3.i586.xzm
python-nbxmpp-0.6.2-i586-bundle.xzm
scite-3.7.4-i586-bundle.xzm
tcl-8.6.5-i586-bundle.xzm
tk-8.6.5-i586-2.xzm
xmlcopyeditor_1.2.1.3-1_i386.xzm
xmltreeedit_0.1.0.26_i386.xzm

User avatar
Blaze
DEV Team
DEV Team
Posts: 2898
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Вопросы про porteus

Post#285 by Blaze » 20 Nov 2019, 08:51

Если выходит undefined symbol - грубо говоря говорит о том, что библиотеки несовместимы и их сборка производилась в разное время и с разными зависимостями.
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

Post Reply