Page 1 of 1

[SOLVED] call to lnusertemp failed

Posted: 10 Sep 2013, 12:56
by quotaholic
Hi All,

Had to recompile the Porteus kernel to get support for my hardware. Grabbed 3.9.11 from and setup Porteus KDE4 2.1 i486 to build with on a 16gb usb stick formatted to ext4. Only have a gig of ram so this setup seemed best.

After getting the kernel patched and built and committing to install it to the target hardware (4gb nand flash module on 44 pin ide header) I get the message in the subject line as well as a dialog that I have to click and then get moved to a login window. As my target hardware is a tablet and has no keyboard attached to enter login information with this is not optimal. If Kvkbd could be called to sit on the login window this would be optimal however no option exists in system settings to do this.

How did you guys handle this in Kiosk edition? Disable logout? How do I troubleshoot the call to lnusertemp failing? Read that /var not having room will cause. I removed a couple directories in /var/tmp but that does not seem right. My sources were still on the flash stick so is it possible that 1gb of sources got carried over in to the new file system and this is what is filling my /var and causing call to lnusertemp to fail?

thanks in advance

Re: call to lnusertemp failed

Posted: 10 Sep 2013, 17:49
by fanthom
a) i'm not sure if kde4 is the best choice for your hardware.
b) startkde in porteus exports 'KDEVARTMP=/mnt/live/var/tmp' to make sure that kde caches are created in tmpfs (fastest response time) rather than in /var/tmp which could be a real filesystem (when user is saving changes).

'lnusertemp' error appears when kde cant write caches so please double check your setup. if you wont be able to figure it out then please upload your ISO and i'll try to find what's causing the error.

Re: call to lnusertemp failed

Posted: 10 Sep 2013, 19:08
by quotaholic
Makes a lot of sense. I get different play on connecting via wifi each boot. Most times I have to reenter password but KDE saves the network name.

Ill take a look at caches later tonight.

New tablet. 10 inch. 1.6 ghz z530 atom with intel gma500 poulsbo. 1GB ram. KDE is quite snappy on this one. The old tablets.... yeah KDE3 or E17 is about all that will run. Razor worked but was too weird.

Cut sheet: ... dt312.html

Got it for $130 off flea bay.

Thanks for the tip. Will look more in 5 hours.


Solved Re: call to lnusertemp failed

Posted: 11 Sep 2013, 00:44
by quotaholic
Thanks for the tip.

Turns out I erased too much from /var/tmp and she would not boot without choosing "fresh" or norootcopy cheat code and from the usb stick.

Installed again but this time I chose not to use installer and manually partitioned and copied only porteus and boot folders. I had 000-kernel and aufs and linux-3.9.11 still on usb from building the kernel along with porteus and boot directories on usb. Hit the CLI installer and rebooted without the error.

Aside from a couple tweaks to .config to get it to take on the hardware this is an ideal distribution for an atom based tablet with 4gb of nand flash available.


Re: call to lnusertemp failed

Posted: 11 Sep 2013, 00:55
by brokenman
3.11 kernel has hit mainline and the rcN aufs patch succeeds. I am using it now and it brings some nice features to the party.

[SOLVED] Re: call to lnusertemp failed

Posted: 11 Sep 2013, 01:10
by quotaholic
Thanks brokenman

I didnt use the method of modprobing the penmount.ko and then using xinput-calibrator this time around. Used this in the past to stay all open source on getting the touchscreen to work. Had to use very current inputattach that had penmount -pm9k option with this method. This tablet uses 6250 controller and have not been able to get inputattach to grab it and slap it on the input layer. I hear its a combo serial / usb that supports multitouch on win7. I tried but it didn't take. Used the vendors touchscreen driver for Debian 7 on Porteus v2.1 and as the Xorg versions lined up It took. I would bite my nails trying 3.11 as its a huge delta against 3.2.xx which I think is what Debian 7 is using. My fear is that the vendor driver would do an abi mismatch on me. Eh my girlfriend is out of town for 5 more days. I'll give it shot and report back.