[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
benjibasson
Black ninja
Black ninja
Posts: 45
Joined: 06 Mar 2019, 15:14
Distribution: Arch linux

[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

Post#211 by benjibasson » 15 Jan 2023, 17:20

Hi,
I cannot download any package with the getmod althought

Code: Select all

getmod -u
has been launched?

for many applications it doesn't build any module. in fact it confuse -m, -M with -d and download only

Code: Select all

root@porteus:/home/guest#getmod -M kdenlive-21.12.1-x86_64-1
Reading Package Lists...Done
The following NEW packages will be installed:
  gstreamer hunspell jasper graphene gtk4 libwacom libinput judy mariadb 
  openal-soft speech-dispatcher xcb-util-image xcb-util-keysyms 
  xcb-util-renderutil xcb-util-wm qt5 attica karchive python2 kcoreaddons 
  polkit-qt-1 kauth kcodecs kconfig kguiaddons ki18n kwidgetsaddons 
  kconfigwidgets kwindowsystem kcrash kdbusaddons kglobalaccel kitemviews 
  kiconthemes kxmlgui kbookmarks kcompletion kdoctools kjobwidgets 
  libdbusmenu-qt knotifications kservice aspell sonnet ktextwidgets kwallet 
  solid kio kpackage kdeclarative ebook-tools kfilemetadata syndication 
  knewstuff knotifyconfig libid3tag sox vid.stab mlt purpose kdenlive 
0 upgraded, 0 reinstalled, 61 newly installed, 0 to remove, 0 not upgraded.
Need to get 155.0kB/187.9MB of archives.
Do you want to continue? [y/N] y

Done
root@porteus:/home/guest# getmod -m kdenlive-21.12.1-x86_64-1
Reading Package Lists...Done
The following NEW packages will be installed:
  gstreamer hunspell jasper graphene gtk4 libwacom libinput judy mariadb 
  openal-soft speech-dispatcher xcb-util-image xcb-util-keysyms 
  xcb-util-renderutil xcb-util-wm qt5 attica karchive python2 kcoreaddons 
  polkit-qt-1 kauth kcodecs kconfig kguiaddons ki18n kwidgetsaddons 
  kconfigwidgets kwindowsystem kcrash kdbusaddons kglobalaccel kitemviews 
  kiconthemes kxmlgui kbookmarks kcompletion kdoctools kjobwidgets 
  libdbusmenu-qt knotifications kservice aspell sonnet ktextwidgets kwallet 
  solid kio kpackage kdeclarative ebook-tools kfilemetadata syndication 
  knewstuff knotifyconfig libid3tag sox vid.stab mlt purpose kdenlive 
0 upgraded, 0 reinstalled, 61 newly installed, 0 to remove, 0 not upgraded.
Need to get 155.0kB/187.9MB of archives.
Do you want to continue? [y/N] y

Done

Code: Select all

root@porteus:/home/guest# getmod -m Blender-3.0.1-x86_64-2salix15.0
Reading Package Lists...Done
Installed v4l-utils conflicts with v4l-utils-nogui
The following NEW packages will be installed:
  jasper LibRaw OpenSubdiv gstreamer hunspell graphene gtk4 libwacom libinput 
  judy mariadb openal-soft speech-dispatcher xcb-util-image xcb-util-keysyms 
  xcb-util-renderutil xcb-util-wm qt5 cmake dcmtk expat jemalloc opencollada 
  pybind11 opencolorio python2 openexr libwmf imagemagick xine-lib opencv 
  robin-map tbb fmt gcc-go gcc gcc-gfortran libaec hdf5 openimageio potrace 
  pugixml v4l-utils-nogui vid.stab Blender 
The following packages will be REMOVED:
  v4l-utils 
0 upgraded, 0 reinstalled, 45 newly installed, 1 to remove, 0 not upgraded.
Need to get 85.0kB/332.3MB of archives.
Do you want to continue? [y/N] y

Done
root@porteus:/home/guest# getmod -M Blender-3.0.1-x86_64-2salix15.0
Reading Package Lists...Done
Installed v4l-utils conflicts with v4l-utils-nogui
The following NEW packages will be installed:
  jasper LibRaw OpenSubdiv gstreamer hunspell graphene gtk4 libwacom libinput 
  judy mariadb openal-soft speech-dispatcher xcb-util-image xcb-util-keysyms 
  xcb-util-renderutil xcb-util-wm qt5 cmake dcmtk expat jemalloc opencollada 
  pybind11 opencolorio python2 openexr libwmf imagemagick xine-lib opencv 
  robin-map tbb fmt gcc-go gcc gcc-gfortran libaec hdf5 openimageio potrace 
  pugixml v4l-utils-nogui vid.stab Blender 
The following packages will be REMOVED:
  v4l-utils 
0 upgraded, 0 reinstalled, 45 newly installed, 1 to remove, 0 not upgraded.
Need to get 85.0kB/332.3MB of archives.
Do you want to continue? [y/N] y

Done
for modules converted to xzm there are plenty missing dependences

Code: Select all

guest@porteus:~$ pitivi 
Could not import 'GstTranscoder'. Make sure you have it available.

Code: Select all

guest@porteus:~$ openshot-qt 
Traceback (most recent call last):
  File "/usr/bin/openshot-qt", line 33, in <module>
    sys.exit(load_entry_point('openshot-qt==2.6.1', 'gui_scripts', 'openshot-qt')())
  File "/usr/bin/openshot-qt", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib64/python3.9/importlib/metadata.py", line 86, in load
    module = import_module(match.group('module'))
  File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 850, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib64/python3.9/site-packages/openshot_qt/launch.py", line 47, in <module>
    from PyQt5.QtCore import Qt
ModuleNotFoundError: No module named 'PyQt5'

Code: Select all

guest@porteus:~$ openshot-qt 
Traceback (most recent call last):
  File "/usr/bin/openshot-qt", line 33, in <module>
    sys.exit(load_entry_point('openshot-qt==2.6.1', 'gui_scripts', 'openshot-qt')())
  File "/usr/bin/openshot-qt", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib64/python3.9/importlib/metadata.py", line 86, in load
    module = import_module(match.group('module'))
  File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 850, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib64/python3.9/site-packages/openshot_qt/launch.py", line 47, in <module>
    from PyQt5.QtCore import Qt
ModuleNotFoundError: No module named 'PyQt5'
what am I suppose to do to have getmod working properly?

Rapha_
Samurai
Samurai
Posts: 158
Joined: 12 Jun 2021, 21:59
Distribution: Xfce 4.12 - 5.rc3 - x86_64
Location: France

[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

Post#212 by Rapha_ » 16 Jan 2023, 01:22

Code: Select all

ModuleNotFoundError: No module named 'PyQt5'
For openshot-qt it seem you need more PyQt5 ( PyQt5-5.15.2-x86_64-5.txz )
beny wrote:
12 Jan 2023, 21:21
hi use this link to search packages for porteus check 15 and x86_64:
https://slackware.nl/slakfinder/
well but isn't a light task to search all the deps

User avatar
babam
Shogun
Shogun
Posts: 465
Joined: 16 Nov 2016, 10:30
Distribution: Porteus 5.0rc3 Xfce K6.1.1
Location: Rainy city

[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

Post#213 by babam » 16 Jan 2023, 19:58

benjibasson wrote:
15 Jan 2023, 17:20
Hi,
I cannot download any package with the getmod althought

Code: Select all

getmod -u
has been launched?

for many applications it doesn't build any module. in fact it confuse -m, -M with -d and download only
Try to comment out line 228
Sorry, my English is bad.

User avatar
Ed_P
Contributor
Contributor
Posts: 7435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.0 ISO
Location: Western NY, USA

[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

Post#214 by Ed_P » 16 Jan 2023, 23:20

babam wrote:
16 Jan 2023, 19:58
Try to comment out line 228
/usr/bin/getmod

Code: Select all

#   [ $? != 0 ] && exit
Like so :)

benjibasson wrote:
15 Jan 2023, 17:20

Code: Select all

root@porteus:/home/guest# getmod -m Blender-3.0.1-x86_64-2salix15.0
This doesn't work for you? blender module build script


Added in 8 hours 30 minutes 34 seconds:
babam, this 9 line narrative:

Code: Select all

guest@porteus:~$ getmod -u

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Enter root's password: 
can be reduced to 2 lines with a root test like this:

Code: Select all

if [ `whoami` != "root" ]; then
   echo -e "Enter root's password\033[1;31m"
   su -c "sh $0 $1 $2"; exit
fi
echo -e "\033[0m"; echo -en "\033]0;GetMod\a"
Ed

User avatar
babam
Shogun
Shogun
Posts: 465
Joined: 16 Nov 2016, 10:30
Distribution: Porteus 5.0rc3 Xfce K6.1.1
Location: Rainy city

[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

Post#215 by babam » 17 Jan 2023, 10:58

Ed_P wrote:
17 Jan 2023, 07:56
babam, this 9 line narrative:

Code: Select all

guest@porteus:~$ getmod -u

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Enter root's password: 
can be reduced to 2 lines with a root test like this:

Code: Select all

if [ `whoami` != "root" ]; then
   echo -e "Enter root's password\033[1;31m"
   su -c "sh $0 $1 $2"; exit
fi
echo -e "\033[0m"; echo -en "\033]0;GetMod\a"
You are free to modify it.
Sorry, my English is bad.

User avatar
Ed_P
Contributor
Contributor
Posts: 7435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.0 ISO
Location: Western NY, USA

[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

Post#216 by Ed_P » 17 Jan 2023, 15:59

babam wrote:
17 Jan 2023, 10:58
You are free to modify it.
:) Thank you. :) Other 011-* module users might appreciate the change also, especially newbies. :)
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 7435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.0 ISO
Location: Western NY, USA

[Porteus 5.0's USM replacement] getmod: A wrapper for slapt-get to build modules

Post#217 by Ed_P » 20 Jan 2023, 22:13

For users interested in making the discussed getmod changes:

Code: Select all

guest@porteus:~$ diff  /usr/bin/getmod  /mnt/live/memory/images/011-slapt-get-0.11.6-x86_64-2gv.xzm/usr/bin/getmod 
15,16c15,16
<    echo -e "Enter root's password\033[1;31m"   # sudo -E -p "Enter root's password: " "$0" "$@"
<    su -c "sh $0 $@"; exit                      # exit
---
>     sudo -E -p "Enter root's password: " "$0" "$@"
>     exit
18c18
< echo -e "\033[0m"; echo -en "\033]0;GetMod\a"  #  
---
> 
228c228
< #    [ $? != 0 ] && exit
---
>     [ $? != 0 ] && exit
guest@porteus:~$ 
< = my lines 15,16,18 & 228 changes
> = the current lines

And my current slapt-getrc file.

Code: Select all

guest@porteus:~$ diff /etc/slapt-get/slapt-getrc /mnt/live/memory/images/011-slapt-get-0.11.6-x86_64-2gv.xzm/etc/slapt-get/slapt-getrc 
18,28d17
< # The Slakfinder repository
< #SOURCE=https://slakfinder.org/sbomt64-15.0/:DEFAULT
< # commented out since slakfinder.org not working at this point.
< # Eric's US mirror
< SOURCE=http://taper.alienbase.nl/slackpkgplus/
< 
< SOURCE=https://slackware.uk/csb/15.0/x86_64/
< SOURCE=http://ponce.cc/slackware/slackware64-15.0/packages/
< 
< SOURCE=https://slackware.nl/people/alien/sbrepos/15.0/x86_64
< 
< = my 11 lines added after line 17.
Ed

Post Reply