nmap-7.12-i586 for Porteus 4.0

Post links to your 32-bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
User avatar
Rava
Contributor
Contributor
Posts: 4414
Joined: 11 Jan 2011, 02:46
Distribution: XFCE 5.0 x86_64 + 4.0 i586
Location: Forests of Germany

nmap-7.12-i586 for Porteus 4.0

Post#1 by Rava » 29 Aug 2022, 18:15

TLDR version
download nmap
https://slakfinder.org/show.php?pkg=74940

download libnl
https://slakfinder.org/show.php?pkg=78270 - I know it says "Repository: Slackware-15.0" - but I searched for it searching for arch:i386 / distro:14.2 via https://slakfinder.org/index.php?act=se ... e=#results

convert both into modules, activate both modules, nmap runs in XFCE i586 Porteus 4.0.
___________________________________________________

Elaborate version:

Trying to get nmap-7.12-i586 for Porteus 4.0 running in XFCE.
Same with x86-64 - libnl.so.1 is missing.

Code: Select all

guest@porteus:~$ nmap
nmap: error while loading shared libraries: libnl.so.1: cannot open shared object file: No such file or directory
Only, unlike running x86-64 Port 5.0 Nmap-7.92 for Porteus 5.0-x86_64 (Post by Rava #89484) getpkg fails:

Code: Select all

root@porteus:/# getpkg libnl
Checking that mirror is online ...


Looking up mirrors.slackware.com
Making HTTP connection to mirrors.slackware.com
Sending HTTP request.
HTTP request sent; waiting for response.
HTTP/1.1 302 Found
Data transfer complete
HTTP/1.1 302 Found
Using https://mirrors.slackware.com/mirrorlist
Looking up mirrors.slackware.com
Making HTTPS connection to mirrors.slackware.com
SSL callback:certificate has expired, preverify_ok=0, ssl_okay=0
Retrying connection without TLS.
Looking up mirrors.slackware.com
Making HTTPS connection to mirrors.slackware.com
Alert!: Unable to make secure connection to remote host.

lynx: Can't access startfile http://mirrors.slackware.com/mirrorlist

[ERROR] Could not connect to http://mirrors.slackware.com/mirrorlist
What must be done too fix that?
Palemoon has no issues accessing https sites.

Added in 45 minutes 38 seconds:
I used this
https://slakfinder.org/index.php?act=se ... e=#results
instead to get libnl-1.1.4-i486-1.txz
Will test it when I am back on the i586 machine, should work since that library was the only thing needed to get the x86-64 version to run, so chances are high it is the only dependency for the i586 version.

Added in 2 hours 32 minutes 26 seconds:
and it works:

Code: Select all

guest@porteus:~$ nmap -V

Nmap version 7.12 ( https://nmap.org )
Platform: i586-slackware-linux-gnu
Compiled with: liblua-5.2.4 openssl-1.0.2g libpcre-8.42 nmap-libpcap-1.7.3 nmap-libdnet-1.12 ipv6
Compiled without:
Available nsock engines: epoll poll select
:) :Yahoo!: :celebrate3:

These are my main base modules running i586 Porteus 4.0

Code: Select all

guest@porteus:~$ cat /etc/porteus/*
001-core.xzm:20180422
002-xorg.xzm:20180422
003-xfce.xzm:20171113
initrd.xz:20180311
Cheers!
Yours Rava

Post Reply