Poptrayminus 1.2.0

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Poptrayminus 1.2.0

Post#1 by Ed_P » 19 Feb 2019, 21:22

Okay. Trying this again. I downloaded a poptrayminus_1.2_all.deb file, converted it to a xzm file and now it's failing because it's looking for a PyQt4 module.

Code: Select all

guest@porteus:~$ poptrayminus
Import error "No module named PyQt4", please reinstall PyQt4 libraries
"sudo apt-get install python-qt4" may do the trick on Debian/Ubuntu
guest@porteus:~$ sudo apt-get python-qt4

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Password: 
sudo: apt-get: command not found
Anyone got a link to one? My searching leads me to .exe files.
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2103
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Re: Poptrayminus 1.2.0

Post#2 by ncmprhnsbl » 19 Feb 2019, 23:15

Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Poptrayminus 1.2.0

Post#3 by Ed_P » 20 Feb 2019, 00:36

ncmprhnsbl wrote:
19 Feb 2019, 23:15
http://ftp.slackware.com/pub/slackware/ ... 6_64-2.txz
obviously you'll need qt4 as well
Thank you ncmp. :good:

Actually I have a qt4 module but apparently not a good one. :wall:

Code: Select all

guest@porteus:~$ poptrayminus
Import error "No module named sip", please reinstall PyQt4 libraries
"sudo apt-get install python-qt4" may do the trick on Debian/Ubuntu
guest@porteus:~$ ls /mnt/live/memory/images/qt*
etc/  usr/  var/
guest@porteus:~$ ls /mnt/live/memory/images/
000-kernel.xzm/
001-core.xzm/
002-xorg.xzm/
003-jssouza-180702.xzm/
007-printing-x86_64-2018-02-23.xzm/
05-devel.xzm/
 :
PyQt-4.12.1-x86_64-2.xzm/
 :
 :
poptrayminus_1.2_all.xzm/
qt-4.8.7-x86_64-6.xzm/
 :
 :
guest@porteus:~$ 
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2103
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Re: Poptrayminus 1.2.0

Post#4 by ncmprhnsbl » 20 Feb 2019, 01:39

well sip is a separate package called sip , oddly enough.. (fair to say, debian/ubuntu packaging differs somewhat from slackware)
but yeah that pyqt package i linked is from slackware-current and you might be better off using 14.2 packages
(because the 'current' of porteus 4.0 release has moved on a bit since then, and 14.2 stays the same)
i recommend http://slakfinder.org for this sort of troubleshooting..
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Poptrayminus 1.2.0

Post#5 by Ed_P » 20 Feb 2019, 02:01

Code: Select all

guest@porteus:~$ poptrayminus
Import error "/usr/lib64/python2.7/site-packages/sip.so: undefined symbol: PyUnicodeUCS2_DecodeLatin1", please reinstall PyQt4 libraries
"sudo apt-get install python-qt4" may do the trick on Debian/Ubuntu
guest@porteus:~$ ls /mnt/live/memory/images/ | grep sip
sip-4.18-x86_64-1.xzm/
guest@porteus:~$ 
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2103
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Re: Poptrayminus 1.2.0

Post#6 by ncmprhnsbl » 20 Feb 2019, 03:30

most likely needs to be compiled for our python version/unicode encoding:
here's the source : http://server-pro.com/poptrayminus/popt ... 2.0.tar.gz
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Poptrayminus 1.2.0

Post#7 by Ed_P » 20 Feb 2019, 03:56

ncmprhnsbl wrote:
20 Feb 2019, 03:30
most likely needs to be compiled for our python version/unicode encoding:
:o Seriously!!

This is getting to be a little beyond my capabilities. :(
(I have never compiled a Python program before.)


-update-
http://server-pro.com/poptrayminus/ wrote:
Requirements

There are only three requirements to use PopTray Minus:

Python and PyQt 4.4 (required)
KDE or GNOME (recommended)
UIDL support on POP3 server (recommended)

PopTray Minus is written in Python using PyQt4 GUI libraries, so these two things are required. Fortunately, Python is already installed and PyQt4 is available for installation on the most Linux distributions. If you use Windows or Mac OS X your mileage may vary. If you are using Ubuntu 8.04 Hardy, you have PyQt 4.3 installed by default, but PopTray Minus requires version 4.4, please check this How To Install PyQt 4.4 for Ubuntu 8.04 hardy page.

Code: Select all

guest@porteus:~$ ls /mnt/live/memory/images/ | grep PyQt
PyQt-4.12.1-x86_64-2.xzm/
guest@porteus:~$ 
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Poptrayminus 1.2.0

Post#8 by Ed_P » 21 Feb 2019, 18:22

OK, I'm confused. https://askubuntu.com/questions/324871/ ... ython-file So how should I compile poptrayminus on Porteus?
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2103
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Re: Poptrayminus 1.2.0

Post#9 by ncmprhnsbl » 21 Feb 2019, 23:34

yeah, sorry, compiling not necessary:
seems to working with these packages: (all slackware-current)(in porteus 4.0 cinnamon)

Code: Select all

PyQt-4.12.1-x86_64-3.txz              
python-chardet-3.0.4-x86_64-3.txz  
qt-4.8.7-x86_64-11.txz
sip-4.19.8-x86_64-3.txz
and poptrayminus_1.2_all.deb converted to .xzm
python-chardet being that last missing package..
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Poptrayminus 1.2.0

Post#10 by Ed_P » 22 Feb 2019, 04:01

Around and around we go. :crazy:

Code: Select all

guest@porteus:~$ poptrayminus
Import error "/usr/lib64/python2.7/site-packages/sip.so: undefined symbol: PyUnicodeUCS2_DecodeLatin1", please reinstall PyQt4 libraries
"sudo apt-get install python-qt4" may do the trick on Debian/Ubuntu
guest@porteus:~$ poptrayminus
Import error "/usr/lib64/python2.7/site-packages/sip.so: undefined symbol: PyUnicodeUCS2_DecodeLatin1", please reinstall PyQt4 libraries
"sudo apt-get install python-qt4" may do the trick on Debian/Ubuntu
guest@porteus:~$ ls /mnt/live/memory/images
000-kernel.xzm/                     flashplayer-plugin-32.0.0.142-x86_64-1.xzm/
001-core.xzm/                       jre-8u201-x86_64-1.xzm/
002-xorg.xzm/                       libgc-7.6.8-alt1.x86_64.xzm/
003-cinnamon_x86_64-20190105.xzm/   poptrayminus_1.2_all.xzm/
05-devel.xzm/                       python-chardet-3.0.4-x86_64-1_slonly.xzm/
07-printing-x86_64-2019-01-13.xzm/  qt-4.8.7-x86_64-6.xzm/
AisleRiot-3.22.4-x86_64-don.xzm/    sip-4.18-x86_64-1.xzm/
PyQt-4.12.1-x86_64-2.xzm/           tree-1.7.0-x86_64-1.xzm/
firefox-60.5.0esr-x86_64-1.xzm/
guest@porteus:~$ 
Between the two poptrayminus runs I deactivated & reactivated the PyQt-4.12.1-x86_64-2.xzm module.
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2103
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Re: Poptrayminus 1.2.0

Post#11 by ncmprhnsbl » 22 Feb 2019, 06:04

dunno Ed, maybe you need the exact package from slackware current official (if not all those exact packages above)
python-chardet-3.0.4-x86_64-3.txz
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Poptrayminus 1.2.0

Post#12 by Ed_P » 22 Feb 2019, 06:45

Code: Select all

guest@porteus:~$ poptrayminus
Import error "/usr/lib64/python2.7/site-packages/sip.so: undefined symbol: PyUnicodeUCS2_DecodeLatin1", please reinstall PyQt4 libraries
"sudo apt-get install python-qt4" may do the trick on Debian/Ubuntu
guest@porteus:~$ poptrayminus
Import error "/usr/lib64/python2.7/site-packages/sip.so: undefined symbol: PyUnicodeUCS2_DecodeLatin1", please reinstall PyQt4 libraries
"sudo apt-get install python-qt4" may do the trick on Debian/Ubuntu
guest@porteus:~$ ls /mnt/live/memory/images
000-kernel.xzm/                     flashplayer-plugin-32.0.0.142-x86_64-1.xzm/
001-core.xzm/                       jre-8u201-x86_64-1.xzm/
002-xorg.xzm/                       libgc-7.6.8-alt1.x86_64.xzm/
003-cinnamon_x86_64-20190105.xzm/   poptrayminus_1.2_all.xzm/
05-devel.xzm/                       python-chardet-3.0.4-x86_64-3.xzm/
07-printing-x86_64-2019-01-13.xzm/  qt-4.8.7-x86_64-6.xzm/
AisleRiot-3.22.4-x86_64-don.xzm/    sip-4.18-x86_64-1.xzm/
PyQt-4.12.1-x86_64-2.xzm/           tree-1.7.0-x86_64-1.xzm/
firefox-60.5.0esr-x86_64-1.xzm/
guest@porteus:~$ 
Going to bed. :(


-Update-

This group works!! :Yahoo!:

Code: Select all

guest@porteus:~$ ls /mnt/live/memory/images
000-kernel.xzm/                     flashplayer-plugin-32.0.0.142-x86_64-1.xzm/
001-core.xzm/                       jre-8u201-x86_64-1.xzm/
002-xorg.xzm/                       libgc-7.6.8-alt1.x86_64.xzm/
003-cinnamon_x86_64-20190105.xzm/   poptrayminus_1.2_all.xzm/
05-devel.xzm/                       python-chardet-3.0.4-x86_64-3.xzm/
07-printing-x86_64-2019-01-13.xzm/  qt-4.8.7-x86_64-6.xzm/
AisleRiot-3.22.4-x86_64-don.xzm/    sip-4.19.8-x86_64-3.xzm/
PyQt-4.12.1-x86_64-3.xzm/           tree-1.7.0-x86_64-1.xzm/
firefox-60.5.0esr-x86_64-1.xzm/
guest@porteus:~$ 
The PyQt, python-chardet, sip .3 versions. :good:

Thank you :worship: ncmp. :beer:

NB While I get a window to enter Settings in terminal I also see:

Code: Select all

guest@porteus:~$ poptrayminus
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)" 
guest@porteus:~$ 
Will test more tomorrow.
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 4978
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Poptrayminus 1.2.0

Post#13 by Ed_P » 22 Feb 2019, 17:35

Added my ISP email account to Settings and it works. :happy62: :D

Now to find one for my gmail email account. :lol:
Ed

Post Reply