Porteus 4.0 NVidia 340.108 driver for older hardware for kernel 5.4.50

If you are looking for a specific 32-bit package and you can't find it in any of the 32-bit repos, please post a request for it here.
Post Reply
dorian_newton
White ninja
White ninja
Posts: 4
Joined: 04 Feb 2021, 02:10
Distribution: porteus

Porteus 4.0 NVidia 340.108 driver for older hardware for kernel 5.4.50

Post#1 by dorian_newton » 23 Feb 2021, 03:33

Any chance to get this for kernel 5.4.50?

Info by Rava
Since dorian_newton replied in the x86_64 xzm modules sub-thread to the post Porteus 5.0rc1 and rc2 NVidia 340.108 driver for older hardware for kernel 5.4.30 (Post by Rava #76838) I presumed he wanted a NVidia 340.108 driver for x86-64 Porteus kernel v5.4.50
Only in a later reply he told me he wants it for i486/i586 Porteus kernel v5.4.50.

Therefore this thread split.
Last edited by Rava on 25 Feb 2021, 10:42, edited 2 times in total.
Reason: added info explaining the thread split

User avatar
Rava
Contributor
Contributor
Posts: 2929
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

Porteus 5.0rc1 and rc2 NVidia 340.108 driver for older hardware for kernel 5.4.30

Post#2 by Rava » 23 Feb 2021, 16:26

dorian_newton wrote:
23 Feb 2021, 03:33
Any chance to get this for kernel 5.4.50?
Like I wrote
Rava wrote:
09 Apr 2020, 17:49
Finally managed to create it: the NVidia 340.108 driver for older hardware for kernel 5.4.30, compiled under Porteus 5.0rc1.
Kernel 5.4.30 is already newer than what is officially supported by the driver.
I would love to compile the needed NV drivers for even the most recent kernels, but me thinks without a competent 3rd party hack applied to the NV source that will not be possible, as I lack the needed skills in C coding to create such hack myself.

But please direct me to the Porteus kernel aka vmlinuz and its corresponding 000-kernel.xzm and the correct 05-devel.xzm with the same gcc compiler version that was used in creating the kernel, and the crippled-sources module and I will try creating a NVidia 340.108 driver for kernel 5.4.50.

All these are necessary in creating the NV driver, and it would not work when using a even slightly different version of gcc, so the requirement of the kernel and 05-devel having the very same gcc version either used in creating it (vmlinuz) or as binary (05-devel) is adamant. The NV driver is just that picky when it comes to that. Technically, you could compile the driver, get warnings by the driver creation software, and finally booting anew you would realize the driver would not work, so trying to compile it without the very same gcc version is futile.

I presume the kernel you want the NV driver for was created by either neko or blaze?
Cheers!
Yours Rava

dorian_newton
White ninja
White ninja
Posts: 4
Joined: 04 Feb 2021, 02:10
Distribution: porteus

Porteus 5.0rc1 and rc2 NVidia 340.108 driver for older hardware for kernel 5.4.30

Post#3 by dorian_newton » 24 Feb 2021, 04:43

I presume the kernel you want the NV driver for was created by either neko or blaze?
Yes

I need a complete 32bits porteus iso with nvida support (340.108)

I failed to assemble with existent isos and the files provided here

i'm not an expert in linux and seems to me very confusing all the stuff in this forum,

I need this for an old pc with geforce 9600 gt

Thanks for your help

User avatar
Rava
Contributor
Contributor
Posts: 2929
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

Porteus 5.0rc1 and rc2 NVidia 340.108 driver for older hardware for kernel 5.4.30

Post#4 by Rava » 25 Feb 2021, 10:17

dorian_newton wrote:
24 Feb 2021, 04:43
I failed to assemble with existent isos and the files provided here
but you can direct me to the forum post with the needed 4 files?
If the files are no longer available you would have to upload themselves.
Cheers!
Yours Rava

Post Reply