LyX 2.3.0 [Solved]

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
rych
Samurai
Samurai
Posts: 119
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

LyX 2.3.0 [Solved]

Post#1 by rych » 21 May 2018, 07:23

I think it's worth making a separate thread for this.

I'm looking for a LyX 2.3.0 built against Qt 5.9.5 of @jssouza (or for Qt 5.10 but then the Qt 5.10 itself is needed) with spell checking support. We have Lyx 2.3.0 thanks to @jssouza, which works on Qt 5.9.5, but, curiously, spell-checker seems to be disabled in his build.
Last edited by rych on 23 May 2018, 07:37, edited 1 time in total.

User avatar
wread
Module Guard
Module Guard
Posts: 1172
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v4.0-kde-64 bits
Location: Santo Domingo
Contact:

LyX 2.3.0

Post#2 by wread » 21 May 2018, 12:49

@rych
You can find LyX 2.3.0 in slackbuilds.org. Qt5.9.5 is in alien.slackbook.org/ktown/current/5/deps.
I myself use Latex for that purpose. Texlive for Porteus 3.2

If you cannot compile Lyx try Latex. It is FB...

Cheers!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

jssouza
DEV Team
DEV Team
Posts: 663
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

LyX 2.3.0

Post#3 by jssouza » 22 May 2018, 13:11

rych wrote:
21 May 2018, 07:23
but, curiously, spell-checker seems to be disabled in his build.
That's coz I just built the packages, saw it ran fine and created the module :) . I've never used lyx in my life. That's why I asked you to verify if everything is working fine. No problem, I created a new module for you for 4.0. Checked spell checking and it seems to be working (along with aspell, you also need the aspell-en dictionary). Included in the xzm are also mythes, hunspell and enchant. I have removed python 2.7, since it is now part of the base modules in porteus 4.0 and hence the module is much smaller :good:
You also need the qt5-base-5.9.5-x86_64-jss.xzm from here: Qt 5.9.5 for Porteus 4.0

Here is the link:
http://www.mediafire.com/file/barrt0ikv ... 64-jss.xzm
Please note, it is the same link as the previous lyx for v3.2.2, so the previous is overwritten.
Let me know if this works fine.

rych
Samurai
Samurai
Posts: 119
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

LyX 2.3.0

Post#4 by rych » 23 May 2018, 07:36

@jssouza, it's amazing how fast you can fix these things. Thank you, it works now with spellchecking! I had to activate additionally

Code: Select all

hunspell-en-2017.01.22-noarch-1_slonly.xzm
mythes-dict-en.xzm

jssouza
DEV Team
DEV Team
Posts: 663
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

LyX 2.3.0 [Solved]

Post#5 by jssouza » 23 May 2018, 13:31

Great :good:
You can merge these additional xzms to the lyx xzm and create a single module.

rych
Samurai
Samurai
Posts: 119
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

LyX 2.3.0 [Solved]

Post#6 by rych » 29 Sep 2018, 05:55

@jssouza, thanks for your LyX module it's been working great. They are now rolling out Lyx 2.3.1 https://www.lyx.org/Download. When/if you get a bit time could you update your module. Or else, teach me how you do this. If I'm capable of it at all, it felt like a quite sensitive process, getting the Qt5 dependencies right, spellcheckers etc. This is not urgent at all. Cheers.

jssouza
DEV Team
DEV Team
Posts: 663
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

LyX 2.3.0 [Solved]

Post#7 by jssouza » 30 Oct 2018, 12:28

Here you go, lyx 2.3.1, if you're still looking for the module:
http://www.mediafire.com/file/rsrgzeuq8 ... s.xzm/file

Creating this module was a little tricky, since Slackware has moved on since we created lyx 2.3.0 module and hence its dependencies have moved on as well. Please check if it works. You again, would need my qt5-base-5.9.5-x86_64-jss.xzm as before, as well as the dictionaries that you had to additionally activate.
Check if the spellchecker is working, I saw it was disabled, but then I checked on lyx 2.3.0 and saw it was disabled there as well..

rych
Samurai
Samurai
Posts: 119
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

LyX 2.3.0 [Solved]

Post#8 by rych » 02 Nov 2018, 05:36

@jssouza, Thank you once again: the new module works by replacing the old one, with spellchecker etc. and no problems so far.

Post Reply